Question about 1996 Cadillac Eldorado

1 Answer

96 eldorado the battery is good, i was told it could be the ignition coil or module.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    MVP:

    An expert that gotĀ 5 achievements.

    Master:

    An expert who has achieved Level 3.

    Sergeant:

    An expert that hasĀ over 500 points.

  • Master
  • 460 Answers

Thanks for that... but to confirm weather it is the ignition coil or the dynamo one has to take a closer look at the engines... so i request u to take it to a mechanic... but also what solution are u expecting from us...

Posted on Aug 13, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 96 Cadillac Eldorado want start no sparks from quoil


ensure coil is correctly connected, battery is okay? If the coil gives no power and is correctly connected it will need to be replaced
It cannot be repaired

Jun 05, 2015 | 1996 Cadillac Eldorado

1 Answer

Where is the ignition module in a 99 voyager


Hi Eric:
Also called Ignition Coil, is located at the back of the intake manifold...

2_11_2012_12_07_40_pm.jpg

Fig.: remove the 2 lower ignition coil mounting bracket bolts...


2_11_2012_12_08_55_pm.jpg

Fig.: then remove the ignition coil and mounting bracket together from the engine.

Disengage the wiring harness connector from the ignition coil.
Disconnect the ignition wire from the coil.
Remove the coil mounting bracket bolts, then remove the coil and mounting bracket assembly from the vehicle.
The ignition coil can be separated from the mounting bracket.

To install:

If separated, loosely mount the ignition coil to the mounting bracket.
Loosely install the coil and mounting bracket assembly to the intake manifold. Tighten the coil mounting bracket-to-intake manifold bolts to 115 inch lbs. (13 Nm) and the ignition coil-to-mounting bracket fasteners to 96 inch lbs. (10 Nm).
Connect the ignition wire to the coil.
Engage the wiring harness connector to the ignition coil.
If removed, install the windshield wiper/motor module assembly.
Connect the negative battery cable.

Hope this helps; also keep in mind that your feedback is important and I`ll appreciate your time and consideration if you leave some testimonial comment about this answer.

Thank you for using FixYa, have a nice day.

Feb 10, 2012 | Plymouth Cars & Trucks

1 Answer

Car died while driving, cranks, but won't fire, no communication with scan tool as far as engine or transmission. It will communicate with body.


did you say scanner not powering up or you not getting any code.because if engine not firing a faulty crankshaft position sensor or ignition module will cause no spark conditions.also check 20 amp ignition fuse to ignition coils and ignition module,check ignition battery feed 10 amp fuse to the pcm.check at the 16 dlc terminal at top ground terminal 4 that would be fourth terminal top from left to right.and check bottom far right terminal 16 see if you getting getting battery power.if fuse all good no power at terminal 16 your pcm could be getting poor ground contact or problem in the pcm thats not a home fix dealership has to run diagnostic scan test look for pcm fault or wiring fault.

Nov 29, 2011 | 1999 Cadillac Eldorado

1 Answer

96 licoln contintal no fire to plugs coils test good


Try the ignition module. You will need a special tool usually found in the tool section at Advance Auto. (ford ignition module removal tool)

Aug 17, 2011 | 1996 Lincoln Continental

1 Answer

My 1985 2.5 s-10 wont spray gas through the throttlebody but pumps from the fuel pump what would make it do this i can straight wire it to the battery and it will spray someone told me it could be the...


Using a test light, and with the ignition key in the "On" or "Run" position check for full battery voltage at the (+) positive side of the ignition coil, and then check for full battery voltage at the wire connector to the distributor for the wire that runs between the (+) positive side of the ignition coil and the distributor. (dis-connect the wire connector from the distributor to test) If full battery voltage is present at the (+) positive side of the ignition coil but not through the ignition coil to the distributor then replace the ignition coil. If full battery voltage is present at both the ignition coil and the distributor then remove the ignition module from the distributor to have it tested and most auto part stores will test it for you for free. The ignition module is what generates the signal that the ECM uses to time and fire the fuel injectors, and be certain that the ignition module is installed into the distributor using a silicone grease or some other die-electric compound to completely cover the metal mounting surface of the ignition module because it is a heat-sink, and be careful not to over-tighten the ignition module or it can be damaged. There is also a hall-effect switch inside of that distributor that would be the next suspect if the ignition module tests out alright, and if there is no spark there is a pick-up coil/stator assembly that could be faulty and if that is the case then replace the entire distributor because the distributor will have to be removed and dis-assembled to replace the pick-up coil/stator assembly.


zaraki_38.jpg

zaraki_39.jpg

zaraki_40.jpg

zaraki_41.jpg

Nov 30, 2010 | 1985 Chevrolet S-10 Blazer

2 Answers

Got fuel to the throttle body but still wont fire,


There is the possibility that the ignition coil is faulty and first check to see if full battery voltage is getting to the "Pos" (+) positive side of the ignition coil when the key is in the "Run" position, and also that full battery voltage is getting through the "Pos" (+) or positive side of the ignition coil and over to the distributor ignition module, dis-connect the wire connector from the ignition module and if battery voltage is not present at the connector to the ignition module with the key in the "Run" position but it is present at the "Pos" side of the ignition coil, then the ignition coil is faulty. If battery voltage is present then check the ohms between the high tension terminal (where the coil wire goes on the ignition coil) and the "Pos" terminal on the ignition coil by first dis-connecting the wires from the ignition coil and then test with the "Neg" lead from the ohm meter in the high tension terminal on the ignition coil, and the "Pos" lead from the ohm meter to the the "Pos" terminal on the ignition coil, and the ohm reading should be between 6,000 and 30,000 ohms and if not replace the ignition coil. A faulty ignition coil can also damage the ignition module.

The ignition module and the pick-up coil/stator located inside of the distributor is what generates the signal that the ECM (Engine Control Module) uses to time and fire the fuel injectors, as well as the signal to run the fuel pump and the dwell signal timing to fire the ignition coil, and a faulty ignition module can cause any one of these systems to malfunction.

That does sound like a malfunction with the ignition module inside of the distributor, and you can remove the ignition module and have it tested for free at most auto part stores. If the ignition module does test out alright then the problem could still be in the pick-up coil/stator, (it can be tested using an ohm meter by dis-connecting the wire connector from the pick-up coil/stator and the ohm reading between the two wires from the pick-up coil/stator should be between 500 and 1500 ohm's, and both of the wires from the pick-up coil/stator should show an open loop or an infinite reading between each wire and ground) and if the pick-up coil/stator is found to be faulty then replace the entire distributor, or the distributor will have to be dis-assembled to install a new pick-up coil/stator.

If you do purchase a new ignition module be sure that it does come with a silicone grease or a die-electric compound because it is a heat sink and the ignition module will burn up without it.

To install the new ignition module first clean out the mounting surface inside of the distributor. Then completely coat the metal contact surface under the ignition module with a thick coat the silicone grease or die-electric compound and do not leave any of the metal contact surface of the ignition module un-coated with the silicone grease or die-electric compound, and be very careful not to over-tighten the ignition module or it will be damaged.
The same principal applies to HEI (High Energy Ignition) ignition systems with the ignition coil mounted in the top of the distributor cap.

45ca149.jpg

da6d91b.jpg

Sep 21, 2010 | 1988 Chevrolet K1500

2 Answers

How to install ignition module on1995 buick


The ignition module is under the coils. It is what the coils plug on to. To replace it removal all the coils and unplug it.

Jul 31, 2010 | 1995 Buick LeSabre

1 Answer

96 suburban , firing problems


Disconnect the ignition coil module connector.
  1. Probe the ignition coil module connector terminal with a voltmeter to ground.
  2. With the voltmeter on the AC scale, crank the engine.
  3. Monitor the voltage reading.
Is the voltage reading within the specified value?
1-4 V if not replace ECM


Aug 24, 2009 | 1996 Chevrolet Suburban

1 Answer

98 eldorado


The ignition coils plug into it! MoDule

Apr 24, 2009 | Cadillac Eldorado Cars & Trucks

1 Answer

77 ford truck


i had a 1975 f-100 v8 i changed coil and wires. cooked module. speed shop told me make sure i remove battery cables from battery first. hope that will help best i could throw your way

Dec 26, 2008 | 1982 Ford F 250

Not finding what you are looking for?
1996 Cadillac Eldorado Logo

Related Topics:

96 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cadillac Experts

yadayada
yadayada

Level 3 Expert

61249 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Cadillac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...