Question about 2007 BMW 525xi Sedan

1 Answer

5 series 95M 520i se auto, hesitation on take off from stand still only, runs fine through gears. When in park if accelerator is pressed very quickly will almost stall so same on take off from stand still, idle all ok but can hear like a suction noise if bonnet open if i try to rev it up quickly. Many thanks

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 17 Answers

Sounds like youve a split in one of your hoses or one of the couplings is loose.check every thing that intakes air. thoroughly not just a quick look, hope this helps

Posted on Aug 13, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have 2015 VW Passat 6 Speed Automatic I am havinf hesitations/delay froma dtopped postion for around 3 seconds when you press the accelerator ? Poblems I know. Suggestiobs ?


Volkswagen Passat Hesitation Issue - Edmunds

forums.edmunds.com > Volkswagen > Volkswagen Passat
Learn more about Volkswagen Passat at the Edmunds.com Car Forums! ... I amconfused by (1) a bit: I saw the acceleration number is very good (3 sec to 30 miles;.... I've tested 5 series and they do indeed have this lag, but with the 6 speed ...Anyone having the hesitation issues with your 3.6, the software fix works and you .
Acceleration lag [Archive] - Volkswagen Owners Club Forum 'VW Golf ...volkswagenownersclub.com/vw/archive/index.php/t-23192.htmlDec 18, 2010 - 42 posts - ‎18 authorsHas anyone else notice a lag when you first step on the gas pedal from a stop? ... It is the delay from when I push the pedal, I find an acceleration lag. ... I have a 2011 SE 5speed and I have the same thing as you. ... Top gear quotes? ... Lifting the foot from the brake, I take 3 seconds before stepping on the ...Passat MAF, problems with the MAF sensor, Mass Air Flow ...https://2urbietorbi.wordpress.com/2008/.../passat.../comment-page-1/

Feb 03, 2016 | Cars & Trucks

2 Answers

2009 toytoa tacoma 2.7 lt rear wheel drive shake on ideal while in gear


1st things first. What fault codes do you have in memory from the diagnostic port? Buy a code reader and check that.

Mar 17, 2014 | Toyota Tacoma Cars & Trucks

1 Answer

My 1995 jeep grand cherokee laredo 4.0 inline 6


Something mechanical, ignition, or fuel.
It can run rough under a load such as in gear and ok in neutral with no load. Have you checked the plugs and dist cap ?

Feb 11, 2014 | Jeep Grand Cherokee Cars & Trucks

1 Answer

2001 nissan sentra 1.8L 4cyl. running codes P0105:P1605:P0171:P0325... engine idles fine when in park just not in gear, in gear it shakes pretty bad, also hesitates to accelerate when you press on gas...


code po105 refers to manifold absolute pressure(MAP)sensor/barometric pressure (BHARO) sensor -circuit malfunction==causes--wiring MAP sensor--BARO sensor--ECM
code p0171 refers to system to lean bank 1===causes intake/exhaust leak---AIR system MAF/MAP sensor fuel pressure /pump /injectors--HO2SW
code p0325 refers to knock sensor(KS) 1 bank 1-circuit malfunction====causes--wiring ---poor connections---KS
Check the exhaust flexible pipe at the manifold for cracks
have a fuel pressure test done on the fuel manifold to determine either pump/ filter or pressure regulator.
replace HO2S unit

Sep 21, 2013 | Cars & Trucks

1 Answer

Driving 328I into parking garage and here a slight click and accelerator no longer working. Car starts fine goes into every gear but no accelerator. Could this be a cable issue?


yes it could be, just check entire cable to throttle body, it could be broke. I dont know if this is a dealer item. but you can get a new cable cheaper at a auto parts store. good luck!

Jul 14, 2010 | 1999 BMW 328 Series

1 Answer

Very poor acceleration through all gears


diesel pump might not be working right. Try and check fuel pressure. I dont know if its turbo but if the turbo is failing then you will loose power

Feb 05, 2010 | 2006 BMW 5 Series

1 Answer

'93 Celica GT 2.2L w/ Auto Trans. hesitates, jerks


hi,

sounds like a vacuum leak, injectors clogged, bad plugs, plug wires or maybe low tranny fluid or combo one all, have it dynoed to save yourself some money of course.

good luck

J

Jun 29, 2009 | 1993 Toyota Celica

1 Answer

1988 buick park ave problem


1. clogged or partially clogged fuel line 2. clogged fuel filter " note some models have more then one but it is usually the inline filter" 3. bad spark plugs...they could be burned or not gapped right" 4. bad injector's' I hope this helps you....if not consult a local mechanic.

if still does not help
Have vehicle scanned to determine the problem .

good luck
thanks.

Oct 26, 2008 | 1989 Buick Park Avenue

Not finding what you are looking for?
2007 BMW 525xi Sedan Logo

Related Topics:

169 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Fred Sops

Level 2 Expert

271 Answers

Al Clark

Level 2 Expert

290 Answers

Doberman

Level 2 Expert

246 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...