Question about 2000 Mitsubishi Eclipse

1 Answer

Heating my eclipse gs 2000 has been working fine but after putting my car in storage for deployment and getting it back my heater is not working, it just blows cold air and no heat comes out at all, i cant seem to figure out the problem.

Posted by on

  • Anonymous Dec 09, 2008

    my 2000 mitsubishi eclipse GT had a radiator leak ,and i bought a new one and replaced it and after that my heating system does not work

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 60 Answers

Look at the temp rheostat on the a/c control

Posted on Aug 12, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Picture diagram for 2000 eclipse spark plug to distributer


According with engine sizes, check this for 2000 Mitsubishi Eclipse GT 3.0 liter SOHC V-6

zjlimited_399.gif



or 2000 Mitsubishi Eclipse GS 2.4 liter SOHC L4

zjlimited_400.gif

Hope helps.

Apr 29, 2011 | 2000 Mitsubishi Eclipse

1 Answer

Panel lights


you unplugged the wiring for the panel lights or blew the fuse

Mar 03, 2010 | 2000 Mitsubishi Eclipse

1 Answer

2000 eclipse heater - swithch on HOT, doesn't put


make sure heat temp. control pot inline on one of the heater hoses is functioning properly by looking at it while someone inside the car is moving the selector switch slowly from cold to hot several times, you should be able to see or feel the valve moving. if not, check for vacuum at the pot by removing the hose from the pot and holding your finger over the end of it, you should be able to feel the vacuum with your finger. if there is no vacuum check the line for cracks/dryrot, if theres none the switch is prolly bad.if the pot is working make sure coolant level is full, if it is low there wont be sufficient hot water pushing thru the heater core

Nov 14, 2009 | 2000 Mitsubishi Eclipse

2 Answers

No heat,engine temp.is normal


the valve that allows the hot water into the heater core is not opening. most likely electronic issue. also check all vacuum and electric lines.

Nov 03, 2009 | 2000 GMC New Sierra 1500

1 Answer

2000 eclipse gs no horn on alarm and locking


Have you tried resetting the alarm, or even disconnecting the car battery and reconnecting it... also make sure all doors and trunk lid is closed

Aug 04, 2009 | 2001 Mitsubishi Eclipse

1 Answer

Coil not firing on 2 cly


Not sure what size of motor you have so please choose what you need:

1999 Mitsubishi Eclipse GS
2.0 liter DOHC L4

6045609.gif
1999 Mitsubishi Eclipse GS-T
2.0 liter DOHC Turbo L4


ac4a9fa.gif

1999 Mitsubishi Eclipse GSX (AWD)
2.0 liter DOHC L4

8a697b1.gif

Mar 17, 2009 | 1999 Mitsubishi Eclipse

1 Answer

Heating in a 2000 Mitsu Eclipse GS wont work


the heat system on most vehicles use the same basic technologies,using the hot water that coming from an running engine to produce hot air inside car to keep you warm ....to start please ck if the heater core lines are propely atached to the core outlets , ck if they arent not crossed,ck if they arent not cruched ,plugt ,by passed ,ck the valve for openning and closing propely, ck for a good workin thermostat ,plenty of fluid in the radiator cap sealed no leaks/ make shure the blower fans is working propely.......nicolas.....

Dec 21, 2008 | 2003 Mitsubishi Eclipse Coupe

3 Answers

2003 Mitsubishi Eclipse GS blows cold air in heat mode.


ok here we go and you aren't going to believe it...
I replaced the thermostat step one

I noticed that I had a small leak at the engine side of upper hose fixed that by taking it off and cleaning it and putting the hose back on Step two

then while refilling the reservoir with coolant i found that the hose that was supposed to be in the fluid was curled up on top and not sticking down in the fluid where it should be.
played with the hose until i got it to fall down in the reservoir where it should be Step 3

I started the car with the radiator cap off and let it run until it got to normal operating temp. and keep filling the radiator with fluid until the level stayed constant. Then put the cap back on and test drove. Everything worked fine haven't had that much heat in awhile and it kept blowing hot even when i stopped and let it idle for ten min.during test drive. Checked reservoir when I got home and had to add a small amount of coolant but not much.

I really think that the hose in the reservoir not being in the right place and pulling air into the system instead of coolant is the real culprit of this drama, but i replaced the thermostat to be safe.

Nov 16, 2008 | 2003 Mitsubishi Eclipse Coupe

Not finding what you are looking for?
2000 Mitsubishi Eclipse Logo

324 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

61037 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...