Question about 2004 Chevrolet Suburban

1 Answer

My Suburban won't start

I thought my Suburban had a bad battery or loose connection, but the battery and connection was fine, but i gave it a boost anyways, and it still didn't start, I looked through all the wires and they were fine, and I got to the fuse board under the hood and was very confused

Posted by on

1 Answer

I open the doors and the inside lights do not come on.

Posted on Aug 31, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Won't start no power anywhere battery tested ok and power to starter. What is up?


Could be bad or dirty battery cables or loose so no power getting through to the motor. My cables were tight but they were corroded and had no power any where. I put new cables on the pos and neg side of battery and everything worked after that. Even tried to boost and no power would go through.

Feb 08, 2015 | 1994 Chevrolet Suburban

1 Answer

Loud clicking sound when i try to tunr it over


boost, hummmmm ?????????????
a charger with a boost button? (big shops have this)
or you mean jumper cable , jump started from a running other car?


my wild guess. is you always start fine, when jumper cable jumped.
this proves, the
battery in your car is BAD or is only discharged.
for 100 years now, same deal.
try a fresh battery off a good car.
works now, so ??? yours is weak or bad!

but started car , is the voltage 13.3. to 15v? a walfart $10 meter.?
no , then the charge system is bad (charge lamp on?)
note, i said system. not a specific part.

if the charge system is failing.?
  1. bad battery. tha'ts right alts do shut down with battery bad. (open or shorted battery)
  2. loose alternator pulley belt.?
  3. bad alternator wires. connections.? or bad battery cables.?
  4. scan the PCM most 2007 will report what is wrong with voltages and charge. scan it.
engine rpm way below normal at idle 800 is typ. good. 400 dead wrong.
battery cables bad.
battey cables lugs green with corrosion
someone put the minus cable far end to the wrong part>?
this minus cable has correct spot near the starter.
some fit to block others to stater , bolt or bell blots.
to frame is wrong, seen that , with lazy work.



Feb 11, 2014 | 2007 Toyota Tacoma

1 Answer

98 Suburban won't start. Ran fine one day, next day nothing.


You should check your fuel pressure with a gauge. If these trucks don't get enough pressure (55psi, i think), the injectors will not open.

Feb 08, 2013 | 1998 Chevrolet Suburban

2 Answers

MY CAR WANT START BUT ONLY WIT HA BOOST


i would try a new starter first. take it off and go to your local automotive part store and have them determine wether it is bad or not. if thats not the problem then it could possibly be the alternator, my best friend had a dodge dakota that did the same thing you are describing and came to find out the person he had just bought the truck off of put a new alternator on the truck but it was the wrong amp alternator for that truck. he got the right one and truck is just fine now. make sure you check the power and ground connections on your battery before you do any of this stuff, sometimes the connections can be loose. good luck

Jan 07, 2013 | 2001 Cadillac DeVille

1 Answer

Suburban won't start, bought a new battery but does no thing, when jump started it stays running until it is shut off and will not start again


If you can jump start it and it stays running....I am assuming that you connect the Jumper Cable Ground to something other than your battery. If so, Your negative battery cable is suspect. Check both ends for ANY corrosion or loose connections.

Aug 18, 2011 | Chevrolet 1500 Cars & Trucks

3 Answers

Have a 1991 or 1995 Intrepid and car died, tried to boost the car gave it power than died, we noticed corrosion on the posts so cleaned the posts. (Noticed lights and power was coming back on when...


did it stay running when connected to the car giving the boost? if so then the alternator is not charging the electrical system, get it serviced or replaced.

Feb 25, 2010 | 1996 Dodge Intrepid

1 Answer

Every 3 or 4 days my 1999 Ford Escort won't start


the alternator may be bad...replace it and you should be fine

Feb 16, 2009 | 1999 Ford Escort

Not finding what you are looking for?
2004 Chevrolet Suburban Logo

Related Topics:

60 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

63990 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...