Question about 2005 Mitsubishi Lancer Evolution

2 Answers

I think its an electrical problem...

My '05 Evo VIII will start unless you jump it off or charge the battery. Think its either a short or cut wire or a bad battery. I had this problem a few weeks ago and replaced the alternator because the battery checked out fine. About a week later all the lights inside and out would flicker when you pressed the gas. And now a few weeks later the problem is back- my car shuts off. I have a mini battery kit on it so im not sure if the battery is the problem. When i get the car started it will run for appx 5 mins and then all my guages get weaker, then turn off and then whole car shuts off. I had a loose cable on the alternator which i tightened and that didn't help. I have an air/fuel ratio guage made by innovative motorsports and i know when the car is going to shut off because the guage begins to say E9. Its an error 9 message which means(off there site) : Error 9 Supply Voltage too low Supply voltage too low for
sensor regulation

Twice tho i have gotten an E 4 code where the car ran fine. It means:
Error 4 Pump cell circuit open 1. Damaged sensor cable or
sensor connector not fully
seated
2. Sensor heater calibration
incorrect



I'm not sure what the problem could be but if anyone can offer any suggestions at all i would appreciate it. Thanks.

Posted by on

  • kirkd127 Aug 15, 2008

    Never mind. I figured it out.

  • kirkd127 Sep 12, 2008

    no it was a bad alternator again. i replaced it but now all the lights flicker- the headlights, the dash, the consol, inside lights, etc. I believe its just a cheap alternator. Its a pain in the **** to put in so i got raped for installation so they got a cheap alternator from autozone. It is $70 when everywhere else is around 250. I had it tested and was told that it charges at 14.27 but random jumps around and spikes between 16-17. The battery is an odyssey pc-680. I talked to an odyssey tech and he said that the battery can't take over 15 or it gets burnt up. I think that my battery is getting fried and making the lights flicker but im still not 100% on that. And i dont want to drop alot of money again and the problem come back.

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

Your problem sounds like your main ground harness that goes to your frame find this ground take it off clean the terminal and the area the ground is connected with sand paper then put it back together if that dose not work check your starter make sure the ground and positive nuts are tight these problems will cause what you have.

Posted on Jul 20, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Habit-Forming:

    Visited the website for 3 consecutive days.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 111 Answers

Was it a draw?

Posted on Sep 11, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My battery keeps draining it wont start without a jump start and dies if I turn on head lights or use my blinkers. Somebody recently stole my stereo I think a wire maybe arching and draining my battery how...


Have you replaced your battery yet? Sounds like you have a bad cell in your battery basically your battery is not holding a charge. It sounds pretty bad too because typically the alternator will keep it somewhat going while you are driving. When you put you're lights on its drawing a higher load on the battery and killing it. Does not sound like an "arc" of any type. I think you mean a short to power. That could be a possibility especially if you run through alot of batteries on that car. Normally like one every 4 years or so, give or take would be normal. Before you go running chasing short to grounds, check your batt terminals and corrosion on the power and ground wires.

Oct 19, 2013 | 1991 Mazda Protege

1 Answer

We have an aftermarket car alarm installed, but have lost the remote. Our battery died and when we jumped it, the alarm reactivated itself and now we can't turn it off! We cannot start the vehicle unless...


I don't think that the alarm can be bypassed once installed. So you'll have to contact the aftermarket car alarm installer that put it in to try to get a new fob that will work with it, or else have it uninstalled by an alarm dealer.

I think the wires need to be traced to deactivate the alarm system, one way or another, because most alarms cut into the ignition or start wiring to prevent the vehicle from running.

Aug 09, 2010 | Chevrolet TrailBlazer Cars & Trucks

1 Answer

1 have a 1986 caddilac deville i have to jump start it everyday it runs fine after the jump start but soon as i cut the car off it wont start anymore until i jump it again what do you think is the problem


Have you checked your battery???
A bad battery will not hold a charge. When you jump it to start it it will then keep running on the power produced by your alternator.The alternator will be trying to charge your battery but will not be able to if your battery is bad.

Mar 03, 2010 | 1989 Cadillac Sedan DeVille

1 Answer

1996 Mark 8 Radio cuts out


You may have a short that is slowly frying your electrical system. Make sure there aren't any loose wires and then replace your Amp.

Aug 11, 2009 | 1996 Lincoln Mark VIII

1 Answer

Electrical Short???


Has the stereo been changed recently? If not move to the cigerett lighter. These two are most likely the prob. But you could have a bare wire anywhere grounding out. Good luck and hope you find it.

Jul 26, 2009 | 1996 BMW 318

2 Answers

When trying to start the car it makes a weird sort of ticking/buzzing noise. i think it may be the voltage regulator. how can i tell if it is or not?


If there is only this noise and enginr not turning then would suggest you either have a loose battery cable or battery is dead. If the battery is dead then you need to find out why or it can happen again. common reasons are,< lights left on,battery is bad,charging system failure,battery terminals corroded and have weak connection, electreical short,etc.in any case you need to charge battery, < battery charger or jump start>,if you jump start car make sure you attach gruond wire from cables to metal surface of your vehichle to prevent electrical problems. would suggest if it isn't obvious reason,< terminals,lights left on,or something of this nature > take it to someone who can tell you why because most likely will leave you stranded somewhere with dead battery again. The regulator only operates with motor turning and shouldn't prevent starting engine,but can effect charging battery.

Apr 23, 2009 | Toyota Tercel Cars & Trucks

1 Answer

Have 1994 Cadillac Eldorado won't start without jump


Check the NEGATIVE battery cable from the battery to the ground pont

Feb 27, 2009 | 1994 Cadillac Eldorado

1 Answer

Lincoln Mark VIII wont start


if you tried to jump the veh. when the batt. died, then you may have fried a fusable link in the harness. use a test lite to (CAREFULLY) look for voltage leading away from the batt. also you may want to check and see if someone can hear the relay click on as you try to start. (it is sometimes hard to hear it, so you want minimum back ground noise). good luck!

Jan 09, 2009 | 1994 Lincoln Mark VIII

Not finding what you are looking for?
Cars & Trucks Logo

165 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

60867 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...