Question about 2004 Audi A4

3 Answers

Audi A3 2002 model auto - temperature gauge not working

Hi all,
just bought an audi a3 2002 model and the temperature gauge is not working, any ideas on how to troubleshoot this ??

thanks in advance.

Posted by on

  • cesarnz Aug 11, 2008

    ok found something interesting, while i was driving my car to a friends place in order to check out the suggestion you made i noticed the temp gauge which had been sitting on 60 deg. went up to the half way mark (90 deg) for about 10 minutes and then dropped back down to 60 !!!

  • gpina Oct 07, 2008

    I have a used 2003 A4 and the temperature sensor did not work at all. I replaced the temperature sensor and noticed the problem of the car running at 60 degrees, I put in new themostat thinking it was stuck open, problem is still there. If I drive the car and shut it off and start it the temperature guage will be at 90 degrees. If I drive the car on the open road the guage will drop to 60 degrees. The mechanic thinks now it might be softare problem where the variance is to small.



3 Answers

  • Level 1:

    An expert who has achieved level 1.


    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

How do I locate the sensor on a 2003 A4 1.8L? I see a blue sensor on the right by the firewall, and a green sensor on the left nearer to the battery on the left. Is it possible that I already have a green sensor in my car?

Posted on Nov 23, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 20 achievements.


    An expert that got 10 achievements.


    An expert that got 5 achievements.

  • Master
  • 1,586 Answers

Change the coolant temperature sensor. They're known problem areas on other Audi models, including my A4. The part runs about $20 from and it's the problem probably 75% of the time. If that's not a fix, it could be a thermostat that is stuck open and causing the gauge to never read warm.

Posted on Aug 11, 2008

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 1 Answer

I'm having the same problem and when I put it on the diagnostics it said that the Temperature gauge on the cluster isn't reading it or something like that. The thermostat and sensor are functioning properly, if they weren't the fan wouldn't turn on. I'm having problems finding the gauge, part of the cluster.

Posted on Jan 18, 2013

  • Elie Daher Jan 18, 2013

    I'm having the same problem and when I put it on the diagnostics it said that the Temperature gauge on the cluster isn't reading it or something like that. The thermostat and sensor are functioning properly, if they weren't the fan wouldn't turn on. I'm having problems finding the gauge, part of the cluster.


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

My car is over revving going to 1000 rpm at idle what is it please help Audi A3 s line 2.0 tdi

Revving on Idle ' > ... > A3/S3/Sportback (8P Chassis)
Feb 1, 2012 - My Car 58 S3, as of last night decided to start revving whilst on idle, I found a clip ... I can do or is it going to be a trip to audi for them to pull my pants down! ... Lots of members all over the UK have VCDS, have a look at the VCDS .....and as the engine warms up it'll auto-rev to 1000rpm every time i sit at idle. Car revving itself on idle ?
Sep 23, 2013
Whining noise when accelerating, any ideas?
Mar 15, 2012
More results from

[FIXED] Audi A4 RPM Idle Problem - YouTube

? 2:48
Feb 5, 2011 - Uploaded by RickyTomatoes
[FIXED] Audi A4 RPM Idle Problem .... whole lot more and sometime i can even feel like the engine is just gonna die. sometimes it does it some other times it does ... Our cars shouldidle at 900. ... AUDI A3 1.6 IDLE PROBLEM!

When getting into first gear, is revving to 2000 RPMs before ...

RedditSep 3, 2014 - When getting into first gear, I bring the revs up to around 2000 RPM right ... Being able to get going without any throttle is fairly dependent on car size and ...Thats how I have a 300,000 kay clutch still on my audi with no slippage. ... Clutches ought to last well over 100,000 miles if they are not abused, and ...

Revs going up and down while car is stationary - > ... > Audi Models > Audi A4 > B7 Models

Jan 21, 2016 | Cars & Trucks

2 Answers

Why does Temperature gauge reads hotter then normal but engine temp. is ok

some times after market senders read hotter if there not quiet the same value

Aug 15, 2014 | 2002 Audi TT

1 Answer

96 honda accord lx temperature guage not working

Hi Stephan,your coolant temperature switch could be bad,here's a link to it.

Mar 20, 2013 | 1996 Honda Accord

1 Answer

No readout on outside temperature gauge on dashboard - sensor behind front bumper seems intact and works on another audi

I have the same problem few days ago, and still didn't find any solution. Can any one please help?????8

Jul 28, 2011 | 2005 Audi A3

1 Answer

2006 A3 The interior is slow to heat. The temperature gauge reads low (at the bottom of the scale). The check engine light just came on. I bought this a3 used last week.

put your hand onto the top hose or the radiator top to feel the heat (if any)if its cool to the touch,then first change the thermostat.not forgeting to vent the system after to release any trapped air.

Feb 12, 2011 | 2006 Audi A3

1 Answer

The rear speakers do not work in my audi A3, apparently its an optional extra. is there wiring in place and is it simple to connect

My 2002 Audi S3 non bose passage rear side speakers is not working, I have checked the fuses and all is ok but still not working.
Does anyone have any ideas of what the problem will be?

Feb 25, 2010 | 2007 Audi A3

Not finding what you are looking for?
2004 Audi A4 Logo

3,493 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audi Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers


Level 3 Expert

77932 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14403 Answers

Are you an Audi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides