Question about 2002 Nissan Maxima

2 Answers

Car won't run faster than 20 miles today.

I can't drive faster than around 20 miles. When I try to press harder on the gas pedal it doesn't seem help. It can be Fuel Injection problem, the Service Engine light indicator was on and off for a few months,

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

I just had a similar problem where my car wouldnt go over 50. i ended up changing the trans filter and had no problems . just a suggestion

Posted on Aug 12, 2008

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 22 Answers

Try to replace the fuel pump. then check the fule injector if it is clogged by dirt.

Posted on Aug 12, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Gas pedal acts like brake?


Could be plug catalytic con.

May 08, 2013 | 2000 Saturn SL2

1 Answer

My automatic transmission car is having difficulty to pull forward


take the car to autozone and have the fault codes read
that will give codes that you can have repaired

Mar 21, 2017 | 1995 Toyota Corolla

1 Answer

I have a 2000 GMC Jimmy that has around 93,000 miles on it. The last oil change was 2 weeks ago. Today, on a trip on the interstate, I pulled off to have dinner. When I left the restaurant and started...


If the trucks engine rev'd up when you first put the gas pedal down, but didn't go anywhere then it was probably in neutral (not drive as you thought). If it was in drive and still didn't go anywhere but engine still rev'd up then its a transmission issue or PRNDL switch at the side of the tranny. I can't see anything relating to the gas pedal by NOT reving up the engine when it was pressed down. I wouldn't suspect a throttle cable issue. Check the tranny fluid while truck is running in park, see if the fluid is badly burnt or low on the dipstick. If it looks good I would have the PRNDL switch checked. (Park Reverse Neutral Drive and Low) switch.

Jan 31, 2011 | 2000 GMC Jimmy

1 Answer

When pulling into a parking stall the car raced forward


try removing the floor mat.. sometimes the mat gets caught on the gas pedal and as you apply the brakes it applies the throttle. It would seem that the harder you press the faster the engine races...

Jul 08, 2010 | 2000 Buick Century

1 Answer

My 89 Camaro has sat through the winter, and now after getting it started and "freshend" up, I am having major problems driving it. It idles and goes into gear fine, and the RPMs raise normally when I rev...


If you car has been sitting for that long of a period it may have water in the gas. Water is heavier then gas and will block your fuel filter which will cause you to loss power because of lack of fuel, as the water runs down/off the filter it always gas through then will block it again. Try some stp fuel treatment, read bottle to make sure it drys up water in the gas. Add some more gas after emptying the fuel treatment to your gas. problem should clear up.

Jun 02, 2010 | 1989 Chevrolet Camaro

1 Answer

Started car this afternoon for short errand. Drove 8 miles to store and when ready to leave store car would not crank, engine would spin but would not start. Waited about 20 minutes checking under hood for...


Clutch pedal switch would not let the starter to operate. So you can eliminate that. Possibly the fuel pump.or it was momentarily flooded. When you pushed the accelerator pedal whaile cranking you were allowing more air into the engine, thereby blowing the excess gas thru and out the engine.I would have it checked for correct fuel pressure and any vacuum leaks.

Jan 16, 2010 | 1988 Toyota Camry

1 Answer

Shakes and cuts off


What motor, how many miles, and what maintenance has been done?

Mar 07, 2009 | 2003 Chrysler Concorde

2 Answers

I have a 2002 Saturn s-series sc2 3door coupe


crank sensor located behind engine, cost at advanced auto 21.00 dollors.

Feb 22, 2009 | 2002 Saturn SC

Not finding what you are looking for?
2002 Nissan Maxima Logo

107 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

70387 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

705 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...