Question about 1996 Chevrolet Astro

1 Answer

1996 chevrolet suburban 1500

I had a crank sensor code, crank and cam not matching. Then came out and would not start. Ran the battery down, changed the crank sensor, had to buy new battery, still won't start. Can get one good sounding fire and then nothing. Compression is over 150 while cranking, have spark and fuel. Any ideas ??

Ken

Posted by on

  • IFiXhouston
    IFiXhouston Aug 10, 2008

    Thanks, that was my next purchase. I will check it out and let you know.



    Ken

  • IFiXhouston
    IFiXhouston Aug 14, 2008

    Camshaft sensor on the distributor and an ICM connecting to the coil. ECM is the computer on this model. I hope you are suggesting one of the other two items. I am going to purchase those two and a new coil for kicks. I believe this should solve the problem, what do you think?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 2,920 Answers

Check the ecm on the distributor..it may have fried when you had the sensor pop out

Posted on Aug 10, 2008

  • Ronnie Houston Aug 14, 2008

    i believe between the three you should have the problem covered

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1993 Chevy Suburban will not start and has no spark


Check all fuses under the hood. Test the coil with an ohmmeter. Check for battery voltage on the coil primary with key on.
If all good, suspect the crank position sensor. A bad sensor will cause no spark.

Nov 19, 2013 | 1993 Chevrolet Suburban

1 Answer

Will not start


check crank position sensor. check cam position sensor. Have the fault codes read for fault. Check key battery is not flat causing the immobiliser not to work.

May 03, 2013 | 1996 Chevrolet K1500

1 Answer

2001 crankshaft sensor changed now car want start


If the store pulled the codes and it had a code for the crank sensor, the real problem could be a bad cam sensor or a problem with the crankshaft. The crank sensor "sees" a mark or magnet on the crank and sends a signal to the computer. The computer takes that signal and compares it to the cam sensor to start the engine then runs off of one or the other. It sounds like the computer is not seeing the two signals match up.

Jun 24, 2012 | 2001 Chevrolet Cavalier

1 Answer

I have a 96 suburban and it want start just turns over, so I replaced the fuel pump and still nuthing, someone said cam sensor, but what about a crank sensor? How can I tell with no engine light on for a...


check for spark at the plugs..if you have spark..get some auto mobile starter fluid ..spray some in engine intake.. if engine starts ..you have a fuel deltvery problem..that should narrow your your problem down..your fuel pump might be good..there are other parts in your system that will cause pump not to work.. such as plug fuel filter/pump relay..ecm..fuel pump fuse etc..take it one step at a time..guessing is costly

Sep 13, 2010 | 1996 Chevrolet Suburban

1 Answer

I have a 1996 camaro, 3.8. Have really been having alot of problems, idle seems low, i get a code P300 ( random misfire) and a Cam shaft sensor code, I replaced the cam sensor 2 times, changed the plugs...


you can disconnect the battery for about 2 min and that should clear any codes that are stored in in it or take it to autozone or someplace that will erase the codes for you i hope this helps

Apr 11, 2010 | 1996 Chevrolet Camaro

1 Answer

I can here the fuel pump running but it wont start 1998 chev k1500 4.3v6


It may be the cam position sensor or the crank position sensor

May 27, 2009 | 1999 Chevrolet Silverado 1500

Not finding what you are looking for?
1996 Chevrolet Astro Logo

Related Topics:

167 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

64052 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...