Question about Chevrolet Silverado 1500

1 Answer

2004 Sliverado, 2x2, 30,000 miles on it. Just bought it off a dealers lot, 2 months ago. Just clicks when trying to start. Battery is Amco, tested okay. How do you know if it is a starter ?? How much do they cost to repair.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 56 Answers

If it just clicks one time each time you turn the key it sounds like the starter is bad. If you do-it-yourself you can replace it for around $100 . Add another 100 or more if you have it replaced somewhere. Make sure you disconnect the batt before removing the starter and just make sure the wires are back in the same place they came off of and it is a simple project. The auto parts store can also check your starter before you buy a new one. If it makes a lot of more like buzzing or a bunch of clicking you should make sure your cables are clean and tight before buying a new starter. Hope this helps.

Posted on Aug 09, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Chrysler Town & Country minivan. Two month ago I rebuilt a transmission at AMCO. Now my speedometer shows speed 10 to 15 miles faster than actual speed. AMCO refuses to fix it. Any idea...


Chrysler products allow you to program the computor for the tire size on the vehicle. I have no idea how this could have been altered, but find someone with a scanner and have them give that a shot.

Sep 04, 2011 | Chrysler Town & Country Cars & Trucks

1 Answer

I have a 2000 S Type with 100,000 miles that I bought about 4 months ago. Within 2 weeks of purchase, the Failsafe engine light kicked in and went straigh into "limp home mode" I did some...


the best thing to do is to have the car scaned with the diagnostic computer to see what fault codes are stored.
acording to the fault code you'll be able to work out what's wrong with it.
I'm sorry i ca't be anymore helpfull.

Jul 25, 2011 | 2000 Jaguar S-Type

2 Answers

Hello i have a 2004 expedition , and i have been having issues with my battery draining. about a month and a half ago i went away vacation , came home to start my truck only to relize my battery was dead....


Your solution is a little hard to find too bad they told you to change the alternator. It is a simple fuse you need to change that is blown. on the expetion sometimes there are two one in the fuse box and one under a black cover follow the alternator small wires it should point to the direction of the small i believe 7.5 amp fuse. it was hard to find and i do this for a living. good searching.

Apr 20, 2011 | 2004 Ford Expedition

1 Answer

My ford dealer replaced the alternator 18 months ago. I put on 60,000 miles. I see the red light flicker on the dash board. Is it time to replace the alternator?


since the alternator was just replaced 1 1/2 years ago I would say that it might not be the alternator but it could be your battery. I would take your car down to a battery shop and have them do a load test on the battery to see if the battery is starting to go bad and not holding the charge from the alternator.
if the battery test shows that the battery is good then the alternator is bad,, check your paper work from the dealer to see if it is under warranty.

c...

Jan 19, 2011 | Ford Explorer Cars & Trucks

1 Answer

2003 BMW 530i won't start; mechanical hum, but no clicking sound


my 530i are 203 and problem was iwash the car with watter and starting problem no start all light is vuzible

Jan 03, 2010 | 2004 BMW 5 Series

1 Answer

Won't start


disconnected the battery last nite, reconnected this morning, started right away.
I noticed a cell phone charger was plugged in, I am hoping this is the thing that was draining the battery, if not, will look further.

Jul 06, 2009 | 2004 Chevrolet Silverado 1500 Crew Cab

4 Answers

Engine don't start and have a clicking sound


you should check and see the batttery smart visor indicator (if applicable - see owners manual)
this may be that the battery has been drained and does not have enough power to rotate the starter. lights, dashboard, instruments light up ok as the voltage is there but the power (amperage) is low. please refer to owners manual on how to recharge your battery. bare in mind that removing the baterry from the care will reset systems (audio, alarm) and you wil need to recode them by using the codes provided with the car.

Jul 08, 2008 | 2004 Audi A4

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

55 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60541 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...