Question about 2001 Ford Expedition

1 Answer

Ford expedition 2001

Cannot start the engine.
battery - checked 12v - the contacts were oxidated. clean them.
still nothing.
yesterday i drove my car with no problems.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 23 Answers

Try jumper cables

Posted on Jan 11, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Every stereo I connect to the wiring in my 98 Ford Expedition will illuminate but not power on including stock stereo that was working right before I started this so called project!


you must test the fuse, wiring, and connector. Clean it, by corrosion, dirty , oxide, and repair any wires broken or open use the DVOM, for to do this test, Disconnect the batteries the + side before to do this.
2) test the ribbon cables connection for your Radio, can be broken or open , and clean it with eraser pencil, for corrosion, dirty, oxide, or bad contact, and replace if necessary. God bless you

Oct 13, 2012 | 1998 Ford Expedition

1 Answer

2001 Expedition - check engine light came on. Oil change on 1/27/11 not due for another 1000 miles. It just started to tremble and is running rough.


your oil change has nothing to do with your check engine light. probably needs spark plugs and a coil or 2

Mar 29, 2011 | 2001 Ford Expedition

2 Answers

I have an 89 s10 and it has been running just fine. I took a load of scrap to the junkyard yesterday and on my way home it died. I started it back up and drove the rest of the way home. On the way home the...


multiple symptoms are usually caused by faulty ground connections, in you case probably engine to body strap, use booster cables to establish ground fron battery to engine then engine to body, if it solves the probem then clean all grond connections and battery cables, there should be a strap at the rear of engine to body

Nov 04, 2010 | 1999 Chevrolet Silverado 1500

1 Answer

Car wont start, acts like battery is dead. battery shows full charge. full lights, buzzers, etc. put it on charger-didnt start...cleaned cable connections-didnt start...tried to jump with truck-didnt...


Check the battery +12v power connection to the starter is in good order,
Check the ground connection between the battery negative and the engine/starter motor is robust and intact.
If no problem with above, replace the starter motor.

Oct 10, 2009 | 1993 Ford Tempo

1 Answer

Car cranked fine drove 80 miles shut off car went back to crank it would not do anything


Most likely battery related:
1. Clean battery terminals, remove the battery cables and clean the cable clamps and the battery posts. It may start now.
2. The negative cable, where it connects to the engine ground, is loose, corroded, damaged, or otherwise not making good ground contact.
3. Turn ON headlights and try to start engine. If there is a slight dimming or no dimming, the solenoid needs replacement (maybe the starter, too).

Oct 08, 2009 | 2001 Ford Explorer

1 Answer

2001 expedition 5.4l. wont crank


get a multimeter and test battery output, if more than 13v when you turn key to crank position if below then battery may be faulty and not holding charge, check starter relay and fuse, if ok also check for any parasitic draw from any accesary that might draw down battery when engine not running

Oct 03, 2009 | 2001 Ford Expedition

1 Answer

Car Battery


Alternator is bad. It is not charging the battery as you drive.

Apr 30, 2009 | 2002 Ford Expedition

Not finding what you are looking for?
2001 Ford Expedition Logo

Related Topics:

70 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

63801 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...