Question about 1999 Chevrolet S-10 Pickup

1 Answer

My problem is I bought a truck and the wiring in the back was played with so the trailers lights would work for him,and I had the wires apart and looking for burnt out bulbs signal lights do not work they blink really fast in front and the passenger side in the rear is bright and the drivers side is dim when signal lights are on its blinks wierd but it was working when I plugged the plug back in and tryed and still the same thing what can I do to fix this

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 174 Answers

Take his wiring off of the truck. If it is a plug in harness, bypass it. See if the lights work correctly now. If not, check each light for a loose connection. If they work correctly, go get another harness. Hope this helps, Mike

Posted on Jun 23, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Bought a 1998 nissan frontier. Tried to hook up a trailer to it but no plug was found to plug up the trailer. I went and bought a 4 wire plug and wired it up with wire colors all matching up. Plug up to...


Do you have it hooked up to the ball when you are testing? 4 Leads covers L+R turn (2) Brake (1) and Running lights. You don't have a ground.

Jul 14, 2014 | Cars & Trucks

1 Answer

I just bought a horse trailer and when I hook it up to my 2006 Silverado, the lights don't work. My trailer hitch and wiring system are new, and the previous trailer owner tested the lighting of


Some people wire trailer plugs differently. If the plug is not wired differently than yours, make sure the tow ball is clean. No rust. That's where the trailer gets its ground from. Usually they will work if thats the case, but not right. I can't remember what the wire colors are right now. Go to etrailer and look up the diagram.

Feb 05, 2013 | 2006 Chevrolet Silverado

1 Answer

Trailer hitch lights


check the ground to the trailer this will be the cause of most lights acting funnyit will be the white wire

Jun 25, 2012 | Cars & Trucks

1 Answer

Hi, we recently bought a 2010 Honda odyssey and ha...


is the trailer attached to the ball on the van?? could be a ground problem,,run a jumper from hitch to trailer see if that works,,

May 21, 2010 | Cars & Trucks

2 Answers

Trailer brakes


Take a 12 volt test light... the kind that has a spring loaded clip to hold the probe into the wire, and insert it into the wire just before the trailer plug, vehicle side. (Blue I think) If there is a connection, the brake should see it and you should have an indicator light. When you activate the brake the test light should lite up. If not, move up to the brake actuator and test the blue wire. If there is nothing at the actuator, check the black wire. It is power to the controller. If no power there, check fuses again. If it does pick it up at the plug, connect the trailer and test the trailer itself. First ground to the trailer and then to the truck. Most problems are ground wire related. Then move to the axle and test it there. For the brakes to work, and even show on the indicator, there has to be a ground and power to the brakes themselves. There are 2 wires to each brake... a ground and a power. Test across both wires to make sure you have power and ground. You can also hook another trailer to your truck or another truck to your trailer. Lights can work through trailer ball ground. Brakes can't. leave the trailer unhooked from the trailer and hook the wiring up and test the lights. That usually will indicate a good or faulty ground. Also make sure there is a GOOD ground to the truck frame/body. Also try http://www.etrailer.com/faq-wiring.aspx. They have a great website with lots of info. Hope this helps. Mike

Sep 30, 2009 | 2003 Chevrolet Silverado 2500HD

1 Answer

Bought trailer harness for my trailer all four poles show 4 wires mine has five wires going to trailer lights turn on signals both light up like four ways also no brake lights. made sure all lights were...


try http://www.etrailer.com/faq-wiring.aspx. This should help. The 5th wire is a lockout for the brakes that hooks to your back up lights. So when you back up, the brakes won't engauge. Typically white is ground, yellow is left turn, green is right turn, and brown is running lights.

Sep 24, 2009 | 1998 Ford Explorer

1 Answer

Trailer signal and brake lights not working at back of trk


THERE SHOULD BE SEPARATE FUSES FOR THE TRAILER WIRES. HAVE YOU LOOKED UNDER THE STEERING COLUMN FOR THEM? IF YOU HAVE AND THEY CHECK OUT OKAY, THEN CHECK THE WHITE WIRE ON THE TRAILER PLUG, IT IS THE ONE THAT IS EXPOSED ON THE TRAILER PLUG. IT IS THE GROUND FOR ALL THE TRAILER LIGHTS AND THE MOST IMPORTANT OF ALL THE WIRES. SEE IF THE TRAILER HAS A GOOD CLEAN GROUND AS WELL(WHITE WIRE). HOPE THIS HELPS. PLEASE KEEP ME POSTED. THANKS FOR AN HONEST RATING AND FOR USING FIX-YA. GOOD LUCK

May 18, 2009 | 1998 Ford Expedition

1 Answer

Trailer lights


check all trailer tow fuses in panel under hood.there is a fuse for trailer brake lights and a fuse for trailer signals.but if one signal is working it is probaly broken or corroded wires at the back of the trailer plug or corroded wires inside plug.

Nov 09, 2008 | 2000 Ford F250 Super Duty Crew Cabs

2 Answers

Wiring harness problem


the issue is the trailer, negative or power feed back,check grounds

Jul 24, 2008 | 2002 Ford Windstar Cargo

Not finding what you are looking for?
1999 Chevrolet S-10 Pickup Logo

32 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8514 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...