Question about 2001 Mercury Grand Marquis

1 Answer

2001 marquis speedometer stopped working. Replaced cluster- nothing, replaced speed sensor-- nothing, checked all fuses-- OK, stopped 3 wks ago when changine out rear air bags. What could the problem be?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mercury Master
  • 8,273 Answers

Check speed sensor signal at sensor and at cluster. Jack up drive wheels, Block other wheels, start car, put in drive. Then check both AC signals. The signal at the cluster is on pins 14 and 16. See diagrams below.

2001 marquis speedometer stopped working. Replaced - jturcotte_1514.gif

Posted on Apr 10, 2011

  • 1 more comment 
  • Jeff Turcotte
    Jeff Turcotte Apr 10, 2011

    sensor diagram:


  • Jeff Turcotte
    Jeff Turcotte Apr 10, 2011

    The same signal goes to pins 3 and 10 of the cruise control module.


  • Jeff Turcotte
    Jeff Turcotte Apr 10, 2011

    Hi, I just wanted to check another thing with you. The spring installation instructions say there is a procedure included with the kit that tells you how to disarm the air suspension light in the cluster. Did you get those instructions and execute them?



    Thanks, Jeff

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 Grand Marquis digital speedo only reads "0". All other displays read correctly. Could it be the speed control? If so, where exactly is it located?


The speedometer provides speed information based on a speed/distance pulse signal from the vehicle speed sensor (VSS). The VSS is mounted on the speedometer driven gear in the transmission.
or the gauge is bad .
  • The speedometer/odometer is inoperative
  • CJB fuse 14 (10A).
  • Vehicle speed sensor (VSS).
  • Circuitry.
  • Instrument cluster.
  • Go To Pinpoint Test E .
PINPOINT TEST E: THE SPEEDOMETER/ODOMETER IS INOPERATIVE CAUTION: Use the correct probe adaptor(s) when making measurements. Failure to use the correct probe adaptor(s) may damage the connector.
CONDITIONS DETAILS/RESULTS/ACTIONS E1 CHECK VSS SPEED SIGNAL BETWEEN CIRCUITS 679 (GY/BK) AND CIRCUIT 676 (PK/OG)
VSS C1088
Raise the drive wheels off the ground. While rotating the driveshaft, measure the AC voltage between the VSS C1088 pin 1, circuit 679 (GY/BK), component side and the VSS C1088 pin 2, circuit 676 (PK/OG), component side.
  • Is the voltage between 1.3 volts AC to 6.1 volts AC?
Yes GO to E2 .

No CHECK and INSPECT the speedometer drive gear. INSTALL a new VSS if the speedometer drive gear is OK. TEST the system for normal operation E2 CHECK CIRCUIT 679 (GY/BK) AND CIRCUIT 676 (PK/OG) BETWEEN THE INSTRUMENT CLUSTER AND THE VSS

Dec 03, 2016 | Cars & Trucks

2 Answers

2001 Buick Century Limited speedometer problem, Speedometer not working but odomitor ok. Is there a fuse?


if the odometer is working then the problem is with the speedometer head unit as the odometer gets its information from the same source as the speedometer. you can have the speedometer head checked and fixed if its fixable.

Aug 22, 2015 | 2001 Buick Century Limited

2 Answers

2001 Ford Windstar Speedometer stopped working after I installed Hub Bearings


The sensor is attached to the output shaft of the transmission and should not be affected by the work that you did. Are the ABS sensors ok?

Apr 02, 2014 | 2001 Ford Windstar

1 Answer

My speedometer doesn't work and the transmission shifting is eratic


electric speed sensor no side of trans one 10 mm size bolt holds in place. check fuses first, then ck speed sensor.

Jul 28, 2012 | 2001 Toyota Sienna

3 Answers

Does any body know why my speed gage and rpm gage doesn't work on my 2001 dodge caravan


mine stoped working and i had to do a cluster diagnostic by pushing and holding the milege reset button untill the diagnostic test starts this might solve your problem

Oct 23, 2009 | 2001 Dodge Caravan

1 Answer

SPEEDOMETER CABLE NEEDS TO BE REPLACED


There is no cable on the 93 Prizms.  The problem is one of two things, either the "vehicle speed sensor" or the instrument cluster itself.   I also have a 93, and the speedometer started acting up a while ago. Sometimes it would register 0 then it would spike up to 70 and stay there at highway speeds then back to 0 upon slowing.  I replaced both items from the junk yard.  The speed sensor at an auto parts store will run about $160, and a new cluster will cost A LOT more at the dealer! I first replaced the speed sensor with no luck ($5.00 at the junkyard) the same thing happened 0 or 70.   I replaced the cluster today ($13.99 at the junkyard).  That was it! Problem solved.  The cluster is EASY to replace, remove the 2 screws from the trim piece and remove trim.  Next, remove the 4 screws that hold the cluster in place; 2 at the very top (don't remove the ones just above the cover glass) and two at the bottom.  Pull one side of the cluster out; there are 3 plugs; squeeze the center of the plugs to release the clip and wiggle them free.  Connect the replacement cluster, but before screwing it in, do a check to make sure all the panel lights work.  I had a few that were burned out, so I used the old cluster lights to replace them.   I would try replacing the cluster first.  Good luck!

Mar 22, 2009 | 1993 Geo Prizm

2 Answers

Odometer stopped working


output shaft speed sensor in the transmission

Mar 13, 2009 | 1994 Mercury Grand Marquis

1 Answer

Honda Accord EX 94 vss has been replaced, but still nothing work


If all the connection and power supplies to instrument cluster are ok,I suspect that the speedometer or instrument cluster is faulty but before you replace it, make sure the gear inside the transmission that drives the VSS is in good.

Mar 12, 2009 | 1994 Honda Accord

2 Answers

91 speedometer and miles


I have a 91 Accord. When I purchased it, the speedometer did not work. I replaced the VSS (Vehicle Speed Sensor) and the speedometer started working again. I paid $24 for the sensor on ebay. The local part stores wanted $150. It's an easy fix. It takes about 20 minutes to replace.

Jan 12, 2009 | 1991 Honda Accord

4 Answers

2004 Chevy Trailblazer Speedometer


replace the ip cluster will fix speedometer

Sep 29, 2008 | 2004 Chevrolet TrailBlazer

Not finding what you are looking for?
2001 Mercury Grand Marquis Logo

554 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

fordexpert

Level 3 Expert

5522 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...