Question about Chevrolet S 10

2 Answers

Hello blower motor only runs on hi after you tap the relay on the firewall I have changed out the relay and the resistor still only on hi after you tap relay or hit a bump it's driving me crazy please help

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Chevrolet Master
  • 442 Answers

Make sure the relay is grounded. If it is check the circuit between the heater switch hi position and the relay trigger terminal. There should be 12v on that circuit with the switch in the hi position.

Posted on Apr 10, 2011

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 66 Answers

Either the blower motor is bad or the control swicth is bad. I would try the cheaper blower motor first.

Posted on Apr 10, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Location of heater relay on 2003 ford focus.


There is no relay, according to my info. At the blower motor, green wire is voltage, fuse protected, goes hot with key on. Black wire is ground. The blower speed control switch is part of ground circuit. There are resistors for the lower speeds. Hi speed doesn't use a resistor. If you have good voltage and ground at blower motor and no blower action, suspect the blower motor. Any motor that uses brushes, sometimes you can tap on suspect motor, and it will run intermittently. Sign of bad brushes.
You may be able to use jumper wires to blower motor connector for voltage and ground, from the battery, just to see if blower motor will run? If it won't run, suspect blower motor. If you use jumpers, use an inline fuse, just in case.

Oct 15, 2015 | 2003 Ford Focus

1 Answer

Blower motor relay


Usually a part called a "blower motor resistor" is the problem. Just follow your underhood wiring from the blower motor across the Firewall and you will find it leads to a connector. This part has 2 attaching bolts and the part itself is 90% hidden. What you can try is to tap the connection with a broom handle or snow brush to reactivate it.

There is probably as good a chance the old part will work just as good as a new part once the warranty expires. The "blower motor resistor" has been a problematic part across the Ford product line for many years. They will reach a point where tapping may not fix this, but the unit can work for years after tapping.

There may be a heater hose in the way of replacing the part. Ask for a technique to make it easier to do.

Jan 01, 2014 | 1999 Lincoln Town Car

1 Answer

Where is the high speed blower motor relay? I looked under the cover on the firewall. The relay cover with the location is missing. Which relay is it? Thanks


The blower motor RESISTOR is probably what you're looking for. It is located under the hood, under the fuse/relay panel. You have to remove the relay box (disconnect the battery first, unscrew the panel, move it aside). You will see where the blower motor cables run right up into where the relay panel was hiding it. Unscrew (not just disconnect) the plug and when you take it out you will see the blower motor resistor. It's a springy looking thing.

Jun 20, 2011 | 1997 Oldsmobile Eighty Eight

2 Answers

Hi ya, i just inquired about my blower motor, is the relay and switches and everything under the dash or under the hood,


In the Dodge Dakota the blower motor resistor is located under the hood, on the right side firewall.

Dodge Dakota Blower Motor Resistor Location:

b3bc94a.jpg

Dodge Dakota with a complaint of no blower operation. After unplugging the harness connector and removing the two screws, you could remove and examine the resistor coils for damage. The heat and subsequent rust damage are clearly visible in the picture below.

6f6f301.png

Apr 07, 2010 | Dodge Dakota Cars & Trucks

2 Answers

Blower motor will not blow fuse relay motor are ok


it could be that the motor itself is bad there is a relay inside the motor as well give these websites a try www.alldatadiy.com and www.autozone.com if it was me i would checkout one at a good salvage yard give this website a try to find one close to you give this website a try www.junkyarddog.com wish you the best of luck Michigan Man.

Mar 13, 2010 | 1993 Buick LeSabre

3 Answers

1991 Olds 98 Elite heater blower motor continues to run with key off. Will change speeds with controls but will NOT shut off..


if you haven't got your blower fan fixed yet, im sure it to be the same as mine, the blower motor relay which is out on the firewall under the big fuse block. take plastic cover off over the fuses and move the fuse block out of the way and you will see it staight under that. should be two screws holding it on.

Mar 05, 2010 | 1991 Oldsmobile Ninety Eight Regency

1 Answer

I'm looking too. I have a 1995 model.


There is a blower motor resistor that needs to be changed. You can get it at auto zone for around 25 bucks. I just changed one on my 03 tahoe.

Aug 08, 2009 | 1996 Oldsmobile Ninety Eight Regency

1 Answer

Blower stopped working on 1998 ford galaxy,ran wires to blower direct and works!Could it be resistor or ellectronic control unit,how could i check?


check for voltage at the blower motor on all settings. if no voltage check the blower motor resistor or relay. if it has a resistor it will be right beside the blower motor, if it has a relay it will be the relay on the firewall under the hood.it will probably have a purple,orange,blue,and black wires. as you said it works directly.it can be resistor or relay.the blower is fine. thanks.

Jul 11, 2009 | 1991 Oldsmobile Custom Cruiser

1 Answer

1994 bonneville blower problem


the blower relay is the third one from the left ,,under the hood on the firewall ... also the high blower resistor is on the center of the firewall ..behinde the relay bracket

Sep 04, 2008 | 1999 Pontiac Bonneville

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

61 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7710 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...