Question about 2005 GMC Yukon

1 Answer

2005 GMC Yukon 1500 XLT Getting following codes: 131,171,307 Started immediately after replacing fuel pump Wondering if related- maybe dirt in filter or something. Missing on 1 cylinder (7)

Posted by on

  • billymac694 Apr 11, 2011

    Getting closer I think.

    4 plugs on bank 1 are black. All on other side are like new.
    Mass Air Sensor is like new
    O2 Sensor ?
    Getting 300 and 171 after resetting aand strung exhaust smell

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • GMC Master
  • 443 Answers

Codes P0131 and P0171 indicate the fuel system is lean at least on bank #1.P0307 indicates a missfire on #7 cylinder. Tou didn't indicate if you replace the fuel filter when you replaced the pump. If not that would be the first thing to do. Beyond that you'll have to check the fuel system for pressure and volume. If that's OK you could have a weak O2 sensor on bank #1. If fuel system checks out you'll have to check #7 plug, wire, coil, etc,

Posted on Apr 09, 2011

  • 2 more comments 
  • billymac694 Apr 09, 2011

    I just checked plug #7 and it was completely shot-black.
    I changed it with a used one I had for now, reset codes and will wait to see if it comes back.
    I will change all the plugs tomorrow and see if any better.
    Could it be only that or is the black plug a result of the other issues?

  • Terry Reimink
    Terry Reimink Apr 10, 2011

    My recommendation would be to drive it. If it happens again you'll have to look further. If not you should be good to go.

  • billymac694 Apr 11, 2011

    Plugs on bank 1 are all black. Bank 2 are all like new as well as air flow sensor.

    I assume O2 sensor on drivers side is bad?

    After clearing codes now getting 171 and 300
    Should I swap O2 sensors on bank 1 and 2?

    Are there 4 in all? 1 in front and one in back of cad conv on each side?

  • Terry Reimink
    Terry Reimink Apr 11, 2011

    You could have a bad O2 sensor on bank #1. It may be stuck at a low reading and the ECM keeps adding fuel trying to get the O2 reading higher.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

P0171 and p0174 GMC YUKON XL 2004 5.3 1500


These codes let you know the engine is running to lean on gasoline . May be only a plugged fuel filter or weak fuel pump. A vacuum leak can cause this problem . The engine controller may need reprograming with new software. Dirty fuel injectors. Try adding fuel conditioner to the gas tank and changing fuel filter.

Feb 15, 2017 | 2004 GMC Yukon XL

1 Answer

Yukon XL was first showing Reduced Engine Power, then Oil Gauge quit working, now car is running hot


Might help, disconnect negative terminal from battery for 10 minutes, if the compute is getting weird readings this will reset it and maybe help.

Dec 09, 2013 | 2005 GMC Yukon XL

1 Answer

1996 gmc yukon giving p0300 code ive changed spark plugs and ignition rotor still misfiring checked for vacuum leaks and there was none


I would suggest replacing fuel filter and maybe having a pressure test on fuel system and if pressure is low this would indicate fuel pump is weak and may need to be replaced..hope this helps and Please rate my post and good luck.

Aug 15, 2012 | 1996 GMC Yukon

1 Answer

I have 04 Yukon, Was driving it down the highway and it just shut down on me. It was still idiling, but when you gave it the gas, it would not go. I killed it, finally got it to start back, and it finally...


{: ) The fuel pump and fuel level sensor are just among the possibilities. If the fuel pump is unable to provide the proper pressure whenever you give gas, the engine may stall. I was wondering if you also happen to see any related messages on your cluster.
It's a good thing you were able to limp your way back home. Reminds me of the throttle control system issue which is also possible on your case. When there is fault in the throttle controls system, it will default to the Reduced Engine Power mode, sometimes called the Limp mode. In this mode, the system will limit vehicle acceleration and speed. At times it may even shut off the engine.
A diagnostic scan tool can effectively address the main cause and rule out other possibilities.
For the meantime, you may want to check your throttle body if its coking up with carbon, better have it cleaned. Who knows? you might get lucky, A dirty throttle body is also one of the possible causes. Maybe your next tune up is on sked.

Jul 02, 2011 | 2004 GMC Yukon

2 Answers

2002 GMC YUKON XL 1500 MOTOR DIES AFTER GOING


Check the fuel cap!! If the vacuum relief is not working it can impede the fuel flow and cause the engine to shut down or not restart after a stop. Waiting usually gives things a chance to stabalize and the engine will restsrt. When this happens again try loosening the cap and see if the engine will restart.....If it restarts immediately, REPLACE the fuel cap..Do Not leave it loose because this will cause other problems. If it is not the fuel cap the problem may be the filter, the fuel pump, or aome other fuel system malfunction.

Jan 23, 2010 | 2002 GMC Yukon XL

1 Answer

I'm getting code 0016 and 0301 on my 2005 gmc sierra pickup, vortec 4.3 v6. Won't start.I've had those codes for several months, but was too busy to get it fixed, with occasional rough starting or poor...


P0016 Crankshaft Position - Camshaft Position Correlation
Replace the Crankshaft position sensor, it's located on the passenger side by the harmonic balance in the front of the engine. Inspect the wire harness and make sure you also buy a can of brake cleaner to clean all the dirt from that area since the sensor is magnetic and will pick up any metallic dirt and will cause faulty reading to your ECM.

P0301 is an indication to a missfire to cylinder #1 which is most likly related to the crankshaft sensor being bad.

Replace the Crank sensor first and it take about 20 min from start to finish. Good luck and keep me posted.

Dec 26, 2009 | 2005 GMC Sierra 1500 Hybrid

Not finding what you are looking for?
2005 GMC Yukon Logo

Related Topics:

214 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...