Question about 2005 Subaru Legacy

1 Answer

Turbo had been working fine then then just stopped and now has no turbo boost at all what do i check and how

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 231 Answers

Hi check around the engine bay for any hoses that have come off, or check the compressor wheel on the turbo hasnt blown to peices on the turbo by removing the air filter pipe or the exaust

Posted on Jun 14, 2011

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

burgessjay69
  • 78 Answers

SOURCE: TURBO NOT BOOSTING

hi is the waste gate stuck open on the turbo ? its a small round flap in side the turbo itmaybe stuck or broke if it looks ok mack sure it opens and closes ok useing the rod on the actuater

Posted on Jun 22, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My new turbo stopped working after a month


Chances are something else is at work, like a boost leak or control system failure. Perhaps the clip on the boost control actuator arm fell off and the arm disconnected from the wastegate.

Feb 20, 2015 | 2004 Audi A4

1 Answer

Turbo not kicking in like it should cant find no leaking pipe and turbo seems to be working fine


In general the possible causes could be:
- Boost pressure sensor harness is open or shorted
- Boost pressure sensor circuit poor electrical connection
- Faulty boost pressure sensor
- Faulty Turbo/Super Charger
- Engine over temperature.
- Ignition misfire exceeds the calibrated threshold.
- Faulty Knock sensor (KS)

I would doubt its the turbo as you said it seems to be working just fine (unless the wastegate is stuck open/wastegate seal is cracked). Also if the ignition misfire exceeds the claibrated threshold then I would think you'd hear that in the engine running normally. I would say locate the sensor and replace it?

Hope this helps

Dec 05, 2012 | Cars & Trucks

1 Answer

Losing boost!! I have a 1993 mazda rx7 13b twin turbo with the stock turbos. When i punch it my boost goes up to about 10psi. But bleeds off and i can head it blowing out. Was thinking it was blow off...


Have you checked all the tubing cuplings? When mine was doing that i had a cupling that would keep sliding off just enuff that it was letting out air and loosing me boost.

Mar 29, 2012 | 1993 Mazda RX-7

1 Answer

88 conquest tsi cuts out when building boost, it was running perfectly fine today, but now the car cuts out when the turbo starts to build boost, and as soon as the boost gauge reaches 0, it cuts out


you may be having problems with the turbine or it could have a heavy short in the system. check the tuning on the turbo it may be starting the boost to soon or to late causing problems also check your intake setup this includes your pcv valve

Nov 04, 2011 | Cars & Trucks

1 Answer

Mk3 Supra Turbo Boost Gauge Problems


The gauge is working fine, the turbo will not kick in untill the engine is spinning fast enough, as the turbo is propelled by exaughst from the engine. So, you can drive around normal and never use the turbo, and climb in the gas and spool the turbo up, what you are noticing is called turbo lag, which is the biggest down fall when compaired to superchargers!

Feb 23, 2010 | Toyota Supra Cars & Trucks

2 Answers

I have a 320d of 2000 which has done 104 000k. The turbo boost used to come in at about 2000rpm and again at just over 3000rpm. The 2000 boost does not seem as powerful as it was and the 3000 boost is no...


dear friend:a turbo can only boost the air that it receives,if the turbo is not damaged it should work properly,the turbo depends on the exhaust gasses for the speed that it turns which then boosts the air that it receives,that means that any restrictions on either side of theturbo will influens the preformance,check the air filter and ducting pipes.

Sep 19, 2009 | 1999 BMW 323 Series

2 Answers

Xj vm 2.5 turbo loss at 2000rpm what sensors and where are they..


You have to check the power switch. And the wires connected to the to it.and check up to the battery connection .The kick does not work if the solenoid , the ignition circuits and spark plug is nut functioning try to check or replace them if destroyed already.

Jul 28, 2009 | 1997 Jeep Cherokee

1 Answer

Power loss and black smoke?


I had a similar issue to this after I got in a VERY small fender bender (literally) in an 87 Turbo Supra. In my case, my pasenger fender got pushed in JUST enough to crack a charge pipe and cause a boost leak.

Basically, what was happening was the turbo would spool and build boost, the mass fair flow sensor would read all this air coming in and tell the ECU to dial up the the appropriate amount of fuel. When the air reached the cracks in the charge pipe, it would escape out of them. Thus there was a much lower air-to-fuel ratio, causing less fuel to combust, which lead to power loss and black smoke out of the exhaust.

My guess is either an oxygen sensor, or more likely a boost leak.

Good luck mate.

Jun 19, 2009 | 2000 Ford Focus

1 Answer

Loss of power going up grade


sounds like a very common problem on turbo vag vehicles,the variable vains are sticking in the turbo,your fault code would have said....turbo boost pressure not reached.....common with v v t turbos,run a good quality fuel cleaner through it ,if that doesnt work then a new turbo is the only cure

Dec 29, 2008 | 2004 Audi A4

Not finding what you are looking for?
2005 Subaru Legacy Logo

Related Topics:

98 people viewed this question

Ask a Question

Usually answered in minutes!

Top Subaru Experts

yadayada
yadayada

Level 3 Expert

75051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7727 Answers

Are you a Subaru Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...