Question about 1997 Subaru Legacy

1 Answer

A delay when shifting into drive after car as been sitting for awhile

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 3 Answers

I recommend checking the transmission fluid level first.

Posted on Sep 02, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Turbo 400 transmission


Is this a rover 75?? or another make entirely

Mar 01, 2014 | Cars & Trucks

1 Answer

Car starts fine after sitting awhile. If you drive awhile then stop and try to restart it won't.


Check the electronics,cam sensor or crank sensor these are the culprits.

Aug 19, 2012 | 2006 Chevrolet Aveo

1 Answer

Start from cold, the shifting gear from one to two seems to be delayed and when it happens, it comes with a kick. The problem is less noticeable after awhile.


try using less gas when pulling away for awhile to see if you get any improvement...(the gearbox is computer controlled and may be shifting to your style of driving)could be wrong though.....

Aug 24, 2010 | 2002 Audi allroad

2 Answers

My automatic escort will not shift out of first gear. I will drive in first gear, slip it into neutral, then back into drive, and will get second gear for about five seconds. Any ideas?


Try replacing Speed sensor.I have 95 Escort that while driving for about 20 miles would shift into low gear and not shift back into higher gears.After letting it sit for awhile it would drive fine for about 20 miles then do the same thing.Had the speed sensor replaced and works fine now.

Feb 27, 2010 | 1995 Ford Escort

1 Answer

1995 vw jetta vr6 just purchased for son when


Transmission solenoid needs replacement.

Jul 18, 2009 | 1995 Volkswagen Jetta

1 Answer

Transmission


Change the fluid and filter and add some Berryman's chem tool to it, most likely a shift solenoid is stuck from sitting.

Oct 07, 2008 | 1992 Nissan Stanza

1 Answer

1999 ford escort


Sorry for Delay:

This could the problem with the electrical fault in the car you need to verify it :Please use this link:

http://www.autozone.com/addVehicleId,2537801/initialAction,repairGuide/shopping/repairGuide.htm?pageId=0900c1528008de28



Good luck....

Jul 19, 2008 | 1999 Ford Escort

1 Answer

Delay in 1992 automatic transmission shifting


Car starts fine- In order for car to move it must sit for 20+ min then it will move - sometimes while driving the trans will seem like its whinning out then start to drive fine- what could be the problem? iam thinking thr screen , but dont have alotta cash to throw at this car anying help would help Thank!

Jul 16, 2008 | 1992 Chevrolet Lumina

Not finding what you are looking for?
1997 Subaru Legacy Logo

Related Topics:

70 people viewed this question

Ask a Question

Usually answered in minutes!

Top Subaru Experts

yadayada
yadayada

Level 3 Expert

60769 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Subaru Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...