Question about Chevrolet Avalanche

1 Answer

Driving down the road and tranny started slipping so I pulled to the side of the road, then let the truck sit for 10 minutes, then the tranny worked again but within 1500 feet was slipping again, and will start working when letting the car turn off for a period of time then will work again for a small distance. Is it the Torque converter? Is it a computer problem? Tranny fluid doesn't smell burnt or look dirty. I am confused on why it keeps working when I turn it off then turn the truck back on after letting it sit for a few minutes???? please help diagnose :)

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Expert
  • 1,114 Answers

It sounds like you either have a dirty filter, or a solenoid is faulty in the transmission. Change the fluid and filter, put some Lucas transmission oil in it and see if that resolves the issue. If the solenoid is dirty then it will cause the transmission to shift improperly, the Lucas will clean it.

Posted on Apr 08, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1989dodgeram4x4d100fuelproblem


I own a 97 crew cab dodge ram. I had that issue the computer at my work said o change o2 sensor on exhaust. it fixed it.

simply flooding motor.

Mar 29, 2014 | Cars & Trucks

1 Answer

While driving on a smooth road, sudlenly it felt that I ran over something. No debree! Then the engine accelerated but would not get to the wheels. After sitting on the side of the road for 5 minutes, I...


The trans solenoid is likely bad, but it could be a fluid level problem. Have you checked that the fluid is at least up to the cold mark and not dark and watery? If the fluid is low or bad, you'll need to add some to get to the cold mark and replace the fluid if it is bad.

If the fluid is okay, the solenoid may be your problem - not a bank breaker but needs to be done. You may find that the car will drive on in P but in first gear only so you can get to a safe place. If you have pulled a trailer or downshifted on long grades like I used to, the tranny can't take it and the solenoid takes the stress and fails.

Good luck.

Feb 06, 2011 | 2001 Chrysler Town & Country

1 Answer

Suburban stalls while driving after running for 15-30 minutes. After letting it sit for 5-10 min it runs fine for another 5-10 minutes, then starts doing it all over again.


a bad crank sensor can cause this. shuts off while going down road, and will start about 10 min, later with no problems runs fine until it quits again. hope this helps,

Oct 07, 2009 | Chevrolet Suburban 1500 Cars & Trucks

1 Answer

I have an 04 Silverado with the 4L60E. The


I would be interested to know why you kept pulling the tranny. Its possible you lost the prgram in the PCM. You may need a reflash. Where there codes. Or you may have a bad torque converter or trans oil pump.

Jul 15, 2009 | 2004 Chevrolet Silverado 2500HD

1 Answer

Car wont work after the initial warm up die down situation


Crank sensor or module. Check fuel pressure too.

Jul 03, 2009 | 1999 Pontiac Grand Am GT

1 Answer

2002 neon tranny faiure??


I had the same problem driving along and had to coast over to the side of the road. 92000km. all the clutches in the tranny were gone and all kinds of filings in filter and pan. the tranny had to be rebuilt at dealer for $1895 canadian Sorry for this news I also thought it slipped into neutral and wouldn't move no matter where I put the shifter

Apr 15, 2009 | 2002 Dodge Neon

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

218 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76673 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8531 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...