Question about 1988 Jeep Comanche

2 Answers

My 1989 commanche the motor keeps stoping, you try too start it , the battery jests clicks, you wait fot a few hours, its start with no problem runs then stops again

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 82 Answers

Replace the terminals on the battery cables and clean the posts. it sounds like you have a bad battery connection. look for cracks and corrosion around the terminals.

Posted on Apr 06, 2011

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Jeep Master
  • 22,156 Answers

I think it has a charging fault ,so check the alternator for output amperage

Posted on Apr 06, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Will not start, battery is new, it just clicks and nothing. turn it off, try again and nothing, try again and it starts


Try cleaning and tightening well the battery connections along with the battery wires to the solenoid and starter motor.

Bad connections and low voltage of 12 volts can result in this anomaly.

Jun 12, 2017 | 1997 Lexus ES 300

1 Answer

1989 fi50 std 4.9l cranks slow, starts, take a long trip...60 miles, shut it off and it is dead, no crank, nothin....wait 1/2 hour starts, still cranks hard then runs....can you help???


starter worn out.. battery with shorted cells..check these.. test the battery for load bearing capability.. it may need replaced..

Dec 28, 2013 | 1989 Ford F 150

2 Answers

I have a 94 Mazda B4000 pickup, the motor stops but will start after waiting about 30 minutes it will start, it will run for a few miles but stops again, I had the fuel pump relpaced and the motor is still...


a 94 i believe uses a ignition module not a ecm these have the exact symptom you describe when starting to go bad eventually it will fail and not start at all if this is it

Oct 20, 2013 | 1994 Mazda B-Series

2 Answers

I want to change my 1989 2wd comanche into a 4wd? how do i do this and can i use a cherokees parts? i have a 4.0L


if u want to change it to a 4x4 u need front drive line. and it bolts to a transfer case. u need to get one special ordered, u could use a cheokee tranny that has 4 wheel drive and bolt it on to the back of the motor. make sure that the bell housing has the same kind of bolt pattern that the back of the motor has.

Jun 02, 2010 | 1989 Jeep Comanche

1 Answer

1989 volvo 760, 4 cyl turbo. our stationwagon is having a little problem starting. in the morning or the first drive of the day the car starts fine but every once in a while we drive it and go into the...


Check the connection at the starter relay. The battery cable should run to the relay and another runs from the starter relay to the starter. If the connection seems fine, the relay itself may have a crack within., preventing a starting connection. If this isn't the problem, the starter solenoid may be getting to hot and not engaging the starter bendix.

Jan 07, 2010 | 1989 Volvo 760

2 Answers

What causes engine to hestitate and lose power-get up & go?


It could be a few things..The map sensor,Throttle position sensor,Fuel pump,Mass air flow sensor..

Mar 31, 2009 | 1989 Buick Regal

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

81 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Kevin Daniels

Level 3 Expert

1455 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...