Question about 1999 Mercury Villager

1 Answer

1999 Mercury Villager: The blow motor resistor quit a couple months ago, and we replaced it. Now there is a burning smell coming from it again. Any ideas why, and how can we fix it?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mercury Master
  • 4,369 Answers

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2000 Mercury Villager and the fuses for the turn signals and brake lights keep blowing. Why?


A burning smell is an important symptom of something VERY WRONG. Get it towed to a repair shop, and get them to trace the wiring harness.

Aug 21, 2015 | 2000 Mercury Villager

1 Answer

Car heater blowing cold air and rubber burnning


If your heater is spraying a light mist through your vents it could be your heater coil. Mine did the same thing, smell rubber burning, then started a light mist through the vents. If you don't get that checked out, it could mess up your water pump and possibly your engine

Jun 22, 2014 | 2000 Chevrolet Cavalier

1 Answer

My 2001 grand marquis heater turns on but wont blow i smelled a strange smell before it quit


Could have been the resistor or the blower motor. It was probably a burning wire smell.
Check the blower motor for power and ground.

Jan 22, 2014 | 2001 Mercury Grand Marquis

1 Answer

Replaced reistor on blow about two months ago that thing that looks like a credit card and than it was fine but now last week it stop working the front blower wont come on but the back will blow


the front blower motor located near the resistor has to be replaced a bad motor can cause the resistor to burn out draws to much amperage you wont need to replace the resistor again

Jan 15, 2011 | 2004 Dodge Durango

1 Answer

1999 mercury villager put in new blower motor and resistor. Every so often when change modes from defrost to lower for example or on start up it blows the front blower motor fuse. the blower motor is a...


it could be the electronic blend door motor. Try not changing any settings for a week and see if the fuse blows. Leave it on floor/defrost.

usually it is the bearing in the blower motor going bad. I believe it's a 25 amp fuse. The motor draws about one amp for each volt increase up to 14 volts.

go to our site for more help.

http://groups.yahoo.com/group/villagerquest/

Feb 02, 2010 | 1999 Mercury Villager

1 Answer

1999 mercury villager put in new heater blower motor and motor blows but nothing out the vents and which way is motor supposed to turn


If it is factory Ford/Motocraft motor, it has an arrow on it for direction of rotation. Pull the hose off the motor and see if air blows out of it. It cools the bearing on the motor. If air comes out, dircetion is ok. Report back

Jan 24, 2010 | 1999 Mercury Villager

1 Answer

Car running rough when raining


check the spark plug wires, put water in a spray bottle and spray along the wires,especially by the coil,if the car starts to run bad or you see sparks, the wires are no good, hope this helps, Ray

Apr 03, 2009 | 1999 Mercury Villager

1 Answer

The heater resistor burns


it's because your blower motor is about to go. It is drawing too much current.
Buy on Ebay or at tascafordparts.com. New is better.

see site for our villager forum. lot's of help.
http://autos.groups.yahoo.com/group/villagerquest/

Please rate as fixya if this solves your isue. Thanks

Mar 02, 2009 | 1999 Mercury Villager

Not finding what you are looking for?
1999 Mercury Villager Logo

Related Topics:

154 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

fordexpert

Level 3 Expert

5470 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...