Question about 1993 Ford Aerostar Extended

2 Answers

Electrical running lights and dash lights don't work

Posted by on

  • scjPDX Sep 23, 2008

    I have the same problem with my 93 3.0L Aerostar. I checked fuses and they are all good. If I ease the headlight switch out, at a point just before the headlights engage, I get the dash lights and the running lights. But if I pull the switch all the way out, the headlights engage, but the dash lights and the running lights are gone.



    I suspect the headlight switch is bad and needs to be replaced.

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Turned out the the switch was bad, as I suspected, and needed replaced. In my situation, I also had a broken wire that needed re-soldered. More $$ than I wanted, but it's fixed now, and also no longer a safety hazard.

Posted on Oct 15, 2008

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 8 Answers

I had this problem once in an old Tempo and am experiencing it in my 1993 Aerostar. It was the headlight switch. It has a sort of coil inside that allows you to dim dash lights and turn on dome light. I could be wrong, but...hey..check it out ;)

Posted on Oct 15, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Electrical problem


I doubt the problem is a fuse altho you could check them to make sure.
The dash lights and tail lights are on two different circuits controlled by the headlight switch. Each circuit would need to be tested.

May 08, 2013 | 1994 Mitsubishi Eclipse

1 Answer

99 chevy dash,parking running lights don't work!


did you replace the dimmer switch on the dash by the headlight switch

Aug 26, 2012 | Cars & Trucks

1 Answer

Dash lights and tail lights don't work


Lights and electrical circuits are sometimes in pairs so that you notice something is wrong (tail lights and dash). On a '90 merc grand marq., that would be fuse #4,the 15 amp blue one, in the panel next to your left foot. If you are lucky,it
just failed from age. If you are not lucky, there is a short in the system containing
the dash, tail,parking,side marker, license lamps and trailer tow relay if equiped.I had to replace the push/pull main light switch which was shorted. If you are lucky, just replacing the fuse in the panel will do it. Referance Grand Marquis Owners Manual for fuses and function.

Apr 12, 2012 | 1990 Mercury Grand Marquis

1 Answer

I have a 1993 Dodge dynasty and I changed the fuses for the dash lights and running lights. They still don't work. Were do i go from here?


you might have a a wire lose causing it it not to work,I would look and see if their is a lose wire somewhere cauing your lights not to work I hope that helps you Good luck ED...

Feb 21, 2012 | Cars & Trucks

2 Answers

My gages don.t work on the dash


You have a faulty instrument cluster.Replace instrument cluster

Dec 02, 2011 | 2000 GMC Sierra

1 Answer

I just bought a 1988 Cadillac Brougham now i would like to fix a few electric things that don't work. Those are the interior lights the automatic door locks and the radio makes strange cracking noises....


the cracking noise in the radio sounds like a ground wire being on loose...the interior lighjts run off a fuse located under the dash next to your hood latch

May 18, 2011 | 1988 Cadillac Brougham

1 Answer

Dash lights work, but chuster lights don,t


i had to disconnect the battery and reconnect on my daughters car and that solved her problem, worth a try!

Jan 27, 2010 | 2002 Ford Taurus

2 Answers

All the running lights work minus the rear tail lights but the brake lights work and the bulbs look good


I have a f-250 super duty,2001, dash& running lights don,t work, found a 15 amp fuse blown in engine compartment. fuse,s keep blowing. please help.

Jan 16, 2010 | 2003 Ford F250 Super Duty Crew Cab

1 Answer

Gage,s on dash don,t work...ac control panel don,t


part of the cars computer may be fried or you have some fuses out that control the gauge cluster.

Nov 19, 2009 | 2005 Nissan Maxima

Not finding what you are looking for?
1993 Ford Aerostar Extended Logo

114 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60867 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...