Question about Chevrolet Impala

1 Answer

Were is it located hooked up wrong when jump starting battery it sparked and after driving it home car now has NO POWER

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 22,219 Answers

Check main fuses in power distribution box under the bonnet ,if all ok then renew the alternator as it should be protected with a zena diode ??but??'

Posted on Apr 04, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Has been running perfectly fine, drove it home this afternoon, parked on the driveway. went to drive it tonight and it won't start, it won't even turn over.


Year make and model might help a bit. Things to check for are starter, alarm, spark, fuel. Does it make any noise while cranking, does it crank. The more info you supply the better the answer

Mar 14, 2015 | Cars & Trucks

1 Answer

Huskee LT 4200. I jumped the battery to get it to start. I mowed for 45 min, turned it off, added gas, starting mowing again for 30 min. Turned it off & now it won't start, turn over or crank. I...


try tapping the starter lightly with a small hammer to rule out a stuck armature. Also make sure all of your connections are tight.
Please explain how you "jumped" it. was it with another battery?

Jun 18, 2013 | Cars & Trucks

1 Answer

1998 nissan altima does not start


Does the engine crank or do you get a click noise. if you getting a clicking then the start is bad, if the engine is cranking you will need see if are getting gas to the engine and also spark to the spark plugs. if it cranks then look at a crank position sensor

Oct 31, 2012 | Nissan Cars & Trucks

3 Answers

Hi, I have a 2008 Pontiac G5 and I accidentally kept the lights on all day. Since I only have a positive (red) connection, I ground the negative connection to metal as well as the other car negative...


sounds like you are on the right track. Hook the jumper cables up to the dead car first. The red cable should go to the jumper terminal as you mentioned and a good place to hook up the black cable is the bolts on the strut tower.

then with the other car running hook up the red lead to the cars positive battery cable and then the negative to a good ground. Let the two cars sit for about 5 to ten minutes to give the dead battery a chance to charge.

Once the dead car is started let it idle with the lights turned off for at least 45 minute to an hour or drive it for the same amount of time with the light on (I assume you will be driving in the dark) or if its day time drive it for 30 to 40 minutes with the lights off. This should be enough time for the alternator to charge the dead battery.

Jun 24, 2011 | 2006 Pontiac G5

1 Answer

Trying to locate the fuse that is for the power steering for a 2007 Chevy Equinox....battery needed to be jumped and lost the power steering


Before continuing with your power sreering problem, please review these articles:
Where's The Fuse?
What Else Could Be Wrong?

The fuse for the Electronic Power Steering (EPS) is marked "EPS" and is located in the underhood fuse block on the left side of the engine compartment. It is an 80 Amp fuse. If this fuse was blown as a result of jump-starting the engine, something must have gone terribly wrong! Like - maybe the cables got hooked up backwards or something? You probably have some serious computer system damage...I would get prepared to spend some BIG BUCKS!

Apr 12, 2011 | Chevrolet Equinox Cars & Trucks

3 Answers

Hi my battery went flat on my car and the guy that jump started it put the neg 2 pos etc.. there was smoke and a spark. i tried driving but it kept losing power now it doesnt do anything, Do u have any...


first check the level of water in the battery...if its totally dry, get a new battery and don't even mess with it. if its a maintenance free battery and more than three years old, replace the battery! try to replace with with nothing less than 600 cold chanking amps! i don't know where you live but if you live in a colder climate you'll need probably a 900 cca! first off, when a person jump starts your battery you are not supposed to hook up the negative to the dead battery..you find a good solid piece of metal on the engine to clip it on to.also when you have hooked it up correctly get in the good car and rev it to 2k for about two minutes to give the dead battery a charge then try to start the other car..if it doesnt start it my need a better engine ground. sounds to me though that just buying a new battery would solve all your problems!

Mar 20, 2011 | Mitsubishi Diamante Cars & Trucks

1 Answer

We have a 1999 chrysler 300m and long story short my husband hooked up a new battery wrong and started sparking, he did unhook the battery then hooked it back up the correct way and the car did start, but...


Hooking up the battery wrong probably shorted out the alternator so that it not charging. The car was running off the battery and discharged it causing the lights to turn off and the car to want to stall. You will need to have the electrical system checked for damage.

Jan 23, 2011 | 1999 Chrysler 300M

1 Answer

I PUT A NEW ALTINATOR /NEW BATTERY/NEW DISTRIBUTER/ROTOR BUTTON/PLUGS/PLUG WIRES/DISTRIBUTER CAP/POWER STERING PUMP/IVE HAD TO GET JUMP START TO START IT /I HAVE NO HEADLIGHTS/DASHLIGHTS/NO BLINKERS /NO...


make sure all battery and alternator and starter connections are fully connected plugged in and clean.. also check the metal ground clip under youre coil pack to make sure its grounded correctly..

Feb 23, 2010 | 1985 Oldsmobile Cutlass Supreme

1 Answer

Car won't start??


Remove the serpentine belt and see if it cranks over. Something in that area screwed up to cause all that to happen. Breaking power steering pump pulleys is rare. I am assuming from your description that the starter won't crank the engine. If I am wrong please clarify.

Jun 29, 2009 | 1999 Ford Escort

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

106 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8518 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...