Question about 1997 Chevrolet S-10 Pickup

1 Answer

I have a 97 s-10 2.2 motor but will not charge? I hae changed the alt. and cleaned the ground connections and changed the battery.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

All I can say is that it is a very simple system. It has three fusible links. You should check those fusible links first, and then check wiring. I am providing the diagram here for easier troubleshooting by measuring voltages.

Cheers


I have a 97 s-10  2.2 motor but will not charge? I - _1108.jpg

Posted on Apr 02, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Won't charge Changed alt starter battery still won't charge


did you get it started ? if you did just use a volt meter and turn it to DCV put one end of probe to ground and one to power lead on alt. and see the reading it should be 12.5 to 13.5 or better,is everything connected properly ,power and ground.my question is what are you working on? year make ,model motor size ?

Mar 24, 2016 | Cars & Trucks

1 Answer

I have an '02 Buick Rendezvous with a problem with the charging system. I got a new battery but haven't changed the alt. Some people have told me its the alt wire that charges the batt. Please help.


Yes that is true BUT
most of the time this is simply a dirty cable to battery connection.
Did you clean the cable connection down to silver color inside when you changed the batt? Folks buy new batts all the time when all they needed to do was clean and tighten them.
With the engine running put volt meter test leads one to ground and on each side of of alt out wires one then the other. should be 13+ volts
then put them on each side of battery and it should be the same. If not take it to the Auto PARTS store and have them check the alt for free.

Hope this helps Mike

Mar 06, 2016 | Buick Cars & Trucks

1 Answer

1997grand cherokee inline 6 cyl.good batery & alt. what's causing it not to charge batery ?


make sure all connections are clean and free of battery corrosion is the battery "really"good it might need more water in it they run out sometimes always check the ground areas make sure they are clean and touching bare metal

Mar 15, 2013 | 1997 Jeep Grand Cherokee

2 Answers

01 Kia Sephia charging system won't keep car running. Alternator and battery are both good. Is there a fuse that connects the two?


have you tried cleaning the batt terminals and make sure the plug on alt is in and the bolt that holds the one wire is tight in the alt

Jan 19, 2012 | Kia Sephia Cars & Trucks

2 Answers

Charges ok, battery was replaced, connections cleaned and painted,ran fine for almost three months, then battery went flat again, checked altenator clleaned and greased connections, van ran fine for any...


I would check and clean any wire and connection between the alt and the battery and all grounds. Also check and see if charging voltage is the same at the battery post as it is at the lug on the alt.

Feb 20, 2011 | Chevrolet Venture Cars & Trucks

1 Answer

03 intrepid not charging new alt pcm battery all connections good .power up field wire charges ok?


A good multi meter would do you some justice it sounds like , from new components and statement sounds like a missing ground , if the motor has been swapped out check all the fram to ground connections as well as any moter mount ground bridges , a charging system is rather simple (make a complete circuit) , wire harnesses make this a chore to trace down but provides a factory working condition ,. To just trouble shoot charging is done with the field wire to batt pos , and earth (ground) to alternator case . good luck!

Oct 26, 2010 | 2003 Dodge Intrepid

1 Answer

I have a 1995 subaru legacy. battery looses charge. i tested the battery and it test good. i had alt checked on the bench tester and it passes bench test but will still not charge battery? could there...


Sounds like a bad Earth connection. Check all the battery and earth leads where they connect to the Battery, Engine, Starter Motor and Body. If possible disconnect, clean and reconnect.

Aug 31, 2010 | 1995 Subaru Legacy

1 Answer

New alternator didn't charge battery. (2VDC


As the car re-started, the battery is not flat.
The voltages measured indicate a problem with either the power or ground connection in the circuit between the alternator and the battery.

You likely have a intermittent / poor ground connection somewhere in the power system.
Check battery terminals are clean and firmly attached.
Check battery cable and alternator ground connections are intact and in good order.

Oct 29, 2009 | 1999 Chevrolet Cavalier

1 Answer

Clicks when you go to start it


Why change battery and alt? Both failed together, not likely. Clicking of the starter solenoid has for decades been a battery gone bad or a starter issue. Solenoid or starter motor brushes etc. What relationship has the sitting and not starting have to do with it. The alt only keeps the battery charged if it the alt can not supply the current needed to run the veh and draws on the battery. That battery keeps the computer memories live and turns the starter over. New battery. Are all the ground wires clean and tight? There may be Relays for the starting circuit. Please do not throw parts at it. Take it to the very best, close by repair facility or dealer. These vehicles are very complex today and even with my 45 years experience,some professional we can't keep up.

Sep 25, 2009 | 2003 Chevrolet Tahoe

2 Answers

Battery wont stay charged


Check the alternator is charging.
Check dash indicator 'BAT' lamp lights when Ignition on prior to starting motor,
Battery terminal voltage should be 14.0 - 14.5V with engine running and headlights on.
Ensure battery terminals are clean and firmly attached - ensure chassis ground is properly connected.

Sep 22, 2009 | 1986 Nissan Sentra 4 Door

Not finding what you are looking for?
1997 Chevrolet S-10 Pickup Logo

128 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8210 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...