Question about 2005 Ford F-150

1 Answer

My battery guage keeps going high when I run my truck but when I turn on the lights it stays the same. Today I had it checked for my battery and alternator and they were good. When I drove off the guage was marking high and the charging system light came on. When I got home I let it sit for a while and then ran it with the lights on and the guage was normal. I don't know what could be the problem. I have

Posted by on

  • Anonymous Mar 30, 2011

    How was the Alt Tested ?
    Was it tested for A/C Ripple
    Was a scope put on it
    Unloaded,no lights on it, overcharges

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 880 Answers

It sounds like the voltage regulator is failing.

Posted on Mar 30, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Amp guage works but battery light is on what is problem


Is that 16 AMPS or 16 VOLTS?? Should be volts from what I remember. 16 volts is WAY to high. Between 12.5 and 14 is normal. So either you have a bad alternator or bad battery or both. If you do not need a hot shot to start it then I would say the alternator. If it stays this high it will affect all electrical systems in the vehicle including the computer. It WILL cook them.

Sep 24, 2014 | 1997 Isuzu Rodeo

1 Answer

What is making my 2005 Silverado's blower motor stay on high even when the truck is turned off? It keeps running, it drained my battery.


Your BCM (body control module), must have gone bonkers. Have it checked out. Might just need a little tweaking-like re-setting.
Good luck.

Dec 05, 2011 | 2005 Chevrolet Silverado

1 Answer

Battery light & brake light flashes on & off. went to parts store & had battry & charging system checked. was told battery was bad , bought new one .problem still there not as bad...


You need to get a volt meter on it. Your battery should be around high 12 to 13 volts while not running, and increase a little without going over 14 1/2 volts running.

Aug 11, 2010 | 2007 Nissan Titan LE

1 Answer

Durango check guage light on - ONLY the battery guage is high


You need to check the alternator regulator. if it lets the alternator go free, it will burn out the diodes.
This is a skilled task. If your not sure get help.

Mar 27, 2010 | 2000 Dodge Durango

1 Answer

Temp guage stays on cold and engine warning light


You more than likely have a thermostat that is stuck open. When this is the case with the computerized vehicles today the computer tells your engine that it is still cold and dumps more fuel to the engine. When this happens the extra fuel goes through your exhaust and uaually makes the check engine light come on as you have O2 sensors that register this flow. Replace the thermostat, disconnect the negative side of your battery for 5 minutes and re-connect. If this has been going on for a while the light may come back on. You may have to drive it for a while until it clears all the excess fuel out of the system then do the battery thing again. You probably have been getting poor gas mileage as well. Hope this helped. Just make sure that the engine light does not flash as this is a sign of major problems and you should not drive it if it flashes

Feb 06, 2010 | 2005 Ford Mustang

1 Answer

My car's inside fan stays on even when off mode


the blower motor resistor is probably the problem with the blower staying it,

Jan 24, 2010 | 2004 Pontiac Grand Prix

1 Answer

Check guages light came on , 9 volts on guage,\radio died. charged batt. ran yesterday, today it wont start. battery has 12 v. turns over but no start.no guages work,when key is on. checked fuses,ok. no...


The main problem is the alternator has went out,and the battery voltage dropped to low for it to run.Most likely the computer has lost memory sense the battery was dead,or close to it.I don`t know the year,but this is most likely what happened.The computer would have to be reflashed at the dealership.But be sure to look for a main fuse to be blown,check all fuses,this might have happened,and not the computer.

Nov 03, 2009 | Dodge Pickup Cars & Trucks

1 Answer

2000 Jeep Grand cherokee Laredo wont start. Engine turn over . No noise from fuel pump with ignition on. Replaced fuel pump and filter.Turn ignition on- pump did not run.Jumped the fuel pump at the pump...


sounds alot the the pcm it controls the fuel pump and ign system but the anti theft would keep it from starting because the key has a transponder in it programmed for that vehicle and that would kill all ign if triggered

Sep 22, 2009 | 2000 Jeep Grand Cherokee

1 Answer

We have a 1996 Cadillac Broughm, and today while driveing home the whole back end went high in the air, and the front end stayed down wards, when we turn the car off, it almost sounds like it running a...


Check that the arm that goes between the rear axle and the level control on the body has not come off or broken. You can pull the fuse temporarily to keep the pump from running so the battery does not go dead.

Apr 21, 2009 | 1996 Cadillac Fleetwood

4 Answers

Electrical problem


I finally broke down and took my truck to the dealer. It took them two tries, but they finally figured it out. It turned out to be the wiring harnes for the shift lever. When it exits the steering column, it was being chafed, and eventually wore through a wire and was intermittently shorting. It would blow a fuse (don't remember which one - I think it was on the bottom row, third in from the right. 20A). It stopped the alternator from charging too. They replaced the shifter harness and the problem went away. I did get a ticket while my speedo was inop however.

Jul 18, 2008 | 2003 Ford F250 Super Duty Crew Cab

Not finding what you are looking for?
2005 Ford F-150 Logo

Related Topics:

76 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

77202 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22265 Answers

fordexpert

Level 3 Expert

5581 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...