Question about Chevrolet S 10

2 Answers

I have a 1989 chevy s10 4x4 4.3 fuel injected. It cranks right up and when I go to press the gas while in drive it wont go anywhere. It back fires and cuts out. what do you think it might be?

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

This sound like fuel pump check the pressure

Posted on Dec 01, 2011

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 52 Answers

Probably a bad O2 sensor. Had the same problem with an 88 S-10 Blazer, I changed the MAP, MAF, and Idle sensors none of those fixed the problem, then I changed the O2 sensor and the truck ran like a champ.

Posted on Mar 30, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Throttle body problems


Possible fuel pressure regulator stuck open or fuel pump anti-drain valve(part of pump), causing excessive bleed down .

Feb 05, 2014 | Cars & Trucks

1 Answer

1989 TLC Gas engine...wont start


Check to ensure fuel pump fuse hasn't burned out. Try spraying starting fluid directly into the throttle body to see if it tries to catch.

Nov 16, 2013 | 1989 Toyota Land Cruiser

1 Answer

1989 chevy van won't run.


Check the air filter (may be very dirty), carburetor may need thorough cleaning, or, if fuel-injected, the injectors may need cleaning. The fuel pump may also be malfunctioning....remove the outlet hose from the pump, place another hose onto the pump and drain it into a container so you don't lose the gas, and have a friend crank over the engine while you watch to see if gas spurts out quickly and abundantly into the container. IF NOT, then you will have to fix the fuel pump, or replace it.

Sep 20, 2012 | Cars & Trucks

1 Answer

It usually cranks and starts within seconds, every other day it will crank and crank and crank before starting, pressing the gas pedal doesn't seem to help or hurt, I'm afraid one day it will crank until...


your vehicle is fuel injected you should not have to pump the gas pedal plugs and wires ill bet that solves your problem and changeing the fuel filter wont hurt and a fuel injection cleaning wont hurt if you havent had one done to it

Nov 30, 2010 | 2002 Ford Expedition

1 Answer

1995 chevy corsica is been sitting for 3 years, we changed the battery already and used fuel starter, engine wont start still. Pls help. Tnx.


Try removing all spark plugs and crank the engine for a bit to get everything lubed up and it will give u max compression..Also replace plugs and fire some carb or injection cleaner in some high octane gas........Hope this helps.

Aug 14, 2010 | 1995 Chevrolet Corsica

1 Answer

1999 Chevy C3500 with a 5.7L SFI wont start


a crank position sensor could be bad or your cam position sensor could be bad

Jun 06, 2009 | 1998 Chevrolet C3500

1 Answer

Wont stay cranked


chek your injection nozzles they maybe clogged , also the fuel filter

May 31, 2009 | 1989 GMC S-15 Jimmy

2 Answers

1987 chevy s-10 2.8 motor. Wont start and gas present on plugs. Getting fire and fuel. TBI injection. New plugs wires cap and rotor. Checked TDC and checked firing order.


Is it flooded? Have you tried holding the accelerator to the floor? You have gas spraying out of the injectors when cranking? Does it even try?

Mar 27, 2009 | 1986 Chevrolet Camaro

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

220 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8514 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...