Question about 2001 Chevrolet Impala

1 Answer

My '01 impala 3.4 v-6 flat spots when COLD, at around 20mph. the idle is ruff with random misfires. acceleration is overall poor. when HOT, most symptoms go away leaving only some slight acceleration resistance. full throttle acceleration will by pass the flat spotting of speed/rpm's wheather COLD or HOT. ALLREADY DONE is new plugs/wires, 02 sensors (2), maf sensor, 2 coil packs, crankcase speed sensor, fuel filter, fuel pump checks ok. we have a new ecm brain ready to program and try. The joker is:...my oem 3.4 went bad and this is a replacement '00 olds 3.4, with 64,000 mile (so it sat up for 5 to 6 years. Yes, it was serviced and fluids/filters changed on installation ( I checked it). But i suspect the installer of sabotage since he owed me the labor from a previous botched repair job and didn't want to do this install to begin with.............my current shop is frustrated.......help!!

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 5,370 Answers

Depending on mileage, but possible tune-up could fix it. if already done then check ignition coil pack and ignition wires also spark plugs, check vacuum hoses for leaks or porous, last injectors clogged - use some techron fuel injector cleaner (wal-mart has them). Also get the throttle body and iac valve cleaned by throttle cleaner . Also this other possibilities are to be checked and confirmed.:---- Engine running rough or misfiring can be cause by the following:

1.Defective spark plugs
2.Inadequate spark/coil, defective spark plug wire.
3. Lack of compression
4.False air leakage.
5. Faulty fuel injectors.
6. Insufficient fuel pressure.
7. Contaminated fuel.
8. EGR valve that is leaking.
9. Oxygen sensors.
10. Throttle position sensor.
11. Manifold absolute pressure sensor
12.Mass Airflow Sensor
13.Idle air control valve

--------- This should help.Keep updated.Thanks.Helpmech.

Posted on Mar 27, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

WHY IS IT IDLEING RUFF


P0300 Dodge P0300 Dodge - Cylinder Misfire Fault Detected Random Cylinders Possible causes
- Faulty spark plug (s)
- Faulty ignition coil (s)
- Clogged or faulty fuel injector (s)
- Intake air leak
- Fuel injectors harness is open or shorted
- Fuel Injectors circuit poor electrical connection
- Ignition coils harness is open or shorted
- Ignition coils circuit poor electrical connection
- Insufficient cylinders compression
- Incorrect fuel pressure



Jun 08, 2014 | 2006 Dodge Magnum

2 Answers

02 ford windstar sometimes it chuggs going down the road changed the master air flow housing and sensor also changed the fuel filter what other reasons would it still be running rough???


CEL glows running?
scan codes stored, use a scan tool ,
chuggs. my guess this is misfire.?
misfire code is P0300 (random) either stored or in pendings
misfire has many reasons.
1 cylinder is like P0301 #1 misfire.
P0300 all cylinder, so not knowing what codes is stored, makes diagnoses, endless.
also does it misfire hot or cold engine or both
going down the road, flat, hills, steady cruise, fast right foot only.?
just a hint of when, and how.? WOT up hills> (wide open throttle)

misfire is under BASICS.
1`; poor compression on hot motor? if fails hot.
2: bad spark ever consider doing the 60k mile listed tune up? if not why not? all steps. not just 1 filter.
3: bad fueling.
4: stuck open EGR (covered under 60k, clean it.)

there are tests for each fail point. above.

use a scan tool, no scan tool the job is 100 times harder.

Oct 23, 2013 | Cars & Trucks

1 Answer

My 1996 tahoe is giving me cylinder 2 misfire And runs ruff idle


For engine misfiring problem check the help links mentioned below. Click the link below to go through the troubleshooting procedure :---- Engine misses and truck jumps? Hard to down shift? Issue with high gear only? http://technoanswers.blogspot.in/2012/02/engine-miss-and-truck-jumps-hard-to.html

-----------
Bad miss at idle?

http://technoanswers.blogspot.com/2012/01/bad-miss-at-idle.html

-----------
While stop engine idles like cylinder missing?

http://schematicsdiagram.blogspot.com/2012/01/while-stop-engine-idles-like-cylinder.html

------------
Engine Misfire codes for car?

http://schematicsdiagram.blogspot.com/2011/12/engine-misfire-codes-on-chevrolet.html
Engine Misfire codes?

http://schematicsdiagram.blogspot.com/2011/12/engine-misfire-codes-on-chevrolet.html

--------------
Misfire on cylinder 4?

http://schematicsdiagram.blogspot.com/2011/12/misfire-on-cylinder-4.html

-----------
Oil on spark plugs and car misfires?

http://technoanswers.blogspot.in/2012/02/oil-on-spark-plugs-and-car-misfires.html

----------

This will help.

Thanks.

Feb 14, 2012 | 1996 Chevrolet Tahoe

2 Answers

I have a 2000 impala with the 3.4 and 160,000 miles on it. The other day white smoke started pouring out of the exhaust and the #6 cylinder was not firing. I changed the head gaskets, upper and lower...


double check your firing order and make sure all wires and hoses are plugged in good. when you pulled the push rods out did you make sure they went back exactly where they came out because there are 2 different lengths.

Oct 22, 2009 | 2000 Chevrolet Impala

1 Answer

Hi, my problem is about the engine idle cold because if its hot the rpm rises a little enought so it doesn't do the trouble that it does when i accelerate it, so the troubble is like a failure in the...


Check the throttle position sensor, map sensor and obviously the condition of the ignition system overall. Your injection system is also suspect in that dirty injectors may give a poor spray pattern that can cause low speed miss (though electrically they appear to be OK)

Jul 16, 2009 | 2000 Jeep Cherokee

Not finding what you are looking for?
2001 Chevrolet Impala Logo

286 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...