Question about Toyota 4Runner

2 Answers

1995 tpyota 4 runner, v6,standard, 4x4. no check eng. lite on.while driving, loss power. leak down test ok. changed out plugs and wires which were carbon up. rotor and cap. no help. changed out mass airflow meter, no difference. what do u think, cts or tps. please advise

Posted by on

  • 1 more comment 
  • edward lai Mar 26, 2011

    the veh. idles at 4 to 500 rpm, almost stalling. u think this is a electrical issue

  • edward lai Mar 26, 2011

    1995 toyota 4runner, v6, standard 4x4. done a tune up, wires, plugs,rotor, cap.poor idle, lack power during accelaration. changed out the maf sensor, no help. performed a leak down test. all good. please advise

  • edward lai Mar 28, 2011

    thanks

×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 3,530 Answers

Welcome to Fixya

Please see below list that would possibly lead to your ongoing issue with your vehicle.

Check and test the following below:

Oxygen sensor
Dirty fuel injectors (cleaning the injectors often fixes this).
Bad MAP (manifold absolute pressure) sensor
Bad TPS (throttle position) sensor
Bad or dirty MAF (mass airflow) sensor
Low fuel pressure (leaky fuel pressure regulator or weak fuel pump)
Vacuum leaks (intake manifold, vacuum hoses, throttle body, EGR valve)
Bad gasoline (fuel contaminated with water or too much alcohol)

Thank you for using Fixya!

Posted on Mar 26, 2011

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 3,513 Answers

Hi

Unless you are driving a diesel, an engine needs electricity to run. The power steering and power brakes are dependent on the engine running. Is the battery holding charge? Check the cables on the battery/fuse box to make sure they are not loose. Also check your Alternator. A dead alternator could be your problem. Your car runs off the alternator when it's running, only uses Battery when it's off. Accessories also run off the battery when you're driving (DVD/cd players, speakers, amps) all of this drains the battery and the alternator recharges it. Check for a loose connection first, and then test the Battery and Alt. Also check for the sound system.

Please get back to us if you have further query else please accept the suggestion.

Posted on Mar 26, 2011

  • Aparajita Batabyal
    Aparajita Batabyal Mar 26, 2011

    Hi



    I told you the various factors behind the loss of power,first you check those probability ,you can check it by your own or take your car to the nearest auto shop.Till then nothing can be confirmed about what has gone wrong.



    Thanks for contacting fixya.com

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Loss of Power on my Opel Corsa lite 1.4 2008 model. Car has 131000kms on. i changed the Fuel pump and still same problem, New Plug wires still no Joy. what could be the problem


Loss of power when ? All driving conditions , Up hills ,steady cruse, hard acceleration. Could be a plugged catalytic converter ! pull O2 sensor and see if it's better or do a back pressure test so you know for sure . Have you changed the air filter ? Before you change parts you should test ,lots of good videos on YouTube ! Testing for plugged clogged restricted exhaust converter Fuel Pump Pressure and Regulator Test

Jan 26, 2015 | Opel Cars & Trucks

1 Answer

1992 Toyota 4x4 V6 engine


check for a failed cat converter as it may be blocking the exhaust system

Oct 30, 2013 | 1992 Toyota Pickup

1 Answer

I have a 1997 lumina with 3.1L. the problem started with loss of power under load and p0300 code. check coils and vacuum leaks both OK.change spark plugs and wires.[same problem] check compression OK.


Since you changed the sensor we will assume it is working. When you disconnect it you put the computer in limp mode which stops it from using sensor values. If code 300 is the only code we will assume the coolant temp sensor and others are ok.
I would check fuel pressure with a gauge next.

Aug 21, 2012 | 1997 Chevrolet Lumina

1 Answer

Hi, i have a 1991 isuzu rodeo with a 3.1 v6 5sp 4x4 with tbi. It starts ok when its cold and seems to run just fine however once its warmed up if you shut it down it wont restart. this was a sudden thing....


You might want to check the coil after the engine has wormed up to see if it is breaking down and not fireing the spark plugs. Use an in line spark tester to check between the coil and the spark plug wires to see if it is firing the plugs after the engine has gotten worm. Have someone to turn the engine over while you watch the tester for fire. Hope this will help you.

May 19, 2010 | Cars & Trucks

1 Answer

2000 Toyota 4 Runner, 3.4L, 6 Cylinder. Engine


look at the plug wires they are known to bust when old near the boot

Apr 28, 2009 | 2000 Toyota 4Runner

2 Answers

Runs real lean and surges under throttle massive loss of power


if you have a vacuum guage handy hook it to your manifold and if your reading is under 15 hg then you have a manifold gasket leaking or you could just replace the gasket.

Apr 28, 2009 | 1995 Toyota 4Runner

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

36 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8180 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...