Question about 2000 Chevrolet Venture

2 Answers

New thermostat and water pump still runs hot - 2000 Chevrolet Venture

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Head gaskets

Posted on Mar 30, 2011

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 72 Answers

Radiator may be leak

Posted on Mar 25, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have a 2003 gl1800, running hot, put in new water pump and all new gaskets, still running hot, any suggestions


Check that the thermostat is opening properly, then i would check that the radiator cores are not blocked also as you have just replaced the water pump make sure you don't have an "airlock" somewhere in the system.

Oct 15, 2016 | Cars & Trucks

1 Answer

95 sentra running hot put two thermostats on it, what else is wrong...plus water runs everywhere?


Here's a link to replace your water pump.Here's how to replace thermostat,If your water pump is leaking,there will be antifreeze coming from it.

Mar 25, 2013 | Nissan Cars & Trucks

1 Answer

Engine temp reading 3/4,new water pump,new thermostat,clean oil and new filter,no sign of water in oil,no steam out rear pipe,engine runs poor once hot,water pipes not tight when hot.head gasket? what you...


Remove thermostat and run the vehicle. do your hoses get tight now? If so, your new thermostat was not opening up. test it by putting it into a pot of water and bring up the temp on your stovetop. if the water boils, and the thermostat isnt open, then get a refund and a new thermostat. Be sure to point the spring end of the thermostat into the engine block when replacing. If your thermostat did open, then your water pump may be shot.

Nov 22, 2010 | Suzuki Swift Cars & Trucks

1 Answer

I have a 2000 nissan maxima and just recently i noticed it was running hot. so i took it to my mechanic and he advised i needed a new water pump. so he replaced the water pump and he is saying it is still...


hot engine usually due to clogged radiator or bad thermostat. Take out the thermostat and make sure it is opening fully in boiling water.
Look inside your radiator for signs of clogging. If yes, professionally flush or replace radiator.

Aug 22, 2010 | 2000 Nissan Maxima

1 Answer

Overheating: 1999 bmw 323i m series 2.5 ..Installed: new water pump , thermostat. radiator,new Water Reservoir, cap.. hose on top side hot , lower hose cold even when engine is hot..no water circulating at...


the water pump and thermostat should have solved it. an air pocket can cause that but usually not to that degree.

don't get one of those cheap *** plastic impeller water pump for sissies. Get the metal impeller one. get a cool running thermostat and drill two 3/16" holes in it 180 degreess from each other. you may have installed the t-stat backwards.

Jun 03, 2010 | 1999 BMW 323 Series

1 Answer

Van running hot replaced water pumb thermostate


my car still hot .we change the water pump,thermostat,coolant temperature sensor ,rad cap,and still hot the gauge is up and down??????

Dec 15, 2009 | 1999 Oldsmobile Silhouette

2 Answers

Water is not flowing in pipes


You need either a new thermostat or a new water pump.

Apr 13, 2009 | 1992 Honda Accord

3 Answers

Engine running hot after thermostat installed


This is a Classic Sign of a Dead Waterpump.

Jan 22, 2009 | 1996 Chevrolet Cavalier

Not finding what you are looking for?
2000 Chevrolet Venture Logo

Related Topics:

22 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75807 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22133 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8172 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...