Question about 1996 Oldsmobile Eighty Eight

1 Answer

Battery goes dead if not driven within 24 hours. Replaced battery - car worked fine for 2 weeks now back to same problem. Also wiper fluid pump doesn't work and power windows operation spotty.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 28 Answers

YOUR ALTERNATOR IS PROBABLY THE PROBLEM.

Posted on Mar 24, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

2010 Tucson Hyundai battery drain somewhere. Changed the battery and alternator and still after sitting for a couple of days it goes dead. Has been in many times for same issue and Hyundai can not seem...


Hi,

we have the same problem. Replaced the battery a month ago and it died yesterday again. The car is at the dealer now. They are trying to blame us for the problem. I have a feeling they know exactly whats wrong, but they are not willing to tell us, since its still under warrenty for 1 month.
Suggestions are;

- the radio might drain your battery, even when its off.
- do you have a homelink? If so, it might be wired the wrong way.

so far thats all i found out by surfing the web.

Feb 17, 2015 | 2010 Hyundai Tucson

1 Answer

2008 chevy equinox rear windshield wiper not working and battery dying. will work when jumping, but dies after being off a few minutes.


you have something draining the battery. you will need to find out were the drain is coming from. could be the alarm /radio/ external alarm module. you will need to find what is doing it. wipe motor could have a a short but that should not affect battery when the car is locked up.

Feb 05, 2014 | 2008 Chevrolet Equinox LTZ

1 Answer

When I first start up my 1995 Toyota Corolla 5-speed, there is a whirring noise. It seems more prominent when the car is cold and when I turn the steering wheel at that time. Also, the battery light has...


for the whirring noice, check for the power steering fluid level, if it's low refill with power steering fluid to the propper level. If the level its fine and the noise continues you have to tighten the engine belts via the tensioner bearings. As for the battery light it's probably letting you know that the alternator is failing, when the light comes on it means that in that precisse moment the alternator isn't charging the battery and that could lead you to a dead battery. (The alternator has a line that it's in charge of activating the battery light if this cable is loose that could make the light go on, secure that cable and if the light never comes on then the alternator is fine) Hope that helps

Jun 24, 2011 | Toyota Corolla Cars & Trucks

1 Answer

Purchased a 2009 Murano S. When the car is not


In that case, whenever u take it for a ride and return to your nest, lift the hood and disconnect the battery terminal which I would recommend having a clip(spring loaded clamps with metal jaws) removed from the battery. Next time you use it, first reattach the clamps to the batter, and start normally.......sodeep

Oct 26, 2009 | 2006 Nissan Murano

2 Answers

Its hare to turn the wheel.


check check fluid level on power steering pump

Sep 19, 2009 | 1999 Dodge Grand Caravan

1 Answer

Battery loses power for unknown reason


there definitely is some leakage or shortage within the wiring somewhere..!!!
show it to an electrician and get the wiring checked.!!!

Jan 27, 2009 | 1991 Buick Park Avenue

Not finding what you are looking for?
1996 Oldsmobile Eighty Eight Logo

75 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

80608 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8841 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...