Question about Chevrolet Camaro

1 Answer

The car runs fine when cold but after driving 10 or 15 miles it acts like its hot even though gauge says normal--hesitation on acceleration and rough idling we've also been having trouble with the radiator over pressurizing pushing coolant into reservoir. When the engine cools it doesn't pull the coolant back into the radiator.so the next time you start up the coolant level is low. IT has a new radiator,new water pump,new radiator cap new intake gasket and there's no water in the oil.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 183 Answers

Sounds like air in the cooling system.What year camaro?What engine size?Have vehicle running at operating temp and slightly open cooling system bleeder (if equiped) leave open until you get coolant only and no more air.If this doesnt work have cooling system pressure tested.Could be a blown gasket somewhere.Good Luck!!!!!

Posted on Aug 03, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Truck drives fine on flat surface but acts like it wants to die out going up hills


Surges under load but only while going uphill Page1 - Chevy High ...

forums.superchevy.com > ... > General Chevy Technical Discussion

Mar 6, 2011 - 14 posts - ‎8 authors
Trying to help out a friend. ... The truck starts, runs, and drives fine until you get to a hill. When going up hill it begins to surge, almost stalling but not quite. ... rubber fuel lines suck shut under a heavy load and act like that. .... tranny fluid level o.k.? ya got me stumped. runs great when it's on a flat surface?

Ford 460 engine - RV mechanic

www.rvmechanic.com > Discussion Forum > Mechanic's Corner - Engines
Will not take gas going up a hill but will maintain speed at 55 mph. ... Want to do a diagnostic test on my 1997 F250 with 460 engine. ... only get to about 40 miles an hour if i push it the engine acts like its running out of gas,thank you .... The truck hesitates on acceleration, while driving on flat surface is fine, however climbing ...

rough idle, stalling, loss of power. - CarGurus


Dec 14, 2015 | Cars & Trucks

1 Answer

I have subaru legacy model 2010 .i have frequent the engine stops when i am breaking to slow down in a trafic jam,the car vibrate showing engine stops if i press on the accelerator the motor will resu


Could be bad EGR valve or vacuum leak. Egr valve, depending on whether it is stuck open or closed can act like the old choke thermostats on the carburator system making the vehicle run and idle rough when it is cold OR hot but normally only one or the other. Will run fine cold but rough once it's hot or rough when cold and fine when hot. Check or have someone check for any trouble codes in the system. It can hold codes and not make the check engine light come on and may help diagnose the problem.

Jan 12, 2013 | Cars & Trucks

1 Answer

My 1998 Ford Explorer is running rough. It feels like it's hesitating or skipping, especially until it warms up. At the same time it hesitates you can hear a loud sound coming from underneath the


Did they not road test for 20 miles or take scan tool &
another person along to look at data

Maybe another few shops until you find some knowlegdable
folks

From what I see on this site that won't happen any time soon

Hate to see you at a dealer,their even worse sometimes

Nov 29, 2012 | 1998 Ford Explorer

1 Answer

Vapor lock


Ask your local technician to set up a fuel gauge pressure monitor so you can track it while your driving. Ask him what the normal range is so you will know when it falls below. Document it and let your Tech know. It sounds like your fuel pump is loosing Pressure.

Sep 15, 2012 | 1999 Subaru Forester

1 Answer

Hesitation on acceleration pulls down on hills it is cold blooded and lack of power


My brand new kia sportage 2L purchased in January 2010 gave me problems from the start. First gas tank was squeezed sometime before and vehicle kept running out of gas even though gas gauge showing gas inside. Dealer replaced gas tank. More persistent problem is the vehicle hesitates to accelerate especially if not driven for about three hours or so and when on an incline. Went back to dealer on several occasions but no solution. any ideas?

Nov 23, 2010 | 1996 Kia Sportage

1 Answer

Even though my truck is not overheating, the temperature gauge will shoot up to hot and the oil light will come on. After a few minutes, the truck will not let me accelerate anymore. If I shut the truck...


Even though my truck is not overheating, the temperature gauge will shoot up to hot and the oil light will come on. After a few minutes, the truck will not let me accelerate anymore. If I shut the truck off, it will reset the oil light and the temp gauge and run fine for a while. But eventually, it will do the same thing again. Is it a sensor or computer problem

Aug 20, 2010 | 1998 Ford F150 Regular Cab

1 Answer

Rough, shaky hot or cold starts on W202+short pwr loss mins later


Check the cable near the abs modulator. Some C180, C200 have short circuit from broken insulators

Apr 24, 2009 | 1998 Mercedes-Benz C-Class

1 Answer

Manual heating system with automatic trans. 7.3 L Diesel, 45k miles


it may be your thermostat, the gauge on the dash is a dummy gauge, there is only three positions that it sees, dead cold, operating temp, and hot, so even though the needle looks fine it just means it s closer to operating temp then it is to cold,

Jul 31, 2008 | 2003 Ford F250 Super Duty Crew Cab

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

172 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

63990 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...