Question about 1996 Geo Metro

1 Answer

I have 96 geo metro drove 15 miles and just died on me... Will not,start replaced dist. And dist cap and button,coil is getting power fuel is gettin to plugs, tried starter fluid but still nothin, fire is orange NOT blue at plugs... So what else can I try? Thanks it is 1.3 liter

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 3,400 Answers

Depending on mileage, Geo's have timing belt and it should be changed every 60k, if you've done all that's mentioned I suspect timing belt is broken.

Posted on Mar 24, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Code 303 - not electrical, what should I look at next?


Check for either a leaking injector flooding the plug or a clogged injector causing a lean misfire. Also, the injector driver in the PCM may be bad not commanding the number 3 injector on and off.

Nov 17, 2015 | Geo Cars & Trucks

1 Answer

I cant start my 93 geo metro and it smells like gas bad when i turn it over


have you checked for spark.Make sure there is no moisture in the dist. cap try to use air to blow out any water that my of found its way into dist.

Feb 03, 2012 | 1990 Geo Metro

2 Answers

Starts and dies on acceleration then will not run


crank shaft position sensor is most likely cause. Do check ignition and fuel pump relays with an ohmmeter to make sure they are not faulty. Check power to ignition module. You can also check crank sensor with the ohmmeter. Check all vacuum hose and also check throttle position sensor.

Nov 15, 2009 | 1995 Geo Metro

1 Answer

95 Geo metro will not crank no fire


take your timing cover off have a friend look to see if the belt is moving while you crank the engine i would say that the belt is broken

Oct 22, 2008 | 1995 Geo Metro

Not finding what you are looking for?
1996 Geo Metro Logo

176 people viewed this question

Ask a Question

Usually answered in minutes!

Top Geo Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8140 Answers

Are you a Geo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...