Question about 1993 Chevrolet S-10 Blazer

1 Answer

I have a 1993 chevy blazer that starts and runs but after it warms up it shuts off and won't start again. I have replaced the ignition module and the fuel filter. Anyone have any ideas?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 117 Answers

Does the truck have coil packs on it, if so they may be going bad. I had a lumina that gave me the same problem as your truck. It ran fine until it got hot and then it just shut down until it cooled off enough to start again. Turned out that the coil pack was going bad. I think there is a way to test them with an ohm meter, but i'm not sure what exactly it is. A quick search on Google should reveal the procedure. I hope this helps.

Posted on Mar 23, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My gmc 4.3 stalls when warm and wont start without ether. then it runs fine


I had the exact problem with my 1993 chevy c1500. I found that the IAC was sticking so the engine would die at idle after warming up and the ignition module was pulsing the ECM intermittently after the engine warmed up so the fuel pump wasn't being turned on after the engine died....I replaced the ignition module and the IAC valve and all is good. I don't know if testing the ignition module reveals that it isn't sending pulses to the ECM.

Mar 28, 2013 | 1991 GMC Sierra

2 Answers

Car starts and runs. Once it's warmed up, the engine shuts off tried to start it again motor turns over but will not start. Wait a couple of hours then the motor will start again and then will shut off...


Wouldn't think sensor or computer problem , more likely an ignition module . When it dies pull a plug wire an check for spark ,i think you will find no spark . Just from my 30 years of diagnosing GM vehicle's this has been the #1 cause of a start an run till warm an dies an wait 20 min . to an hour an it starts again problem. But without testing to know for sure that would be a guess . Having a qualified an certified repair technician diagnose the problem is always the best idea.

Dec 12, 2017 | 1993 Saturn SL1

3 Answers

1993 chevy blazer runs then dies and has trouble starting again


4.3. Do you know if it is TBI or CPI? Is the 8th digit of the VIN a W or Z?

Apr 03, 2010 | 1993 Chevrolet S-10 Blazer

1 Answer

93 s10 blazer runs and then dies and won't start again


check and make sure the sparkplugs are clean, I got a hunch it could be that small back module under the distributor cap, it is very sensitive to heat.

May 31, 2017 | 1993 Chevrolet S-10 Blazer

Not finding what you are looking for?
1993 Chevrolet S-10 Blazer Logo

148 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

79865 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...