Question about Ford Fiesta

1 Answer

My revs are sitting at 1500rpm and not the normal 1000rpm , what could be the problem ?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 1,975 Answers

Check for a vacuun leak. That would be where I would start. I hope this helps you and good luck.

Posted on Mar 23, 2011

Testimonial: "Thanx , i will have a look !! :)"

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Nissan navara wont idle engine runs normal above 1000rpm but once revs drop below 1000rpm engine cuts out.


Take it to an automotive repair centre. This is not something that you can fix yourself.

Feb 23, 2016 | Nissan Cars & Trucks

1 Answer

Toyota corolla hatch 2002 idle at 2000 rpm when


All the above is normal , except 2000rpm is a little high at idle . can be adjusted down to 1500rpm. the computer adjusts the engine speed . in drive the transmission loads up the engine idle drops to 1000rpm . in park engine unloaded rpm increase all normal.

Sep 17, 2014 | Cars & Trucks

1 Answer

Car won't pull back speed when foot off accelerator


Very possibly a vacuum issue. Maybe a line that needs vacuum for the trans is on an inlet that effects the throttle. Not sure how old your vehicle is.

Aug 23, 2012 | Jaguar Cars & Trucks

2 Answers

When my daewoo lanos is at idle the temperature guage sits at the normal running temperature, but as soon as the engine rpm goe above 1500rpm the temperature gauge goes to the cold position? if u back off...


-No. When you rev up, the fan pulls more air trough the radiator
so it get cooler. This is suppose to be. This is good.
-Don't worry about. You're good.
-But if you drive and temperature drop to very low then the thermostat stuck open. It need to be replace.

Good luck


Mai

Jan 19, 2018 | Daewoo Lanos Cars & Trucks

1 Answer

Clicking when try to start. Hooked to my truck with cables and had starter and solenoid tested and they are fine. Cleaned all contacts and still nothing. Any suggestions would be helpful. Thanx


That sound is typical of a battery that does not have enough amps to turn over the engine. This could be a bad battery, bad alternator or both. I would have the battery and alternator checked which most parts stores will do for you. Try jumping the battery from another vehicle with a good battery using jumper cables. Let it charge for a couple of minutes and rev the engine to 1000rpm to 1500rpm and hold it for a minute or two before trying to start your car. **Please rate me on this answer.**

Jun 24, 2010 | 1995 Oldsmobile Cutlass Supreme

1 Answer

Suzuki Vitara Fast Idle


Air control valve maybe or it could be an intake or vacume leak

Nov 17, 2017 | 2000 Suzuki Vitara

2 Answers

No accelerator, engine revs between


Always turn the other car first before connecting the cables, otherwise the computer can be damaged. Try disconnecting the battery for five minutes, then connect them again and start the engine. Hopefully this will restore normal operation.

Nov 14, 2009 | 2003 Mercedes-Benz CL-Class

1 Answer

2005 AVEO - at idle the engine revs up and down (1000rpm to 1500rpm +-). If it is idling smooth you can turn the AC on and it starts reving up and down. Think I got some bad fuel which began the problem,...


check your fuel cap when they start to go bad the pressure in the tank won't read and it will make it do that. and if it still does it then try cleaning the throttle body and the mass air flow sensor when they get dirty they can cause the same problem

Aug 22, 2009 | 2005 Chevrolet Aveo

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

45 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

79865 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

fordexpert

Level 3 Expert

5687 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...