Question about 2004 Ford Mustang

1 Answer

Car stalls and drops rpms in neutral - 2004 Ford Mustang

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 32 Answers

Clean the iac motor ( idle air contol) or replace it it sits right on the side ot throttle body about 4' long round with a 2 wire plug going in the end of it and has 2 8mm or 10 mm bolts holding it on take it off and clean it with carb cleaner

Posted on Mar 22, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Car wont hold rpms. when driving and coming to a light i shift back to neutral and then my rpms drop and my car stalls....just replaced spark plygs and air filter, changed my battery, dont know if its...


If this started when you replaced the battery then that is the problem.When you removed the battery the computer lost all information for the vehicle,you will need to have the computer reprogrammed at the dealership more than likely.

Oct 05, 2013 | 2004 Saab 9-3

1 Answer

Engine and tcs light on car stalling and rpms


p0134 is oxygen sensor fault code
p0717 is turbine shaft speed sensor (no signal) fault code

May 27, 2010 | 2001 Hyundai XG300

1 Answer

I have a 1994 Toyota Celica, lately when im in neutral the rpms begin to drop and when i give it gas the car stalls out or it stays under 2 rpms after second gear.


Look and listen for vacuum leak Free,Change air filter $15, change fuel filter$20, replace fuel pump$300.
S
With motor running and your head under hood listen for hissing sound. Then start replaceing filters first air filter , then fuel filter. Check fuel pump by listening for humming noise at gas cap when you first move key in ignition to on (when the red lights go on). Have someone listen for you at the gas cap.(NO hum need pump)

Jan 21, 2010 | 1990 Toyota Celica

1 Answer

Putting it into drive rpm's dropped to almost stalling car jerks gave it gas and it ran find. everytime i stopped i had to put it into neutral and keep rpms up above 1000


Sounds like you need a tune up,and a throttlebody cleaning.
Use 2+2 carb cleaner to spray your throttlebody until you don't see any black carbon on the throttle plate.

Aug 11, 2009 | 1998 Ford Taurus

1 Answer

Randon stall, no start


If it is the 2.5 v6 , you most likely need the distributor replaced. If it is the 2.4l cam and crank sensors would be most likely cause.

Jul 13, 2009 | 1998 Chrysler Sebring

3 Answers

Rough idle on 1990 saab 900 convertible, 16V


Because the car has adaptive technology, it may take a while to reset and adjust to the new, cleaner and better conditions than those to which it had previously adapted.

Did you change the cap and rotor? if the plugs needed replacement, likely they do too

Possible other causes include:

loose or corroded connections to any electrical component you disturbed (make a checklist and tick them all off as you check them);

mis-reinstallation of any F.I. part disturbed(checklist again)

obstructed water flow through the AIC valve;

improper voltage output from the AIC valve (for LH 2.4 systems, should output 8 volt at idle, dropping as load increases; for LH 2.4.2 system output 7 volt at idle etc; testing between terminals)33 and 17 at disconnected LH connector;

possible problem with MAF.

Hope this helps

Saabreur







May 16, 2009 | 1990 Saab 900 Hatchback

Not finding what you are looking for?
2004 Ford Mustang Logo

Related Topics:

66 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

fordexpert

Level 3 Expert

5495 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...