Question about Dodge Ram Pickup 1500

1 Answer

Speedometer not working abs and break lights are on whats the problem

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Dodge Master
  • 75,817 Answers

You have a faulty Vehicle speed sensor, it is located on the outside of the transmission. Without the model and year i can't be more specific

Posted on Mar 21, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2004 Freestar fuses for Instriment cluster. F2.16 (5A) and F2.8 (10A) Location ?


probable not fuse problem --look more like a speed sensor or abs wheel sensor

Aug 31, 2016 | 2004 Ford Freestar SEL

1 Answer

Abs light on,brake light on,speedometer not working,trans won't shift


Is the break pedal stiff? with the ABS light on and the break light on sounds like your breaks might be locked or locking up which could be why the transmission isn't shifting

Sep 14, 2013 | Chevrolet Cars & Trucks

1 Answer

Uncle put new brake pads on vehicle (he worked on front and back brakes) and now the speedometer doesn't work, the abs light is on, check engine light, and the break light is on. what could have happened ....


Check for disconnected ABS sensors. The front sensors in the front are located next to the axle shafts. The rear sensor is located on the rear differential housing itself on top, in the middle. The ABS is monitored by the computer for performance. The ABS kicks on when the vehicle comes from a certain speed to a dead stop, keeping the wheels from locking up. That could be the reason for the speedometer not working. Or it could be a bad speed sensor. Both can also trigger the check engine light because it is monitored by the computer. The brake light usually comes on due to low fluid level. It can trigger the light, but not be low enough to impact brake performance. I hope this helps.

Oct 16, 2010 | 2000 Dodge Durango

1 Answer

I have a ford winstar and the O/D light is flashing and the check transmission light is on but that only comes on once you start driving. My Break light and ABS light is on all the time. My odometer does...


sounds like you need a speed sensor as well as an ABS module. it runs the speedometer, as well as inform on the wheel speed to make the ABS work, AND the transmission uses it to know when to shift.

generally do not drive it when the O/D light is flashing, it means an issue bad enough to cause serious damage to the trans.

Sep 05, 2010 | 1999 Ford Windstar

1 Answer

No speedometer, and wont sift gear. abs,etc, break


probably your shift box. You need to have the car scanned for codes

Sep 21, 2009 | 1999 Mercedes-Benz E-Class

1 Answer

Speedometer and Odometer not working , Break Light and Abs light on


Most likely you have a check engine light on also. And if you have codes pulled it will be 0500, speed sensor. Replace the one on the rear axle and all should be good. Oh and don,t forget to have code cleared.

Jun 29, 2009 | 1999 Dodge Ram

1 Answer

Speedometer won't work


IT SOUNDS LIKE YOU HAVE BROKEN WIRE LEADING TO SPEED SENSOR IN REAR DIFF..CHECK FOR ANY SPOTS IN HARNESS WHERE IT LOOKS OUT OF PLACE OR RUBBING ON SOMETHING..ALSO CHECK FOR SPREAD CONNECTIONS IN PLUG AT SENSOR..CHECK ALL FUSES RELATED TO ABS SYSTEM IN UNDERHOOD FUSE/RELAY CENTER

May 28, 2009 | 1998 Dodge Dakota

2 Answers

1998 Saab 900se turbo


This happend to my car and it was the ABS module that failed. It does not harm your car you just don't have ABS. Try to replace the ABS sensor first since it is a lot less expensive and a lot less work. If that does not do the trick you will most likely have to replace the module itself. That cost big $$. A new one is about 1200-1500. I bought one from a wrecked card for 300 and it has worked fine for years.

May 19, 2008 | 1998 Saab 900

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

30 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8180 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...