Question about 2000 Chevrolet Silverado

1 Answer

Wipres only work on high ,no low or delay everything else works .

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 10,319 Answers

The circuit board in the wiper is at fault

Posted on Mar 20, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Dodge pick up delay wipers


there is a delay relay on the fusebox that looks like about a 1 inch square cube, it needs to be replaced. get with your mechanic and he can get you one and show you where it goes.

Nov 11, 2015 | Dodge Cars & Trucks

2 Answers

Why my windshield wiper only works on high and don't work on delay?


There is a wiper delay module under the dash that has failed. Windshield Wiper Switch MOTORCRAFT SW-5665

Sep 17, 2014 | Cars & Trucks

3 Answers

2007 Buick Lacrosse low beam headlights both went out at once. Doesn't appear to be the bulb. Also checked the fuses under the hood and those both appear OK too.


The relay under the hood may have gone out. We had the same problem on our 2007 Buick LaCrosse CX. The bulbs were fine, high beams worked, all turn signals and everything except the low beams turned on. Turns out the relay had gone bad.

Sep 07, 2010 | 2007 Buick LaCrosse CXL Sedan

1 Answer

No high beams, no washer, no wiper delay and high and low wipers move at same speed, no fog lights


sounds like your turn signal switch which assembly is bad..most everything you discribe goes throught this.

May 06, 2010 | 2003 Mitsubishi Galant

1 Answer

98 Cadillac Eldorado ETC, Wiper delay and washer quit working. Wipers work on low & high.


you will need a new washer pump that is located in the washer reservoir and a new wiper motor cover which has the circuitry for the delay wipers. All you do is change them out with new parts and it will operate like new again

Jan 24, 2010 | 1998 Cadillac Eldorado

1 Answer

Windsheild wipers only work on high


you have to check the relays connecting the windshield and also the fuses. if any one of these dont work replace them. if they are working fine, the problem is with the motor. the coil should have been damaged.

Jun 01, 2009 | 2005 Hyundai Tucson

1 Answer

Delay wipers don't work.


Try making sure the connection is good.
If it is then you should try replacing the wiper switch.


Brandon Bird

Jan 25, 2009 | 1999 Jeep Cherokee

1 Answer

Delay and low range wiper setting do not work on my 2001 1/2 TRK


Chevy has had Problems with the Wiper Motors on these Trucks for a Long time now. On some Models they Issued Recalls. On My 95' I just Replaced the Wiper Motor and have had NO Problems Since!

Nov 13, 2008 | 2001 Chevrolet Silverado 1500

Not finding what you are looking for?
2000 Chevrolet Silverado Logo

96 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8140 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...