Question about 1995 Mitsubishi Eclipse

1 Answer

I have a 95 GSX, Its will drive fine then just die. wait a while and will start back up. I check the crank sensor and the main power feed is around 12V, but the signal wire is around 0.453V when it wasn't run and when it was, I have the same readings. the cam sensor has the the 5V reference voltage and 12V feed.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 693 Answers

Everything sounds ok , May want to check your converter?

Posted on Mar 19, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

95 chrysler new yorker no distributor signal


Lets start at the beginning. Do you have power going to the coil and is the ASD relay working ?

Aug 03, 2013 | Cars & Trucks

1 Answer

95 pontaic bonneville intermittant loss of power


Could be crank sensor , ignition module and i wouldn't rule out the PCM . But before you start replacing parts test these componets . If you don't have diagnostic skills or a lab scope i suggest you take to a qualified repair shop that does . Hall effect cam crank sensor operation and testing Part 1 an SD Premium...

Hall effect cam crank sensor operation and testing Part 2 an SD Premium...

Apr 02, 2017 | 1995 Pontiac Bonneville

1 Answer

My 95 3L Lebaron Dies when the car is stopped. It starts then dies immediately, after many cranks with lots a gas it will run. Only happens when cold.


I'd use a gage and check proper fuel pressure, key on engine off. My info says 48 psi.
How long since over-all tune up?

Apr 16, 2017 | 1995 Chrysler LeBaron

2 Answers

1993 s10 4.3 starts fine, while idling it dies. sometimes i have a hard time restarting. the blazer died a couple of times while driving.fuel pump is good, tuned up, remanuf. injectors 1 yr ago,engine lite...


only half way there if you have a tbi check the crank sensor/ cam sensor that is the first line of business on that truck if the crankshaft sensor fails the truck stops dead when you wait a few minutes the sensor re energizes and the truck will work again for a bit antiknock can cause similer problems but not while the truck is running

Feb 24, 2010 | 1993 Chevrolet S-10 Blazer

1 Answer

The jeep dies while driving it, then won't start. if it sets for awhile, it will start back up and run as if nothing happened.


I had the same problems with my 95 Jeep GC Ltd. I had the crank shaft position sensor replaced (just under $300) and now it runs fine.

Oct 08, 2009 | 1995 Jeep Grand Cherokee

1 Answer

Truck starts fine cold, but after the first short trip, it won't


A cold start sensor or cold start valve may be faulty or map sensor bring it to a advance auto parts store or auto zone if available to check for stored trouble codes, if any codes are present they will inform you in a detailed manner which sensor to change instead of guessing but if I was to guess the aforementioned would probably be the culprits.

Aug 02, 2009 | 1997 Nissan Pathfinder

2 Answers

My 1995 blazer will not start


Have you changed the module in the distributor?

Mar 21, 2009 | 1995 Chevrolet Blazer

1 Answer

Vehicle dies while driving down the road.


could it be the A/C pump kicking in. might be boging down the motor or electrical circuit, not letting the injectors get enough power. This could happen if the bearings are going bad in th A/C pump or there is a short in it. Just an idea. sounds like you have done the main components.

Jan 03, 2009 | 1995 Oldsmobile Cutlass Supreme

1 Answer

95 Buick Fuel Pump, or Filter?


do you have a dis system(direct ignition system)? If you do it is probably your crank sensor. If you don't it could be your ignition coil or distributor. You could tap on the crank sensor while starting this could help.

Sep 04, 2008 | 1995 Buick Regal

Not finding what you are looking for?
1995 Mitsubishi Eclipse Logo

109 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

75744 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8123 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...