Question about 1988 GMC S-15

1 Answer

1990 S-15 PU 2.5

Starts up and runs about 5-10 min's then shuts down have to what 1-2 hours then it will start up and does the same thing again???

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have a 1989 GMC s15 4x4 i had the same prob. it would run longer then 5 min. though maybe a halfhour. after pulling out my hair for a week and taking it to the dealer which told me " theres nothing wrong we can find " i discovered the ignition modual under the distributor cap was the problem. i recommend to replace with A/C delco part. i tried the cheap one and had to replace it again.

Posted on Sep 06, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1989 ford f-150


If the fuel pump(s) run while the pressure is falling, replace the fuel pressure regulator and (although I'm sure you've already done this), replace the fuel filter. If the fuel pumps appear to be turning off by themselves, replace the inertia (fuel cutoff) switch.

Apr 13, 2014 | Cars & Trucks

1 Answer

1996 plymouth neon 2.0 sohc starts up fine, runs good untill it warms up about 20 min, to 1/2 hour then starts losing power, starts spiting and spudering and when giving gas wants to quit? then it...


well its a long shot but it could be your catalytic converter is going bad or is clogged, i have seen them get so hott they glow red. this sometimes can be seen at night by looking under your car after it has ran to the point of stalling and dieing,, if thats the problem the car cant exhaust creating back pressure that robbs power and can cause your car to die.. after it cools the metal shrinks back and the car will runn again untill it getts hott.. i hope this helps

Jun 01, 2011 | 1996 Plymouth Neon

1 Answer

After driving for a while and stoping for 1/2 hour then starting out again gets to closed loop and stalls . sit for 3 or 4 miniutes then starts up and runs again . did not stall after that drove for 10...


sounds like a integrated safety shut down in your computer check your temp and oil pressure gauges when the car is running if they are norm check the sending units to see if they are working properly

Nov 23, 2009 | 1998 Honda CR-V

2 Answers

Starts well,runs wellfor five mins but then cuts


My first guess would be the fuel filter. It is probably almost completely plugged.

Oct 23, 2009 | 1991 Volkswagen Passat

1 Answer

Electrical Problem?Runs great then shuts down,let it sit runs fin


Sounds like the ECM is bad. This is a common problem, when the ECM gets hot there is a solder joint that seperates, it makes contact again once it cools down

Jun 17, 2009 | 1998 Plymouth Grand Voyager

3 Answers

Engine shut down after 15miles then won't start for half hour


just went thru the same think wit a s 430 it was the crank position sensor . 60 bucks at auto zone and it took me 5min. 2 install if u need help feel free to call me 918 808 9706 chris

Feb 20, 2009 | 2000 Mercedes-Benz S-Class

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

106 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...