Question about 1990 GMC Sierra

1 Answer

My truck starts fine but dies after about 2-3 min when I let off the acclerator and come to a stop. It runs a little rough when I accelerate, I've changed the plugs,wires, air filter, & distributor cap could it be the fuel filter? (305 with carburator)

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 93 Answers

Yes please replace the fuel filter,the fuel filter replace every 40,000 kilometers according to the factory specifacation.then buy a repair kit of the carburator to clean and replace gasket to prevent leaking of gasoline

Posted on Mar 17, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Runs rough and dies what 1 hour well star for 30 min. then die


Check your fuel system, especially your fuel filter and fuel pressure regulator.

Jul 20, 2014 | 1994 Ford Probe

1 Answer

Car running rough at random when accelerating and also idle drops suddenly when slowing down and often completely stalls out when I stop. Smells strongly of gasoline when it stalls/almost stalls but I


This could be a lot of things. one of the tests that you need to run is shift it into nuetral when you are stopping and see if it still drops RPM and wants to stall. This will eliminate or conclude that it is a transmission issue. If it is still doing this then it could be a vacuum leak or fuel delivery issue.

Feb 13, 2014 | Subaru Cars & Trucks

2 Answers

Idles roughly, then low when stopped or in park, then dies. Decreasing gas mileage. Slow to accelerate


Sometimes that's caused by a vacuum leak near the manifold area.

Sometimes air in the coolant will cause an idle problem. Air will keep the air temp sensor from sending proper info.
Hope this helps.

Jan 03, 2014 | 2004 Ford Taurus

1 Answer

Rough idle/ not accelerating/coolant leak


Rough Running Engine - James on Engines #2 - Bell Performance

https://www.bellperformance.com/blog/rough-running-engine
Apr 21, 2015 - When diagnosing an engine with a rough idle, there are certain things that must be ... If the problem does not reoccur, the codes will be erased by the computer. ... when accelerating the vehicle, which causes a higher fuel demand. .... it was water in gas...added added Gas LineAntifreeze/Water Remover.

Mar 17, 2017 | 2000 Ford Focus

5 Answers

1989 corvette runs rough, wants to stall even after new plugs and rotor.


i want to give you the right answer but the only thing i think of is the mass air flow sensor.

Apr 06, 2010 | 1989 Chevrolet Corvette

1 Answer

In park the engine dies; only will run if given gas


It sounds like there is a problem with the Idle Air Control (IAC) valve. Its job is to open and let air into the manifold when the throttle is closed at idle. If it does not open, the engine dies at idle. The IAC is mounted on the throttle body. Possibly the valve is clogged or stuck, in which case it could be ok again if it is removed and cleaned. Or it is broken, and needs to be replaced. Or, there is a problem with its electrical connection, that needs to be traced. Good luck, let me know if you have any questions.

Mar 30, 2010 | 1993 Chevrolet Lumina

1 Answer

Car starts and runs fine then after 30 min or so runs rough


Check the primary and secondary resistance on your coil and resistance and gap on your spark plugs. Sounds like you have a high temp foul out.

Jul 31, 2009 | 1983 Ford Crown Victoria

1 Answer

Starts fine when cold, after running dies on idle then wont start


Sounds like the fuel filter is dirty and needing to be changed. It's cheap and easy to swap out.

Jan 12, 2009 | 2002 Land Rover Discovery Series II

Not finding what you are looking for?
Cars & Trucks Logo

141 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76691 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...