Question about 1999 Chevrolet Suburban

3 Answers

I have a 1999 Chevrolet Suburban 1500 4wd. Today I was helping a friend with a dead battery and when she stepped on my gas petal to give her the jump she pressed too hard. When she did this brown water started to spray out of my car really close to the the thermostat and stopped when she removed her foot. Her brother told me to add some water to the resevoir not where the coolant goes so that my car will not overheat when I went home. Well while driving home I started to hear a hissing or sprying noise and notice the temp gauge going up really fast and then smoke with a smell like burnt rice or popcorn started to come from under the hood. I got to my husband's job opened the hood and saw that water had sprayed every where and it was steaming bad. I took all the kids out of the car in fear of a fire but the hissing noise that I heard while driving slowly started to stop and the car slowly cooled down. Mind you no water had gone down in the tank and there is no spraying or leaking when the car is cranked just when I step on the gas. I had to stop 4 times before I got home just to let it cool because the temp gauge kept going past 260. I am scared to drive it but this is our only transportation with six kids. I do not know if I popped a hose or if something broke PLEASE HELP!!!

Posted by on

3 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 130 Answers

You probly have a cracked radiator hose when you give it gas the engine moves and lets it spray

Posted on Mar 16, 2011

Testimonial: "Thank you I was so lost and was hoping it was not something very expensive."

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 66 Answers

I would try to replace the hose on the thermostat first. Sounds like the thermostat stuck and blew the top hose, which in this case I would change the thermostat also. If you were blowing brown water that smelled burned, you should flush the cooling system too. I hope you did not overheat the engine too much as this could cause bigger problems later like warped heads or cracked head gaskets. Good luck!

Posted on Mar 16, 2011

Testimonial: "I will take care of both things and check all of the hoses as well thank you"

  • ekell82 Mar 17, 2011

    Thank you so much for that help. BY the way does it cost a lot to get that fixed? Is that something that can be easily done by myself with a manual?

×

You can not use the truck at all

You will have to have what most likely
is a heater hose that rotted away,replaced

Posted on Mar 16, 2011

Testimonial: "Thank you so much"

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Wont shift to high gear?


change your filter are your third gear could be burning up..my need to replace..i hpoe this could be some help..

Apr 18, 2013 | 2000 Chevrolet Suburban

1 Answer

Eight days ago 2005 Suburban would not start. Made a clicking sound when I tried to start it. Jumped the battery seemed fine. Today same thing. Made clicking sound, jumped, started up. Went and bought...


Even a new battery will go dead if the car is running on the battery instead of the alternator.
Check alternator output.
First charge the battery up.
Then check voltage with a meter from Harbor Freight ($3).
Should be 12.5.
The start engine and rev it up.
Should go over 14.
But also clean and grease battery terminals, alternator terminals, and check engine ground strap.

Sep 21, 2010 | 2005 Chevrolet Suburban

1 Answer

How do i get to the battery of a 1999 chevrolet..dead battery


connect the red jumplead to the starter motor(poss) and the black to the body(earth)then "jump" as normal

Jun 26, 2010 | 1999 Chevrolet Lumina

1 Answer

Have o3 suburban. turns over does not start


out of gas or fuel pump over heating

Mar 04, 2010 | 1999 GMC Suburban

1 Answer

Battery is dead, once i jump the truck it starts


Sounds like you need a new alternator.

Jan 19, 2010 | 2005 Chevrolet Tahoe

1 Answer

1994 suburban will not keep charge from battery,


Sounds like a bad altnator. if the alt. is working propperly it will run the burb. with out the battery installed. With that though, it possiably could of damaged the batt. enough to the point of replacement as well.

Jul 17, 2009 | 1994 Chevrolet Suburban

Not finding what you are looking for?
Cars & Trucks Logo

255 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7782 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...