Question about 1996 Mitsubishi Montero Sport

1 Answer

My temperature guage is not working - 1996 Mitsubishi Montero Sport

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

DOES THE AIR ALSO BLOW HOT WHEN U HAVE THIS PROBLEM? THIS COULD BE YOUR THERMOSTAT OR THE SENSOR INSIDE. YOU CAN CHANGE THE THERMOSTAT OR THE SENSOR WHICH IS A LOT CHEAPER.

Posted on Mar 16, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Temperature guage in car not working stays on cold doesnt move


which 2 sensors did you r/r? was one a temperature SENDING switch? Poss gauge ? see if your getting any voltage to the sensors themselves & same w/ sending switch.Electric fans working?

Sep 20, 2015 | 1996 Nissan Quest

1 Answer

My temperature gauge doesnt work


Easy test ground the sensor wire to ground(intake manifold) the guage should max out if not check for power on the back of the instrument panel at the guage if you have power on one side ground the other side if it works .If grounding it at the guage makes it work bad connection at the sensor or broken wire

Feb 01, 2014 | 1995 Jeep Grand Cherokee

1 Answer

Temperature guage goes to high, but it doesn't appear that the van is overheating (no steam/fluid leaking) Radiator & thermostat were recently replaced. Guage will jump to high when idle, but...


FLUSH RADIATOR, HEATER CORE AND ENGINE BLOCK.ADD 50 / 50 ANTIFREEZE AND WATER ALSO REPLACE RADIATOR PRESSURE CAP.IF TEMPERATURE GAUGE STILL STAY HIGH THE ENGINE COOLANT TEMPERATURE SENSOR COULD BE FAULTY.

Aug 21, 2011 | 1996 Ford Econoline

2 Answers

Temperature guage doesn't work and heat blows cold


Check the thermostat.It sounds as though it's stuck in the open position. Fuel comsumpion increases as well.

Nov 24, 2010 | 1994 Toyota Tercel

1 Answer

Fuel guage & water guage are not working properly the fuel guage reads ful then will go to empty after you drive it for awile - the water guage only goes up to a quater


The gas tank sending unit has a float on it to register the amount of gas in the tank. The float is probably faulty which will cause erratic readings and is a fairly common issue with some GM units. Replacement of the sending unit should resolve that issue. As far as the coolant temperature gauge, it could be a faulty temperature sending unit or a thermostat that is stuck open or someone removed the thermostat. This will cause the engine to never reach operating temperature which in turn makes the engine run rich and can clog cat. converters and destroy some sensors.

May 08, 2010 | 2001 Chevrolet Venture

1 Answer

92 crown vic - temperature guage on the dash is not working...


0900c152801e4775.gif

The temperature gauge sending unit is located in the front section of the intake manifold, just to the right of the alternator on the 4.6L engines. Got this from autozones repair manuals


Mar 16, 2010 | 1992 Ford Crown Victoria

1 Answer

2003 Ford Taurus temperature guage


replace the temp sending unit if you continue to have this problem

Jan 22, 2009 | 1996 Ford Taurus

1 Answer

If the temperature guage is not working and engine light is on sh


Not really because the thermostat may be fine and the light will still be ON. If the guage is NOT working it will trigger check engine light. First you should fix guage, it probably needs a temperature sensor or sensor wire may be broken. Check it out, good luck.

Jan 13, 2009 | 2001 Chevrolet Venture

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

123 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8514 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...