Question about 2001 Mercedes-Benz C-Class

3 Answers

2001 c-240 loss of power when I rev engine

Engine boggs down when I punch it, then shuts down. 100,000 miles .
Had new Mass Air Filter replaced , no better results.
Any one have a answer.
Location of fuel filter , Fuel Pump and Fuel pump relay . I think I will replace all as it is original and never changed.

Please help
THANKS
HENRY

Posted by on

  • Googe Aug 02, 2008

    Thanks for your advice, I am lucky to have another car which allows me to proceed with caution on who to take the car to and what to beleive

×

3 Answers

I had the same problem and had Mass Air Filter replaced. Same problem showed up.
Second time the dealers did a complete tune up. New spark plugs and wires. (2001 with only 46,000 miles). After the tune up, the car drive like new. And I drive the heck out of it. Pedal to the metal.

Dzung

Posted on Oct 16, 2008

I had a problem.... with my c240, was losing power when i floored in on the highway. Airflow sensor was replaced..... drives like new now

Posted on Sep 28, 2008

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 14 Answers

Sounds like a lack of air/oxygen problem. Just had a similar problem with a Diesel engine, Mercedes C220 CDI. Found the pipe to the Turbo spli/collapsed, so no air to Turbo = no power.
Try checking air inlet pipes to Fuel pump.
Also once had a problem with a different car dying on me in the outside lane of a motorway. Turned out to be a burned out fuse on the fuel circuit, after the breakdown mechanic's suggestions of maybe need new alternator, new injector pump, maybe new onboard computer. Turned out to be a twopenny fuse!!!
Check before you replace anything is my advioce. Go down to your local helpful garage or Mercedes Dealer if they are helpful.

Posted on Aug 02, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Loss of electrical power resulting in engine shut down


I would check ALL grounds first and then main relays. Does this do it at a certain speed everytime or when ever it feels like it ???

Dec 28, 2013 | 2001 Chevrolet Impala

2 Answers

Slow accelleration


CAR BOGS DOWN COULD BE FAULTY TPS SENSOR, CLOGGED FUEL INJECTORS AND CLOGGED FUEL FILTER, STOPPED UP AIR FILTER, FAULTY MASS AIR FLOW SENSOR.BEST BET IS TO HAVE CAR CODE SCAN MANY THINGS WILL CAUSE ENGINE BOG DOWN.HAVE VECHICLE CODE SCAN AND SEE IF YOU HAVE ANY FAULT CODES.MAKE CHECK TRANSMISSION FLUID LEVEL.ENGINE NEED TRANSMISSION TO FOR TORQUE AND POWER TO PUT CAR IN MOTION IF TRANSMISSION NOT WORKING OKAY IT WILL PULL DOWN ENGINE POWER.

Nov 01, 2011 | 2004 Ford Taurus

1 Answer

2001 Pontiac firebird, when accelerating, engine boggs down, loss of power. Especially on hills. Car revs up, but no power.


two things to check it's either a fuel problem, which is most likely a fuel filter, which probably has never been changed, or the rotor in the distributor. that should help you narrow your problem

Sep 23, 2009 | 2001 Pontiac Firebird

2 Answers

2005 hyundai terracan loss of power on faster journeys


check transmission sensor, I hope is not time for a new transmission

Jul 25, 2009 | 2005 Hyundai Santa Fe

1 Answer

Power loss s-10


Possibly restricted catalytic converter.

Jun 26, 2009 | 1992 Chevrolet S-10

2 Answers

1996 s10 2.2 engine starts but idles rough and will not rev up.


Hi! You must be frustrated by now! your code is marking that the O2 sensor is bad in bank 1. Did you replace the O2 sensor that is located  before the catalytic converter?  The S10 has an O2 sensor specially made for that cat. its about 30$ That would explain for your blackened spark plugs; your pc on the car is asking for more fuel. GOOD LUCK!!

Apr 29, 2009 | 1987 Chevrolet Blazer

1 Answer

Throttle revs up right at start up


i also have a 2000 celica with a little over 100,000 miles; i was having the same problem and had to have my driving belt and my mass air flow meter replaced.

Mar 18, 2009 | 2000 Toyota Celica

1 Answer

Engine light on, bad fuel milage


You didn't mention if you replaced the mass air flow sensor, if the tech got that code, it needs replacing, if you haven't alresdy done so.

Feb 25, 2009 | 1997 Buick.5 Regal

Not finding what you are looking for?
2001 Mercedes-Benz C-Class Logo

402 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

yadayada
yadayada

Level 3 Expert

60769 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

164 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...