Question about 1999 Chevrolet Camaro

2 Answers

Losing Power to radio and windows in a 99 Camaro

I was just wondering if you ever found the solution to the problem with your car because mine is acting very similar to the way you described yours. The windows and radio randomly turn on and off. I would greatly appreciate your comment back. I really dont know what else to do. Thanks

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 4 Answers

Take a look at the map of the fuse box. The Windows is directly above the fuse for the radio. They're probably shorting. No big mystery.

Brotherman

Posted on Aug 10, 2012

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Hi, just had mine in the shop for the same thing. Pinched wires behind the dash. Have you ever had the stereo out or replaced?? There's a bracket back there that the wires could be pinched against, that was the problem with mine. Hope this helps.

Karen

Posted on Aug 31, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Car radio not turn after battery change


Whenever battery power is disconnected your radio/Nav system must have it's factory code re-entered after voltage is restored . The radio manual describes this procedure very clearly. Your car should also have the radio security code imprinted on a card, which is found in the owner's manual dossier.

Mar 25, 2014 | 2006 Aston Martin V8 Vantage

1 Answer

The car run rough act like it want to die


Mine has the 2.2 also and i found i had a vacuum leak from my intake, my best guess would be to tighten up your intake components

Feb 24, 2014 | 1990 Toyota Celica

1 Answer

Where is the coolant sensor that acts as a choke ?


do you mean the the thermostat? the one that lets your car get up to working temp before it opens up to let the water circulate? that is normally found the on the engine where the rubber hose from the radiator connects to the engine

Apr 09, 2013 | 1991 Subaru Loyale

1 Answer

Turn signal lights dont work


may not be a solution for you but when mine quit working, found 2 places where fuses had to be changed. keep in mind that mine was a different type vehicle than yours but could be a similar type problem.

Mar 07, 2012 | Ford Taurus Cars & Trucks

2 Answers

My explorer 2004 some time no take D or R, stedy like in N, after 25 minut beguining workingI need some help?


sounds like its low on transmission fluid but i could be wrong as it could be a front clutch worn out but check the oil level first

Feb 25, 2012 | 2004 Ford Explorer

2 Answers

Cranks over but won't start changed fuel pump but still not starting started once drove it 20 miles and now won't start again


I had a 95 Astro that acted in a similar way. Mine was the fuel pump. I wonder if your ground is loose for the pump circuit or if there is a relay dying on you. Does it act differently with a change from hot to cold weather? A loose ground would do that. You could also have a faulty pump. I heard stories of people getting non-GM approved pumps that failed or had to low a PSI to accurately supply the engine with fuel. Is it getting adequate fuel pressure (50-60 PSI). It should be 60 psi but I was told my 50psi was within GM specs. Mine eventually drank the radiator due to a blown head gasket that no one ever properly diagnosed.

Sep 09, 2011 | 1997 Chevrolet Astro

1 Answer

My 2002 grand cherokee loses power on hills and acts as if it doesn't have a passing gear. It has 109000 miles.


Does it otherwise start and run OK?

Have you replaced fuel and air filters?

Check running fuel pump pressure, and also have fuel pressure regulator checked for correct operation.

What you describe sounds somewhat like fuel starvation, although severely impeded air flow because of a clogged air filter could possibly produce similar results.

Jan 31, 2011 | 2002 Jeep Grand Cherokee

2 Answers

Have heat, not blowing have checked fuse, replaced fan and resistor - Mechanic wonders if could be a control module, anything else? 2001 dodge caravan, 6 cyl


Hello redtruck.
I had the same problem in a newer version of your Caravan this past week.
To test it you need to ground the front blower motor relay ground. The pin for it is the one closest to the left fender. If the blower comes on your problem is similar to mine.
We found the problem in the circuit board under the fuses in the "intellegent power module. The module at the front of the panel was not the problem, it will come off with two Torx head screws.
We took it apart taking pictures as we went for reassembly.
We used a magnifying glass to inspect the circuit board and found a corroded terminal. Then soldered in a wire to jump past the bad area.

Dec 05, 2009 | 2001 Dodge Caravan

1 Answer

1991 F-250. feul injected 460 w/c6 tranny. acts like it is missing when engine runs at 3000rpms. accelerates just fine and runs wonderfully below 2900 rpms. just when i try to plane out around 70 mph the...


Hello. katienjoe. the fuel line from the filter to the fuel rail has a restrictor in the line its at the fitting at the rail. the opening messures 3/16 of a inch. so loaded it doesn't pull above 50 mph. you can change the line I did on mine the hot rod shops can supply what you need.

Sep 14, 2009 | 1991 Ford F250

1 Answer

My car will not go into reverse


probably your shifter assembly and the interlocks. either needs to be adjusted or replaced. had a similar issue with mine lately, replaced at a cost of ~ $250

Jun 30, 2009 | 2008 Dodge Avenger

Not finding what you are looking for?
1999 Chevrolet Camaro Logo

206 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

70346 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6869 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...