Question about 2000 Ford Expedition

1 Answer

My 2000 expedition oil pressure needle drops while driving

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 17,129 Answers

If the engine is heating up then you need to check the condition of the engine , check the oil , if there is level drop in the sump or if the oil is old and gone too soggy. If so replace with new filter.
However is the engine seems trim and working fine then the oil pressure guage needs a check. Test with an alternative before confirmation or else the oil pump is a suspect at higher temperatures.

Posted on Mar 15, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Oil pressure drops intermittently


Try removing the cooling fan and shroud, unbolt the engine mounts and try to jack up the engine until you have clearance.

Jan 04, 2014 | 2002 Ford Expedition

2 Answers

I;ve lost oil pressure the needle stay's down while driving, is the oil pump bad or going bad? is it located in the oil pan or the front of the 4.6L MOTOR?


If the needle is staying down and the motor is not knocking then the gauge is probably bad. If you run the engine with no oil pressure, then it will not last long. It will start knocking and ruin the engine. But yes the oil pump in in the oil pan. There is also a oil pressure sending unit that could be bad. It is located on the back of the engine.

Jan 03, 2011 | 2000 Ford Expedition

3 Answers

I got in my 2001 Expedition, started it up and the oil pressure light came on. The guage was down to 0. I stopped it and started it again. The guage press. went up and then slowly dropped at first and...


oil pump gears inside the lower engine, or electrical. 1st make sure its full on oil, then sheck it with another pressure guage to confirm its not actuall pressure.

Jan 02, 2011 | 2001 Ford Expedition

1 Answer

The oil pressure gauge niddle drops everytime the jeep is park. what could be the problem?


Do you mean everytime you go from drive to park (engine still running, idling), the oil pressure needle drops to the bottom.....
????

Oct 15, 2010 | 2001 Jeep Grand Cherokee

1 Answer

2007 Ford expedition won't start


ur oil pump may be failin-there r sensors everywhere on new cars-keepin u from starting as safety measure-computer systems r complex n things dont always show on 1 scan-they kinda hav the mindset of a pc

Sep 15, 2009 | 2007 Ford Expedition Eddie Bauer EL

1 Answer

Wife driving 2001 Expedition and the Oil light came on, engine seemed to lose power. Traveling approx 70 mph with cruise control set, light came on, cruise control went off and lost power. When i arived 15...


when you travel over 65 mhr for long lenghts of time you don,t work the engine enough to move the fluid to lubricate the engine also when you go on long trips make sure the oil life is still gonna be good for the hole trip

Aug 20, 2009 | 2001 Ford Expedition

1 Answer

No oil Pressure, with knock.


The first thing I would do is change the oil filter. Also, what engine do you have.

May 27, 2009 | 2000 Ford Expedition

1 Answer

Oil pressure on 99 sebring drops after the car has warmed up for


could be sludge build up under the valve cover.
the oil may not be draining back down to oil pan good, may also be oil pump.

Feb 20, 2009 | 2000 Chrysler Sebring

Not finding what you are looking for?
2000 Ford Expedition Logo

238 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5501 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...