Question about Land Rover Range Rover

Open Question

1997 RANGE ROVER 4.6 HAS CODE P0340 CAM SENSOR HAVE REPLACED SENSOR STILL NO GOOD WILL IDLE BUT BACKFIRES WHEN ACCELERATING AND WON T REV

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: IDLE FLUCTUATION

adj idle with cable adj thanks Trevor

Posted on Aug 06, 2008

Ad
  • 22 Answers

SOURCE: 1995 Range Rover Land Rover Questions

which shape is the range rover is it a p38 or classic ? i am guessing p38 , the beeping noise could be a couple of things , it could be registering door open fault , do you get anything flash up on display?

Posted on Oct 23, 2008

countrysi248
  • 443 Answers

SOURCE: rough idle, backfire on acceleration

check everything you can under the hood your air intake system all of it especially make sure all clamps are tight .. and make sure all vacuum hoses are good and not cracking or broken or just loose . you might run a little fuel cleaner through a tank of gas too cleaning the engine fuel system up some. just a few ideas.. Jerry

Posted on Apr 12, 2009

  • 21 Answers

SOURCE: Stumbles and backfires on acceleration

Check the distributor shaft. They have a history of developing finite cracks that causes the condition your describing. Let me know if I can help you with any other info.

Posted on Jun 01, 2009

vwmike2001
  • 74 Answers

SOURCE: idles but no acceleration?

Their are a few things that would cause that to happen. Check your plug wires to be sure they are on tight. If you havn't had a tune up in a while I would definately replace the wires and spark plugs. Both are things that cause those problems. I don't what you are driving but if it is newer you also might have a bad ignition module. If you have no distributor then you will have those instead. Their also is the possibility of the timing being off. While this tends not to happen by itself it could happen if your timing belt needs to be replaced. When the belt strecthes over time and use it can cause to throw the timing off. I hope this helped you out. It woulod be appreciatted if you could rate my answer. Thanks, MIKE-

Posted on Aug 25, 2009

Testimonial: "helpfull"

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

1997 montero sr 3.5 L 4wd The truck has no acceleration. Slow start until 40 mph.


Check the cam position sensor and the crankshaft position sensor for loose connections or possibly a bad sensor. Run a diagnostic test to give you a better idea of which parts are faulty.

Dec 20, 2015 | 1997 Mitsubishi Montero

2 Answers

Poor idle and no acceleration on a '91 GMC Sierra 1/2 ton p/u w/4.3l v6 manual trans


there is vital information missing here
to start with it is a v 6 so there will be 2--HO2S sensors one for each bank before the cat converter and 2 --O2ensors --one for each bank after the cat converter
there is a vast difference between HO2s and O2 sensors as each reports different information to the ECM
next slow acceleration can be accelerator position sensor or throttle position motor
every time you read the codes it cancels them so you have to run the vehicle for a few miles for codes to reappear
from the codes there can be up to 7 reasons for that code to appear so you don't pick on the first one as it could be another or a combination of others

Nov 08, 2015 | Cars & Trucks

1 Answer

1997 tacoma 2.7 cam sensor problem replaced it but still code p0340 so tryed crank sensor


There may be more than one issue. Here's some possibilities:
1. The new sensor you bought is defective. I have run across this problem a few times. Most notably was a mass air sensor for a Maxima that the first 3 NEW sensors were defective right out of the box.
2.Look for oil in the sensors plug socket and the pigtail connector. If oil is present, spray out both the socket and pigtail with brake cleaner. (Be sure to wear safety glasses when doing this)
3. The timing belt tensioner is losing/has lost the ability to keep tension on the timing belt and it's out of time.
4. There's a break or a sort in the wiring. You'll need a schematic and a mutlmeter to check for continuity.
(Least likely) 5. The computer is failing or has failed.

Apr 21, 2013 | 1997 Toyota Tacoma

1 Answer

2002 sebring sudddenly will not rev over 1500 rpm


start car, try to rev (try to cause error)... allow to idle for 30 secs
shut off car, with car stopped, turn key, on-off-on-off-leave on. codes will be displayed in odometer readout.

if code P0340 it is the cam sensor, very easy fix, one bolt.

Apr 16, 2012 | 2002 Chrysler Sebring

1 Answer

I have a p0340 code along with a blown 30amp ignition b fuse... symptoms include. rough idle and backfiring. replaced cap rotor and wires plugs.. Whats the fix? cam position sensor?


300 CODES ARE IGNITION CODES THE 4 IS THE CYLINDER THAT HAS THE PROBLEM, CHECK THE SPARK PLUG FIRST TO SEE IF IT IS BLACKENED IF IT IS OK CHECK THE WIRE, GO TO AN AUTO PARTS STORE AND BUY A SPARK TESTER INSERT ONE END INTO THE SPARK PLUG WIRE UNTIL IT STOPS. ON THE OTHER END WILL BE A DIAL, DIAL IN THE GAP FOR THE PLUG. ALSO THERE IS A WIRE WITH A CLIP THIS IS GROUND. CLIP IT TO A METAL PART. HAVE SOMEONE START THE ENGINE AND IF THE SPARK IS STRONG AND BLUE IN COLOR YOU HAVE A GOOD WIRE. IF IT IS NOT STRONG AND WHITISH IN COLOR YOU NEED TO REPLACE THAT WIRE.

Mar 03, 2011 | 1997 Chevrolet Tahoe

1 Answer

I have a 05 Dodge ram 1500 90,000mi. and it start to bog and eng.light came on my codes were p0129-p0405-p0340-p0868 and pending codes were p0129-p0325-p0330-p0405-p0340. I had put a new map sensor in...


P0340 is for camshaft position sensor circuit malfunction so the problem can be in you hav already changed sensor, then you need to check wiring from sensor to ecu and if the wires are ok than check the ecu! It can be either of them cousing the problem.

Jan 30, 2011 | Dodge Ram 1500 Cars & Trucks

1 Answer

97 kia sephia, replaced battery, plugs, wires, cap, rotor, air filter, fuel filter, added heet water removal and lucas fuel injector. It sputters, backfires/pops when accelerating and it has no power,...


As you have replaced all the obvious things that could cause the symptoms it may be a good idea to have a cylinder compression test done , if comes back OK i'd try a fuel addative , one that covers the catalytic convertor , as there are many sensor's involved in the fuel/exhaust system as you know , this addative will clean any residue affecting there reading's , hope this helps

Apr 06, 2017 | 1997 Kia Sephia

1 Answer

1997 chevy cavalier 2.4 twin cam engine dogs out when throttling


Possibly bad tpos sensor

Bad idle air control valve

Bad maf sensor

Check the computer codes first before spending any more money on it

Also do a compression check

And check your valve timing and ignition timing just in case.

Apr 05, 2010 | 1997 Chevrolet Cavalier

1 Answer

Rough idle and misfire on ram truck


Change cam sensor & erase codes.( disconnect battery for a minute or so after.) 340 & 1391 refer to cam sensor problem, and all other 300 codes are cylinder misfires that should disappear when cam sensor fixed.

Jul 09, 2009 | 1997 Dodge Ram 1500 Club Cab

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

194 people viewed this question

Ask a Question

Usually answered in minutes!

Top Land Rover Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22265 Answers

yadayada
yadayada

Level 3 Expert

77202 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8743 Answers

Are you a Land Rover Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...