Question about 1998 Chevrolet S-10 Pickup

2 Answers

I have a 95 S-10 2.2 when it starts it runs very rough and sputters and spits under load but when it warms up and the oil pressure drops it smooths out and runs properly with no hesitation at all. New fuel filter, IAC valve and new EGR, with PCV also.

Posted by on

2 Answers

Check sprk plugs & wires for fouling, cracking, etc. Before heading in for the $$$$ overhaul, buy 2 cans of "Seafoam", 1 in gas tank with 5 gals gas( will treat up to 20/25 gls), 1 in crankcase. This is a GREAT product that for less than $20 may hold you over for awhile if indeed you have to tear into internal engine.

Posted on Aug 02, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 253 Answers

How many miles sounds like bad engin pressure to me. then when it gets hot pressure is up. Headind for an overhaul soon looks like.

Posted on Aug 01, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why are all these codes being thrown in my Dodge w250?


What year is it? Your symtoms suggest oil contamination from bad fuel pressure regulator.

Sep 02, 2014 | Cars & Trucks

1 Answer

05 taurus spits and sputters on startup when cold


This can be caused by a problem in the fuel pressure check valve of the fuel pump. Have a pressure leak down test run by a shop, if the system is losing pressure then the pump assembly must be replaced. The fuel pump is located inside the gas tank and is electric

Sep 19, 2012 | 2005 Ford Taurus

1 Answer

Hard to start sputters when starting smooths out runs fine?


check the engine coolant temp sensor under the distibutor. they can go bad and cause longer starting times and rough running until the car warms up.

Aug 08, 2011 | 1992 Honda Accord

1 Answer

My car will not start in the mornings or any extended periods of time .It will start after it has run for a while.It spits and sputters and shakes when trying to start it.When it does start and I press on...


here are a few possibilitys, a bad fuel pressure regulator . the vehicle runs rough, the engine will not start ( usually in mornings ) many times engine starts but stalls shortly after starting. a bad regulator can result in fouled plugs. replacement is only cure. black soot on plugs, blake smoke from tailpipe, running rough, stalling. make sure fuel filter is not plugging up. or low fuel pressure from fuel pump. check fuel pressure regulator first. have a good day !! the regulator if bad will cause an instant drop in fuel pressure when turned off. and it will cause a delay in building sufficient fuel pressure,.when starting.

Apr 23, 2011 | 1998 Toyota Tercel

1 Answer

Hello, I have a 99 silverado z71, I was driving along and all of the sudden it lost power and started to spit and sputter and ended up on the side of the road,sitting there it continued to idle roughly,...


Have the shop check fuel pressure at the fuel rail. Maybe the pump impeller has failed. If fuel pressure is good, your timing chain/belt may have slipped.

Nov 07, 2010 | Chevrolet Silverado 1500 Cars & Trucks

1 Answer

Difficulty starting when warm, OK when cold


Have you checked the fuel pressure regulator for leaks into the intake

Mar 29, 2010 | 1990 Ford Probe

2 Answers

Runs good until warm


I would suspect fautly spark plugs.

Dec 03, 2009 | 1987 Nissan Pathfinder

1 Answer

1994 dodge ram van b250. when warm, starts easily. when cold, will crank but not start. eventually, fuel pump kicks in and primes lines, starts rough, sputters, dies, then finally starts rough and runs...


Sounds like the fuel pump is going out. Its inside the tank. But first see if the fuel pump is clooged. take it off and see if its plugged. Check fuel pressure if you can. should be 45-55 psi

Oct 13, 2009 | Dodge Ram B250 Cars & Trucks

1 Answer

1995 Jeep grand cherokee is missing while running. When it is under a heavy load (driving fast) it runs fine. When idleing and slow driving it spits and sputters.


I have the same problem on my 95 grand cherokee laredo. Sometimes it starts out fine and after about 10 miles it starts spitting and sputtering. Then after a while it seems to clean out and run fine again for a little while. Then other times it starts out spitting and sputtering at the begining. I changed the fuel filter and that was not it. It is a 4.0L 6cyc. Any Ideas?

Thanks,
Broken Arrow, OK

Jul 02, 2009 | 1995 Jeep Grand Cherokee

3 Answers

92 astro runs rough


have mass airflow sensor cked.

May 28, 2009 | 1993 Chevrolet Astro

Not finding what you are looking for?
1998 Chevrolet S-10 Pickup Logo

204 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...