Question about 2004 Hyundai Santa Fe

1 Answer

Every time I put gas in my car it takes approx. ten minutes before it will start up. I let my car run while putting gas in it and my car stopped running. But I was able to start it back up 10 minutes later

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 81 Answers

Keeping the vehicle running during a fill up is a definite NO NO! there is the increased risk of a fire(very bad) the possibikity of someone stealing your car(bad) and the increase for the problem you are experianceing( not so bad, fixable and preventable). the reason youre having the trouble is youre essentially flooding the engine with raw gas. while the engine is running it creates vaccuum in the evaporative emission system. in a nutshell, its constantly sucking the fumes out of the gas tank and burning them by running it thru the engine, there is a small valve in the tank thats supposed to be exposed to air in the tank, when you fill the tank with the engine running you are drawing this air out while the fuel is being added and you are more than likely sucking the raw fuel into the charcoal canister and its becoming flooded with fuel instead of vapor. after you wait about 10 min this exess fuel has evaporated enough that just the vapor is being drawn into the engine again and allowing it to start. in short dont keep the car running while filling, dont fill past where the hose shuts off the first time, trying to cram an extra half gallon into the tank, and this should no longer be an issue.

Posted on Mar 14, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Shutn off while stopped


not good to run low on gas you might have sucked trash into fuel line check fuel filter and stop and going will make what gas is in it to slosh around in tank

Oct 02, 2013 | Cars & Trucks

1 Answer

Could it be the fuel pump


i have a 2001 tracker 2.0 engine it did the same thing it run good but when i cut off i wud have to wait about 10 minutes and it wud start back up i put a new camshaft position sensor on it and its ok now the sensor cost me 289.00 dollars its easy to put on takes maby 5 minutes if u put that sensor on it u wont have anymore problems

Apr 29, 2012 | 2001 Chevrolet Tracker

1 Answer

When i start the truck sometimes it takes a minute to start then i put it in gear and it quits then it takes ten minutes before i can get it to start it also starts up very sluggish like its getting a...


first check fuel filter if clog won't get enough fuel .besides that have your fuel pressure check to make sure fuel pump is working correctly

Dec 02, 2010 | 1998 Dodge Dakota

1 Answer

02 saturn car starts then shuts off within 5 sec put new computer in it cause of step daughter hooking jumper cables up backwards. any ideas. have put on scanner and only found evap codes.


Check security light, if it is flashing , it is set. try this, turn ignition on, don't try to start, let set for ten minutes on. turn off don't take the key out. do this three times ten minutes each, after the third time turn it off, then try to start. This resets the security. If this does not work, then it needs reprogrammed to the new computer you installed. dealer only, about $100.00
Randy

Nov 10, 2010 | 2002 Saturn L-Series

1 Answer

Hi, My friend's rover 825 sterling has suddenly got a imoberlizer problem or should i say thats what we think, he parked his car in his garage overnight after driving it the nite b4 with no problems wot so...


Something you can try, I don't know if it works for your type of vehicle, turn the ignition on, but try to start it, let it set for ten minutes, turn the ignition off, then try to restart it. you may have to do this procedure three times. on for ten off, on for ten off, on for ten off, do not take the key out of the ignition during this procedure. your security has to relearn the key

Nov 09, 2010 | 2007 Sterling 825

3 Answers

How do you star a 98 chavy malibu with tha anti theft light on


Here is what you do. make sure the battery is fully charged cause you dont want it to go dead during this process or it wont work. step down on your parking brake pedal and leave it down. this will keep the headlights off during the process so the battery wont go dead. turn the ignition key like you were going to start the car then leave the key in the on position. you have to leave the key in the on position for ten minutes. during the ten minutes you will see the anti theft or security light flashing or the display in the instrument cluster. when the ten minutes are up the security light will go out. once the light goes out attempt to start the car. if it doesnt start turn the key all the way back to the off position count to three then attempt to start the car then leave the key in the on position another ten minutes till the light stops flashing again. sometimes it takes up to three ten minute cycles to reset the antitheft system. so basically you do the same thing three times leaving the key in the on position for ten minutes each time so it will take approximately thirty minutes. sometimes it will work on the first try though.

Oct 31, 2009 | 1998 Chevrolet Malibu

1 Answer

My car wont start


sounds like security shut down which will start run for second then shut down after several time the security will shut down completely.......you can try what is called the relearn proceedure..this is what you dealer will do...might have to put battery charger on car first... then put key in ignition and turn to the run position do not crank leave it in the on position for ten minutes...... then turn key to the off position then back to the run position again for another ten minutes.....for the last time turn key off then back to run for the last ten minute cycle.... after the final ten minutes is up turn key to off position then attempt to start... let me know

Aug 31, 2009 | 1997 Chevrolet Cavalier

1 Answer

Car died then restarted three times


Run a scan tool to determine problem, if nothing found take the car to the nearest acura service center to check for any recall onthe car.

Jul 09, 2009 | 1997 Acura TL Series

1 Answer

Engine runs rough after about ten minutes /idles really low


Just trowing some suggestions out there, but, I would check the idle air control valve (solenoid) or the throttle position sensor. If they check out then my last guess would be the map sensor or the vaccuum to the map sensor. Hope I was able to help. Best wishes.

Jan 16, 2009 | 1991 Plymouth Laser

Not finding what you are looking for?
2004 Hyundai Santa Fe Logo

326 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hyundai Experts

yadayada
yadayada

Level 3 Expert

74945 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7697 Answers

Are you a Hyundai Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...