Question about Kia Sorento

Open Question

I have a 2033 Kia Sorento 3.5L I have good fuel pressure at rail, I have injector pulse , and spark but I have no tach signal to ECM or tach. I tested coil neg while cranking and there is no signal, no codes in computer

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
johnny5846
  • 379 Answers

SOURCE: no injection pulse

looking at the schematics, well the PCM controls the pulse width to the injectors , BUT , there is a injector coil fuse , its #2 in your kick panel fuse box , a 20 amp , check it , sure hope that fix ya . that would be sweet .

J5

Posted on Jan 15, 2009

Ad
  • 1201 Answers

SOURCE: car has no spark or injector pulse(new ecm,crank sensor)

Check the fuse for the injectors, some vehicles have the injectors and coil running on the same circut, at the same time check the fuse for the ignition.

Posted on Jan 30, 2009

chain saw
  • 94 Answers

SOURCE: 96 audi a6 quattro no spark or injector pulse

I WOULD GO FOR THE ECM AND CHECK WIRING

Posted on Mar 26, 2009

  • 740 Answers

SOURCE: 1993 honda accord 2.2,no injector pulse

This sounds like a main relay problem here is a diagram its located under the dash under steering column its the brownish -orange box in the picture. http://www.tegger.com/hondafaq/mainrelaylocation/7-main_relay_closeup.jpg Good luck and thanks for using FIX YA

Posted on May 15, 2009

  • 10 Answers

SOURCE: 2000 kia sportage. no start no spark no injector pulse.

check both of your fuse panels for a blown fuse. there's 4-5 that control the fuel pump, engine sensors, fuel injectors and such. one of those may be blown and not letting the rest of the system function. one panel is located under hood, and one is under the dash on drivers side. when you take the covers off they have the fuses numbered and tell what they control.

Posted on May 19, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2001 park ave just killed on me wont start


Make sure battery has a full charge and battery connections all good. If it cranks good but won't start, have a helper crank it while you visually check for spark at the plugs. If spark everywhere, use a gage and check proper fuel pressure. Also, check fuel injector pulse. Having fuel in the fuel rail is good as far as it goes. You don't need rpm signal for initial prime.
Any applicable trouble codes?

Dec 08, 2016 | Cars & Trucks

1 Answer

1990 eighty eight 3.8l. Why no fire/pulse to the injectors?


The camshaft sensor may be bad. Check the fuse for the injectors and it is possible the ECM is bad or the injector drivers more specifically are bad in the ECM .

Nov 24, 2015 | Oldsmobile Cars & Trucks

1 Answer

No Injector Pulse


run fault codes as there is a problem sensor in the system. volts at the injector is suspect as the voltage will vary with the fuel requirement.

Jan 05, 2014 | 2005 Mazda Tribute

1 Answer

2004 ford explorer will not start but turns over


For a no start , cranks over ok. be sure you have fuel pressure at the fuel rail first, before checking the injectors. There should be more that 40 psi at the rail... if not .. you might have a fuel pump problem. Even if you have fuel pressure at the fuel rail... the next thing I would check for,,, is spark !! Make sure you have spark at the spark plugs. The order would be... fuel pressure first and then spark , , then injector pulse. !! Then plugged exhaust.... then bad fuel then engine timing. The injectors have power to them all the time. The PCM controls the ground to the injectors. So you would have to monitor the ground side of the injectors. So checking injectors is kinda complicated. Hope this helps you. Good luck.

Mar 03, 2013 | 2004 Ford Explorer

1 Answer

No injector pulse on daihatsu feroza


injector pulse is just controlled by the ecm or computer as some would say,u said u replaced wires? did u have a fire or melt wires? ecm is known to go bad on these,had a few of these trucks back in the day.

Oct 05, 2012 | Cars & Trucks

1 Answer

1991 Buick Century Limited 3.3L, 94,300 miles; stalls under load.


There should be a purple wire with white tracer from ignition module to computer. That wire carries rpm signal to computer, w/o that signal, the computer won't ground the fuel injectors. With the engine cranking, you look for a dc pulse on that wire. If you have a digital multimeter that has a tach--duty cycle or dwell setting, it should react to a dc pulse.
My info on your model year, isn't that great.

Apr 27, 2017 | 1991 Buick Century

2 Answers

My 1995 corvette coupe will not start; it has gasoline, a good battery and turns over good but the engine will not fire; when it does (on occassion) the engine is rough running and will die. The optic...


Check your voltage to the fuel injectors.Also check to see if the fuel injectors need cleaning.First, put your fuel pressure gauge on the shrader valve on the end of the right fuel rail. You should have 35-42 psi and it should hold up for a long time with the ignition turned off. The signal to the injectors is a pulse to ground on the green/blk wire of each injector. The black wire on the injector goes to 12v. Get a noid light at a parts store and see if your injectors are being pulsed during cranking. If not, first check both injector fuses with an ohmeter, they see a lot better than you do. If you have a pulse and fuel pressure and still no starting, you have contaminated gasoline. Engines that start on starting fluid have no gasoline/air mix in the intake due to no gas, or no injecting.Even a cheap $5 multi-meter will work for you.
Check for +12 volts at the black wire of each injector connector or check continunity between all of them and then for +12V.

Check for continunity between the green/black wire and at the ECM connector. Take the connector off the ECM to get at the pin. Also disconnect the neg battery cable before doing this one.

Aug 04, 2017 | 1995 Chevrolet Corvette

3 Answers

1989 Ford Ranger 2.3l. Won't start. Does not have injector pulse. Has spark on all 4 passenger side wires. Has at least some fuel pressure. Timing and belt good. This was a progressive problem in that...


The fuel pressure has to to 35 to 45 psi. And no low fuel pressure will not cause no injector pulse.The veicle sounds more like a idle air control problem why? because as you stated it runs rough when it does start.Get it to start sysle the key you will hear the fuel pump go on cycle it three times then start it up. when the vehicle warms up take the idle air valve out and clean it with carburator cleaner or even brake cleaner you may even want to do the throttle body itself this should help with the hard start up and rough running

Aug 15, 2011 | Ford Ranger Cars & Trucks

1 Answer

The dash gauges all work , fuel pumps are both good , the fuel pumps wont come on and the truck trys to fire when i turn the ignition on but wont , could this be a fuel regulator


did you check the fuel pressure pump on the frame rail for power and ground? have you verified no ignition spark to the spark plugs? have you checked for fire from the coil to the distributor cap? does the check engine light come on when you turn the key on? have you check for injector pulse and power at the fuel injectors? if the fuel pump won't come on and you have no ignition fire and no injector pulse, all of these systems are triggered by the ECM.

Aug 12, 2011 | 1990 Ford F150

4 Answers

On a 89 camaro iroc with tune port injection we are getting fuel and sparks to plugs but the injectors are not pulsing to let fuel spray into cylinders have changed computer?


no not yet i wouldn't change the computr. check to see if there is voltage pos. at one or more of the injector lugs! if not then there is a fuse for them tht may be bad. first check fuse near battery it is in and black plastic cover boted to thefender if it istill mounted and someone didn't nbolt it. then ifthat 25 amp fuse is good checktheones under the dashand also a signif tht fuse nearthe fender is good or not is if the fuel pump is kicking onand the check engine ight work when the key is inthe on position. let me know if you have juice there atthe injectors and if so then iwould check the wire from thecomputer toinjectors if good then iwould say the computerisbad. but let me know and wecanwotk through it.i hve three of these cars i love them. good luck

Sep 27, 2009 | 1989 Chevrolet Camaro

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

26 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kia Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

yadayada
yadayada

Level 3 Expert

76164 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Kia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...