Question about 2006 GMC Envoy

1 Answer

Started in cold weather yesterday. Ran real rough, almost like a motor mount bad. Fan turns by itself when turned with your hand.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • GMC Master
  • 1,199 Answers

If it only happens in cold weather, check your intake manifold bolts for tightness. #5 & #6 by the firewall are easiest to check. Some people will find these not even hand tight = rough running car.

However, if (when cold) your car is vibrating at idle IN GEAR and stopped, this would be a motor mount on Envoys and Trailblazer, very common.


Fan shouldn't turn by itself, you may have a bad fan clutch.

Posted on Mar 14, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What causes the shaking engine and bucking in gear (manual) on semi-cold start?


Check for a possible cold start injector problem or a possible motor or transmission mount that is loose or broken.

Dec 13, 2014 | 2001 Ford Mustang V6

1 Answer

Car stalls accelerate properly


sounds like your alternator is seizing up. take of the serpentine belt and turn the alternator by hand if it sweels or don`t turn, time to replace it. easy fix if thats the case. while your belt is off check the other pullys as well.

Jan 04, 2014 | 2004 Buick Century

1 Answer

My 2000 expedition will not start just clicks under dash but doesnt always first time it happened suddenly came home from store turned motor off got back in 10 mins later just clicked sat for a day or two...


This is a classic sign of a bad starter. When a starter is on its way out, it will usually start when cold. Once it heats up after a short trip or 2, it takes more and more power to get the starter to turn. If the truck will start with a jump when warm, you've confirmed that you have a bad starter.

Apr 27, 2011 | 2000 Ford Expedition

1 Answer

I was driving out 2003 thunderbird yesterday and about 5 minutes after I left home the overheat light came on and then the engine light. It started to run rough so I immediatley went home. The guage of...


u need to take somewhere and have codes scanned (most parts store do this for free) my best guess is it probably a bad coolant temp sensor (u have 2 of them one for gauge and one for computer) one that probably bad is one for computer (should be one with two wires)(one with one wire is for gauge) if temp sensor is reading that the motor hot it will adjust air/fuel ratio for a hot motor but if motor is actually cold it run bad
But to know for sure u need to at least get codes scanned

Jun 28, 2010 | 2003 Ford Thunderbird

1 Answer

Symtoms of a bad timimg chain/belt...but ran real


Problem is not solved but I did change the fuel filter, coil pack,ICM and have proper fuel pressure to the motor. Car starts but dies right away. I cant seem to find out if the fob on the key ring has something to do with stopping the motor. This fob says Radio Key by Secure Key with a number 35077 stamped on this thing.. Still trying to find out what this is and does it effect the cars ability to run

Mar 15, 2010 | 2004 Oldsmobile Alero

2 Answers

Saturn 2000 SC1. Was started this morning ran very rough (thought to be spark plug/wire problem) Would not Accelerate; extremely rough and quit going for a drive around the block. Tried to start it to no...


You need to start with the basics. If all of your cylinders are in good shape, see what is missing, spark or fuel. This will get you started in the right direction. Look at the spark plugs, and see if you have spark at all of them.

Jan 20, 2010 | 2000 Saturn SC

1 Answer

Recurring Mystery Problem in a 1986 Suzuki Alto. (Idle related)


Bad fuel, water in the fuel, dirt in the fuel.

Drain the fuel tank completely.

Pour in a gallon or two of fresh fuel.

See how it goes.

Put some of the old fuel in a glass bottle, hold it up in front of a light and see if you can see any foreign material in it...






Aug 19, 2009 | 1989 Suzuki Swift

1 Answer

COLD START ROUGH IDLE


I hate to be the barer of bad news, but may be the head gasket.

My car started with rough idle. Then very hard to start in cold weather. Next started overheating, but no output from heater. Trickling sound from behind dash board. Overflow bottle overflowing.......

I replaced the water pump, radiator cap, thermostat, coolant, fan belts, power flushed the system. Nothing worked. Some research gave me the answer.

The head gasket leak was allowing exhaust gases to enter the cooling system, displacing the coolant. After use, as engine cools, coolant is sucked back into the system and coolant seeps into the cylinder. This gets worse over time.

First thing you'll notice is the rough idle as the spark plug burns off the coolant in the cylinder. (This is especially true at low temperatures.) If it is the head gasket, the other symptoms will follow as time goes by.

May 17, 2009 | 2002 Nissan Sentra

3 Answers

Car starts hard and runs rough in cold weather, undrivable


The correct spark plugs are very important. Glad to hear you got it fixed good.

Dec 13, 2008 | 1994 Toyota Camry

1 Answer

1992 colt, idles rough


I believe that the oil you are seeing is from the valve covers and drooling down the engine. If oil does go inside the engine cylinders it would usually show up when the motor is first started and seen as blue smoke when running and will slowly go away as the engine warms up!

Most likely you have a bad Idle motor which is mounted on the intake manifold. If the motor can run better with your foot on the gas but dies if removed then it is probably this. This motor is controlled by the OBDII computer which gets it's control signal from the temp sensor which is located either on the radiator or engine block (which could also be bad), if the electric fan (if equipped) turns on then this is not the problem part, but the idle motor is. Another possibility is that you have some bad /cracked vacuum hoses which should be checked for first, before replacing the idle motor.

Nov 30, 2008 | 1991 Plymouth Colt

Not finding what you are looking for?
2006 GMC Envoy Logo

332 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

78267 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...