Question about 1993 Buick Century

1 Answer

Car would not crank, replaced mas air flow sensor. now when i replug in the wire the car cuts off. If i leave it un-pluged the car run rough when i apply the gas.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 504 Answers

Check with code scanner for fault code

Posted on Mar 13, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

1993 Mitsubishi 3000gt when mass air flow sensor is plugged in car wont rev past 2500 rpm car was bought with it unplugged. Replaced the mass air flow sensor an still does it. When its unplugged it runs...


The computer only knows the voltage across what it thinks is the MAS. A bad wiring connector and a bad MAS is all the same to the computer. I would change the harness to the MAS before I spent any time or money on any other problem solving.

Mar 19, 2015 | Mitsubishi 3000GT Cars & Trucks

1 Answer

Running rough-1987 Ford Ranger 2.3 L 4 cyl. Had been running very smoothly until 2 weeks ago when it began backfiring and running rough, especially at low speeds, without my having made any adjustmen


If your car has a mas air flow sensor (usualy located right aroung air filter or in air passage after the air filter) check and clean the sensor. This looks like a small spring on the end of 2 wires. BE CAREFUL not to damage the sensor. I have seen where the sensor gets dirty over time and this can cause a rough idle.

Jul 11, 2012 | Cars & Trucks

1 Answer

1987 GTA trans am TPI. it runs rough and rich. i let it run by itself and now it won't start unless i flutter the fuel pedel and then it still runs really rough and won't rev up. what can i look for?


I would suspect either the tps or mas air flow sensor, you can unplug the mass air flow sensor ( located in air tube to throttle body) see if this helps. The mass airflow sensor may need to be replaced. please rate if this helps

Feb 13, 2010 | Pontiac Trans Cars & Trucks

1 Answer

Dies when under load or on long trips


fuel pump?? try unplugging the mas air flow sensor. its a 3 wire sensor in the air snorkle to the engine. They get dirty and cause it to run rough. Its very common

Jul 28, 2009 | 2003 Chevrolet Suburban 1500

2 Answers

2002 grand prix runs rough,dies service engine


sounds like you have a vacuum leak, check all the vacuum hoses and replace any broken or kinked ones, also check around the intake manifold gasket for leaks. any air leaks after the air flow meter creates 'un-metered' air which inturn will make the car run rough and stall, hope this helps

Apr 04, 2009 | 2002 Pontiac Grand Prix

2 Answers

2001 kia rio engine looses power


try your crank shaft sensor, sounds like the same problem i had , had crank shaft sensor replaced and it drove fine afterwards. maybe go to auto zone or something and see if that code comes up

Dec 30, 2008 | 2001 Kia Rio

1 Answer

2001 xg300 engine runs rough - skips


I had the same car and the same problem.
My case I changed Air Intake
sensor(or call MAS), located right after air filter unit.
Good luck!

Sep 26, 2008 | 2001 Hyundai XG300

Not finding what you are looking for?
1993 Buick Century Logo

Related Topics:

87 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8516 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...