Question about Chevrolet Lumina APV

1 Answer

Quit running on hiway, then wouldn't go faster than 35 mph, today ran fine, seems to be running rich, no engine codes came up, hadit up to 70 mph trans isn't slipping, what does some think?

Posted by on

  • 2 more comments 
  • Jeffrey Beer
    Jeffrey Beer Mar 13, 2011

    1992 chey lumina APV , 3.1 hg 6, throttle body 6cyl

  • Jeffrey Beer
    Jeffrey Beer Mar 13, 2011

    Will get back to you, weather conditions may not co-operate. Thanks Jeff

  • Jeffrey Beer
    Jeffrey Beer Mar 13, 2011

    Front injector coning nicely, other one running like faucet, w/o tear down and rebuild won't know for sure, but looks like diaphram/injector problems,someone told my son his van cam senser went bad, my experience w/cam/crank sensers is usually mechanical failure that cause physical damage. Sunday won't woory about parts until tomorrow. Jeff

  • Jeffrey Beer
    Jeffrey Beer Mar 14, 2011

    Everything looked good w/diaphram, as I told you 1 injector was running like a fawcet, replaced diaphram, no dirt or anything else in fuel ways, unless there is an easy way to take injector apart will need one I believe. Jeff

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 8,589 Answers

Hi, the first thing I would check is the fuel pressure regulator, and then I would check the fuel pressure itself. I will need your model, year, and engine size to be specific about how to troubleshoot, please.

Posted on Mar 13, 2011

  • 2 more comments 
  • Jeffrey Turcotte
    Jeffrey Turcotte Mar 13, 2011

    OK, with TBI, the regulator is in the throttle body. You probably have to take the metering assembly off to check the regulator diaphram, unless you can get under it with a small screwdriver. On the picture below, the regulator diaphram is under the body where the number "8" is pointing. There are 4 screws holding the bowl there, with the diaphram sandwiched in between. You can see what the diaphram looks like here: http://www.autozone.com/autozone/parts/1... See if you can get this apart without damaging the gaskets. Otherwise, you will have to buy that kit for $35 even if you find the diaphram is still good.

    If the van is running rich, it is usually due to a torn diaphram.

    The other thing to do, with the cover off the throttle body, is to look at the injector spray pattern with the engine running. Pull the throttle open and see if the spray pattern is even and the same on both injectors. If not, remove and clean the injectors and the rest of the passages in the throttle body.

    Checking the fuel pressure on a throttle body engine requires a special gage. If you can rent or borrow a gage, check the fuel pressure. The fuel inlet is shown in the second picture below (#38). The pump should be producing at least 12 psi. Please let me know if you have any questions.





  • Jeffrey Turcotte
    Jeffrey Turcotte Mar 13, 2011

    no worries, I'll be here whenever you get the chance.

  • Jeffrey Turcotte
    Jeffrey Turcotte Mar 13, 2011

    cam sensor can also cause poor mileage but not the power symptom you were having.

  • Jeffrey Turcotte
    Jeffrey Turcotte Mar 14, 2011

    Have never taken one apart, but sometimes cleaning will correct poor flow.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Wont go past 35 mph engine run good idles fine but when in gear wont pass 35 mph also abs light on


the car is in limp mode
run the fault codes to find the fault
the indications is the abs circuit / brake problem

Jan 07, 2016 | Cars & Trucks

1 Answer

2001 Sebring 2.4 starts but will not stay running


Hi Ericiarson09.
Check your Crankshaft Position Sensor connector to make sure it is clean and tight. Also check the two screws that hold the sensor to the front of the motor to make sure they are snug and the screw holes are not damaged or broken. This would cause your issue and poor gas mileage. Hope this helps.

May 20, 2017 | 1999 Chrysler Sebring

1 Answer

While driving something made a popping noise and truck started shaking


sounds like a bad u joint or swing bearing or just something loose in thr drive train

Nov 22, 2011 | 1992 Dodge Dakota

2 Answers

Engine seemed to skip at about 70 mph and service engine light came on. Then seemed to skip several more times at different speeds. Ran fine. Just continued to skip as we drove.


hi the engine is not skipping the problem is the engine is miss firing
that is caused by a bad .spark plug or -wires-or coil pack - when was the last time the
car had a tune up . check spark plug connections

Jun 12, 2011 | 2005 Nissan Altima

1 Answer

Hi ! already bough 2001 gls jetta whit 79000 miles and the EPC light comes on and off I drove the car on a hill and the freeway and the car ran faster but the light come on and then goes off, today i was...


I wouldn't trust changing the MAF sensor out first. The make a cleaner that you can spray to clean the MAF. If this gets a little dirt on it, the air flow will be scattered causing the vehicle to ****, shut off, not start, etc. These are very sensitive and it REALLY don't take but your hand about 1 foot away from the air flow of this sensor, and your engine shuts down. Clean it first then go to option B...

Apr 18, 2011 | Volkswagen Jetta Cars & Trucks

1 Answer

CAR RUNS FINE BUT WHEN I DRIVE FASTER THEN 70 MPH THE CHECK TRANSNISSION LIGHT TURNS ON THE TRANS HAS A BANGING SOUND. IT GIVES A INCORRECT GEAR CODE. PLZ HELP


Don't drive faster than 70Mph! That is over 115 feet per second! Anyway, it's 4WD, correct? Check the fluids in the tranmission and transfer case. You transmission may need to be serviced. Limit your speed to 50-60 MPH and don't shift hard...with a lot of RPM's, when taking off and going through 1st 2nd and 3rd. Drive gently until you can have the transmission serviced.

Jan 22, 2011 | 2002 Isuzu Rodeo

1 Answer

Service engine light -- on then off, then on, then off


If it's the check engine light, I'd look at the radiator for partial internal obstruction...In colder temps or running at speed it tends to run a bit cooler. RPM change may be computer attempting to compensate for this. I'm not a KIA expert, but this applies to any vehicle. Also check your coolant level. If it's low it will also act this way.

Mar 31, 2009 | 2003 Kia Sorento

1 Answer

Service engine light -- on then off, then on, then off


Go to Advance Auot parts store or Auto Zone store they will scan it for free and take gas work out of it or buy a scanner they are cheap now very very good investment

May 04, 2017 | 2002 Suzuki XL-7

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

39 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76848 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...